summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <michael@xmw.de>2014-08-26 21:52:06 +0200
committerMichael Weber <michael@xmw.de>2014-08-26 21:52:06 +0200
commita92172782de87a0351053690bd7ef8920d5ce94e (patch)
treeec0e747eda5cf19446511c83f51596eb9540fa85 /dev-games
parent[games-action/rochard] bump (diff)
downloadgamerlay-a92172782de87a0351053690bd7ef8920d5ce94e.tar.gz
gamerlay-a92172782de87a0351053690bd7ef8920d5ce94e.tar.bz2
gamerlay-a92172782de87a0351053690bd7ef8920d5ce94e.zip
Fix freetype plugin (needed for newer flightgear canvas)
Package-Manager: portage-2.2.12 Manifest-Sign-Key: 62EEF090
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/openscenegraph/Manifest12
-rw-r--r--dev-games/openscenegraph/files/openscenegraph-3.2.0-freetype2.patch39
-rw-r--r--dev-games/openscenegraph/openscenegraph-3.2.0-r1.ebuild148
3 files changed, 199 insertions, 0 deletions
diff --git a/dev-games/openscenegraph/Manifest b/dev-games/openscenegraph/Manifest
index 4fd3fb7..b24adcc 100644
--- a/dev-games/openscenegraph/Manifest
+++ b/dev-games/openscenegraph/Manifest
@@ -1 +1,13 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA256
+
DIST OpenSceneGraph-3.2.0.zip 7195748 SHA256 ceca56e58e9ba245d5f9d0661352ddf405a7cb105341a122c5541b69c0ce032e SHA512 9a270f2a0b5f8b0527fb99668da8771073c6469c5a403371a786da47df0443f6a5776716942f2318e7e58d9a41417b5dc5f4ae4a123cfcc72840e3d2999322bd WHIRLPOOL f127956c08364e910d96cba7dd9e444d59d3b7b7b1464cf28218cbd42a461fb801a5d7b2cc65e8992b499618748f9ef30b6aa9a0f41fae4d1be27b36ecaba2cb
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2
+
+iL4EAREIAGYFAlP8QWpfFIAAAAAALgAoaXNzdWVyLWZwckBub3RhdGlvbnMub3Bl
+bnBncC5maWZ0aGhvcnNlbWFuLm5ldDY3QjA4MzdGODg1NUMxMjIzNUQ0MDgxNzky
+N0FERDBDNjJFRUYwOTAACgkQknrdDGLu8JB5VgD/UCBACE3pA4NW1BDDq1Q5o+BF
+zP5DytAp7fsldWtyzCEBAI7ctG8iN43H92syJS0C2VD7JMd87TJzer8zA5OAhUFd
+=Kw7I
+-----END PGP SIGNATURE-----
diff --git a/dev-games/openscenegraph/files/openscenegraph-3.2.0-freetype2.patch b/dev-games/openscenegraph/files/openscenegraph-3.2.0-freetype2.patch
new file mode 100644
index 0000000..0fffb25
--- /dev/null
+++ b/dev-games/openscenegraph/files/openscenegraph-3.2.0-freetype2.patch
@@ -0,0 +1,39 @@
+--- OpenSceneGraph-3.2.0/src/osgPlugins/freetype/FreeTypeFont.cpp
++++ OpenSceneGraph-3.2.0/src/osgPlugins/freetype/FreeTypeFont.cpp
+@@ -14,8 +14,8 @@
+ #include "FreeTypeFont.h"
+ #include "FreeTypeLibrary.h"
+
+-#include <freetype/ftoutln.h>
+-#include <freetype/ftbbox.h>
++#include <freetype2/ftoutln.h>
++#include <freetype2/ftbbox.h>
+
+ #include <osg/Notify>
+ #include <osg/io_utils>
+--- OpenSceneGraph-3.2.0/CMakeModules/FindFreeType.cmake
++++ OpenSceneGraph-3.2.0/CMakeModules/FindFreeType.cmake
+@@ -48,19 +48,19 @@
+ /opt/csw
+ /opt
+ /usr/freeware
+- PATH_SUFFIXES include
++ PATH_SUFFIXES include include/freetype2
+ )
+
+-FIND_PATH(FREETYPE_INCLUDE_DIR_freetype2 freetype/config/ftheader.h
++FIND_PATH(FREETYPE_INCLUDE_DIR_freetype2 config/ftheader.h
+ $ENV{FREETYPE_DIR}/include/freetype2
+ NO_DEFAULT_PATH
+ )
+-FIND_PATH(FREETYPE_INCLUDE_DIR_freetype2 freetype/config/ftheader.h
++FIND_PATH(FREETYPE_INCLUDE_DIR_freetype2 config/ftheader.h
+ PATHS ${CMAKE_PREFIX_PATH} # Unofficial: We are proposing this.
+ NO_DEFAULT_PATH
+ PATH_SUFFIXES include/freetype2
+ )
+-FIND_PATH(FREETYPE_INCLUDE_DIR_freetype2 freetype/config/ftheader.h
++FIND_PATH(FREETYPE_INCLUDE_DIR_freetype2 config/ftheader.h
+ /usr/local/include/freetype2
+ /usr/include/freetype2
+ /usr/local/X11R6/include/freetype2
diff --git a/dev-games/openscenegraph/openscenegraph-3.2.0-r1.ebuild b/dev-games/openscenegraph/openscenegraph-3.2.0-r1.ebuild
new file mode 100644
index 0000000..7cbe227
--- /dev/null
+++ b/dev-games/openscenegraph/openscenegraph-3.2.0-r1.ebuild
@@ -0,0 +1,148 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit eutils cmake-utils flag-o-matic wxwidgets
+
+MY_PN="OpenSceneGraph"
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Open source high performance 3D graphics toolkit"
+HOMEPAGE="http://www.openscenegraph.org/projects/osg/"
+SRC_URI="http://www.openscenegraph.org/downloads/developer_releases/${MY_P}.zip"
+
+LICENSE="wxWinLL-3 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="curl debug doc examples ffmpeg fltk fox gdal gif glut gtk itk jpeg jpeg2k
+openexr openinventor osgapps pdf png qt4 sdl static-libs svg tiff truetype vnc
+wxwidgets xine xrandr zlib"
+
+# NOTE: OpenAL (support missing)
+# TODO: COLLADA, FBX, OpenVRML, Performer, DCMTK
+RDEPEND="
+ x11-libs/libSM
+ x11-libs/libXext
+ virtual/glu
+ virtual/opengl
+ curl? ( net-misc/curl )
+ examples? (
+ fltk? ( x11-libs/fltk:1[opengl] )
+ fox? ( x11-libs/fox:1.6[opengl] )
+ glut? ( media-libs/freeglut )
+ gtk? ( x11-libs/gtkglext )
+ qt4? (
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qtopengl:4
+ )
+ sdl? ( media-libs/libsdl )
+ wxwidgets? ( x11-libs/wxGTK[opengl,X] )
+ )
+ ffmpeg? ( virtual/ffmpeg )
+ gdal? ( sci-libs/gdal )
+ gif? ( media-libs/giflib )
+ itk? ( dev-tcltk/itk )
+ jpeg? ( virtual/jpeg )
+ jpeg2k? ( media-libs/jasper )
+ openexr? (
+ media-libs/ilmbase
+ media-libs/openexr
+ )
+ openinventor? (
+ || (
+ media-libs/coin
+ media-libs/openinventor
+ )
+ )
+ pdf? ( app-text/poppler[cairo] )
+ png? ( media-libs/libpng:0 )
+ svg? (
+ gnome-base/librsvg
+ x11-libs/cairo
+ )
+ tiff? ( media-libs/tiff:0 )
+ truetype? ( media-libs/freetype:2 )
+ vnc? ( net-libs/libvncserver )
+ xine? ( media-libs/xine-lib )
+ xrandr? ( x11-libs/libXrandr )
+ zlib? ( sys-libs/zlib )
+"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ virtual/pkgconfig
+ x11-proto/xextproto
+ doc? ( app-doc/doxygen )
+ xrandr? ( x11-proto/randrproto )
+"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS=(AUTHORS.txt ChangeLog NEWS.txt)
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.2.0-cmake.patch
+ "${FILESDIR}"/${PN}-3.2.0-ffmpeg.patch
+ "${FILESDIR}"/${PN}-3.2.0-freetype2.patch
+)
+
+src_configure() {
+ if use examples && use wxwidgets; then
+ WX_GTK_VER="2.8"
+ need-wxwidgets unicode
+ fi
+
+ # Needed by FFmpeg
+ append-cppflags -D__STDC_CONSTANT_MACROS
+
+ mycmakeargs=(
+ -DWITH_OpenAL=OFF # Commented out in buildsystem
+ -DWITH_NVTT=OFF #broken, just to be sure
+ -DGENTOO_DOCDIR="/usr/share/doc/${PF}"
+ $(cmake-utils_use_with curl)
+ $(cmake-utils_use_build doc DOCUMENTATION)
+ $(cmake-utils_use_build osgapps OSG_APPLICATIONS)
+ $(cmake-utils_use_build examples OSG_EXAMPLES)
+ $(cmake-utils_use_with ffmpeg FFmpeg)
+ $(cmake-utils_use_with fltk)
+ $(cmake-utils_use_with fox)
+ $(cmake-utils_use_with gdal)
+ $(cmake-utils_use_with gif GIFLIB)
+ $(cmake-utils_use_with glut)
+ $(cmake-utils_use_with gtk GtkGl)
+ $(cmake-utils_use_with itk)
+ $(cmake-utils_use_with jpeg)
+ $(cmake-utils_use_with jpeg2k Jasper)
+ $(cmake-utils_use_with openexr OpenEXR)
+ $(cmake-utils_use_with openinventor Inventor)
+ $(cmake-utils_use_with pdf Poppler-glib)
+ $(cmake-utils_use_with png)
+ $(cmake-utils_use_with qt4)
+ $(cmake-utils_use !static-libs DYNAMIC_OPENSCENEGRAPH)
+ $(cmake-utils_use_with sdl)
+ $(cmake-utils_use_with svg rsvg)
+ $(cmake-utils_use_with tiff)
+ $(cmake-utils_use_with truetype FreeType)
+ $(cmake-utils_use_with vnc LibVNCServer)
+ $(cmake-utils_use_with wxwidgets wxWidgets)
+ $(cmake-utils_use_with xine)
+ $(cmake-utils_use xrandr OSGVIEWER_USE_XRANDR)
+ $(cmake-utils_use_with zlib)
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ use doc && cmake-utils_src_compile doc_openscenegraph doc_openthreads
+}
+
+pkg_postinst() {
+ if has_version 'dev-games/simgear'; then
+ ewarn "dev-games/simgear has been detected and may need to be rebuilt now."
+ ewarn "Please run the following:"
+ ewarn " # emerge -1 dev-games/simgear"
+ fi
+}