summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2020-02-29 01:31:46 +0300
committerAzamat H. Hackimov <azamat.hackimov@gmail.com>2020-02-29 01:31:46 +0300
commit67ffad92b12cf2257337484def729fbce1ec5bf2 (patch)
tree5dcf122e3461cd1edc74a6228fe06b03174e300b /games-arcade
parentgames-arcade/gianasreturn: update to 1.10 (diff)
downloadgamerlay-67ffad92b12cf2257337484def729fbce1ec5bf2.tar.gz
gamerlay-67ffad92b12cf2257337484def729fbce1ec5bf2.tar.bz2
gamerlay-67ffad92b12cf2257337484def729fbce1ec5bf2.zip
games-arcade/funkysmugglers: update package
Migrate from deprecated EAPI/eclass. Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com>
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/funkysmugglers/funkysmugglers-20130613.ebuild54
1 files changed, 20 insertions, 34 deletions
diff --git a/games-arcade/funkysmugglers/funkysmugglers-20130613.ebuild b/games-arcade/funkysmugglers/funkysmugglers-20130613.ebuild
index 8b34b55..7e55591 100644
--- a/games-arcade/funkysmugglers/funkysmugglers-20130613.ebuild
+++ b/games-arcade/funkysmugglers/funkysmugglers-20130613.ebuild
@@ -1,50 +1,39 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-EAPI="5"
+EAPI=7
-inherit unpacker games
+inherit desktop eutils multilib-minimal unpacker
-DESCRIPTION="Enjoy a funky 70s-style soundtrack while keeping the airport safe from hammers, scissors, and other illegal goods."
+DESCRIPTION="Keeping the airport safe from hammers, scissors, and other illegal goods."
HOMEPAGE="http://www.11bitstudios.com/games/9/funky-smugglers"
# Is it non-HiB distfile?
SRC_URI="FunkySmugglers-lin_1371139237-Installer"
RESTRICT="fetch strip"
-LICENSE="as-is"
+LICENSE="all-rights-reserved"
SLOT="0"
KEYWORDS="-* ~amd64 ~x86"
IUSE="multilib"
-DEPEND=""
+DEPEND="app-arch/unzip"
RDEPEND="
- x86? (
- media-libs/openal
- x11-libs/libdrm
- x11-libs/libX11
- x11-libs/libXau
- x11-libs/libxcb
- x11-libs/libXdamage
- x11-libs/libXdmcp
- x11-libs/libXext
- x11-libs/libXfixes
- x11-libs/libXxf86vm
- )
- amd64? (
- app-emulation/emul-linux-x86-xlibs
- app-emulation/emul-linux-x86-opengl
- app-emulation/emul-linux-x86-sdl
- )
+ media-libs/openal[${MULTILIB_USEDEP}]
+ x11-libs/libdrm[${MULTILIB_USEDEP}]
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXau[${MULTILIB_USEDEP}]
+ x11-libs/libxcb[${MULTILIB_USEDEP}]
+ x11-libs/libXdamage[${MULTILIB_USEDEP}]
+ x11-libs/libXdmcp[${MULTILIB_USEDEP}]
+ x11-libs/libXext[${MULTILIB_USEDEP}]
+ x11-libs/libXfixes[${MULTILIB_USEDEP}]
+ x11-libs/libXxf86vm[${MULTILIB_USEDEP}]
virtual/opengl
- app-arch/unzip
"
-REQUIRED_USE="amd64? ( multilib )"
-
-S="${WORKDIR}"
+S="${WORKDIR}/data"
src_unpack() {
- unpack_zip "${A}"
+ unpack_zip ${A}
}
pkg_nofetch() {
@@ -54,12 +43,11 @@ pkg_nofetch() {
}
src_install() {
- cd "${S}/data"
- local dir="${GAMES_PREFIX_OPT}/${PN}"
+ local dir="/opt/${PN}"
newicon "icon.png" "${PN}.png"
make_desktop_entry "${PN}" "FunkySmugglers" "${PN}"
- games_make_wrapper "${PN}" "./FunkySmugglers" "${dir}"
+ make_wrapper "${PN}" "./FunkySmugglers" "${dir}"
dodoc README
exeinto "${dir}"
doexe "FunkySmugglers"
@@ -73,6 +61,4 @@ src_install() {
"Copyright license Xpm"
insinto "${dir}"
doins -r .
-
- prepgamesdirs
}