summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Kicherer <dev@kicherer.org>2013-08-30 12:54:42 +0200
committerMario Kicherer <dev@kicherer.org>2013-08-30 12:54:46 +0200
commitd20319d47bd2c150b69c70ba5cf661159c474ab5 (patch)
treed8d90fbd42f10ef2161e52641920426602c00bf8 /games-util
parent[media-libs/sdl, games-*] Fix for bug #482850 (diff)
downloadgamerlay-d20319d47bd2c150b69c70ba5cf661159c474ab5.tar.gz
gamerlay-d20319d47bd2c150b69c70ba5cf661159c474ab5.tar.bz2
gamerlay-d20319d47bd2c150b69c70ba5cf661159c474ab5.zip
[games-util/steam-launcher] new version 1.0.0.40
Diffstat (limited to 'games-util')
-rw-r--r--games-util/steam-launcher/Manifest3
-rw-r--r--games-util/steam-launcher/steam-launcher-1.0.0.40.ebuild108
2 files changed, 110 insertions, 1 deletions
diff --git a/games-util/steam-launcher/Manifest b/games-util/steam-launcher/Manifest
index 778a31f..2f9f82f 100644
--- a/games-util/steam-launcher/Manifest
+++ b/games-util/steam-launcher/Manifest
@@ -1 +1,2 @@
-DIST steam_1.0.0.39.tar.gz 2521856 SHA256 2a5530a35bb9e21e3fdede7fa740285d7c71c8c482bffb27b19a83215c7c83a9 SHA512 40e0d2b727449d02b429bc6bddee047cff74fe0adbb753cb94868145c72866b79767b6b54ff71628bb1633cfedb6a35a5361ef137b1e8bbc91f724e281559154 WHIRLPOOL 162c0ec3ffa6f9ba81c307bc292ceb2cdd3116292b92e71bd272f07711699d40786e8a60e2cdc50db8b6a09d5ca7faa76912ff16da06266409d0d6a8fc16c848
+DIST steam_1.0.0.39.tar.gz 2623602 SHA256 80c20736fcc98c53b7e2aa2f1369368ee2cad70fb8351ed9fc11d29f2a3b153c SHA512 732a2c199f8bbb47b61c115fac6d81a9ce1530a34ed5c293b197f303ef75e1763c6c9bfe692be80e7822673a6fb1ad4fc73c61d0bf788b36e70f743c1667bf66 WHIRLPOOL 00eb39a0e58f118961b222871608c202e273cf7525c19d6f3f881da79f24f30a769378d6f24cd558ab9939f1114ed00608314a08c9e11795d583357b5e98debb
+DIST steam_1.0.0.40.tar.gz 2765887 SHA256 fa72789394d4b8f235f3df81de741732462366d0a712586b7c5af23418ed00d7 SHA512 00cca901f8894c9a8cd8e8dfd4f352e6a62c0b4404fe5ec1721b5423e6ac12b037672335810af815df6d6037aa75c9eb1c102f314615d2ee1c60411e40103614 WHIRLPOOL 3a425827dd5fcc7fb0fa7c5bdd814831e768ab731c1cb25bf8bf1b69591df55c075de102add06a4cb0182dde5ee797dca052fc7497dc25d854daa4a0be28435f
diff --git a/games-util/steam-launcher/steam-launcher-1.0.0.40.ebuild b/games-util/steam-launcher/steam-launcher-1.0.0.40.ebuild
new file mode 100644
index 0000000..5e5487d
--- /dev/null
+++ b/games-util/steam-launcher/steam-launcher-1.0.0.40.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+# Please report bugs/suggestions on: https://github.com/anyc/steam-overlay
+# or come to #gentoo-gamerlay in freenode IRC
+
+inherit eutils gnome2-utils fdo-mime
+
+DESCRIPTION="Installer, launcher and supplementary files for Valve's Steam client"
+HOMEPAGE="http://steampowered.com"
+SRC_URI="http://repo.steampowered.com/steam/archive/precise/steam_${PV}.tar.gz"
+
+KEYWORDS="-* ~amd64 ~x86"
+LICENSE="ValveSteamLicense"
+
+RESTRICT="bindist mirror"
+SLOT="0"
+
+RDEPEND="
+ app-arch/xz-utils
+ app-shells/bash
+ net-misc/curl
+ || (
+ gnome-extra/zenity
+ x11-terms/xterm
+ )
+
+ amd64? (
+ >=app-emulation/emul-linux-x86-baselibs-20121028
+ || (
+ >=app-emulation/emul-linux-x86-xlibs-20121028
+ (
+ x11-libs/libX11[abi_x86_32]
+ x11-libs/libXau[abi_x86_32]
+ x11-libs/libxcb[abi_x86_32]
+ x11-libs/libXdmcp[abi_x86_32]
+ )
+ )
+ >=sys-devel/gcc-4.6.0[multilib]
+ >=sys-libs/glibc-2.15[multilib]
+ )
+ x86? (
+ >=sys-devel/gcc-4.6.0
+ >=sys-libs/glibc-2.15
+ >=x11-libs/libX11-1.5
+ x11-libs/libXau
+ x11-libs/libxcb
+ x11-libs/libXdmcp
+ )"
+
+S=${WORKDIR}/steam/
+
+src_prepare() {
+ # we use our ebuild functions to install the files
+ rm Makefile
+}
+
+src_install() {
+ dobin steam
+
+ insinto /usr/lib/steam/
+ doins bootstraplinux_ubuntu12_32.tar.xz
+
+ dodoc debian/changelog steam_install_agreement.txt
+ doman steam.6
+
+ domenu steam.desktop
+
+ cd icons/
+ for s in * ; do
+ doicon -s ${s} ${s}/steam.png
+ done
+
+ # tgz archive contains no separate pixmap, see #38
+ insinto /usr/share/pixmaps/
+ newins 48/steam.png steam_tray_mono.png
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+
+ elog "Execute /usr/bin/steam to download and install the actual"
+ elog "client into your home folder. After installation, the script"
+ elog "also starts the client from your home folder."
+ elog ""
+
+ if ! has_version "gnome-extra/zenity"; then
+ ewarn "Valve does not provide a xterm fallback for all calls of zenity."
+ ewarn "Please install gnome-extra/zenity for full support."
+ ewarn ""
+ fi
+
+ ewarn "The steam client and the games are _not_ controlled by portage."
+ ewarn "Updates are handled by the client itself."
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+}