aboutsummaryrefslogtreecommitdiff
path: root/10.5.0
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-11-19 23:50:42 +0000
committerSam James <sam@gentoo.org>2022-11-20 00:25:41 +0000
commit6afd754068920d41f4115c28c6c02e964fa5e38c (patch)
treee15ee1086db2985c3cdd5964af42619694becae8 /10.5.0
parentmake-tarball.sh: tweak again for 13 (diff)
downloadgcc-patches-6afd754068920d41f4115c28c6c02e964fa5e38c.tar.gz
gcc-patches-6afd754068920d41f4115c28c6c02e964fa5e38c.tar.bz2
gcc-patches-6afd754068920d41f4115c28c6c02e964fa5e38c.zip
10.5.0: add Clang 16 patches (-Wimplicit-function-declaration, -Wimplicit-int, etc)
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to '10.5.0')
-rw-r--r--10.5.0/gentoo/76_all_configure-c89.patch141
-rw-r--r--10.5.0/gentoo/README.history3
2 files changed, 144 insertions, 0 deletions
diff --git a/10.5.0/gentoo/76_all_configure-c89.patch b/10.5.0/gentoo/76_all_configure-c89.patch
new file mode 100644
index 0000000..9d65cb2
--- /dev/null
+++ b/10.5.0/gentoo/76_all_configure-c89.patch
@@ -0,0 +1,141 @@
+https://gcc.gnu.org/git/?p=gcc.git;a=commit;h=6be2672e4ee41c566a9e072088cccca263bab5f7
+https://gcc.gnu.org/git/?p=gcc.git;a=commit;h=885b6660c17fb91980b5682514ef54668e544b02
+
+From 942a325c81136138c4c199f8ab3e89a1945c3790 Mon Sep 17 00:00:00 2001
+From: Florian Weimer <fweimer@redhat.com>
+Date: Tue, 18 Oct 2022 16:58:48 +0200
+Subject: [PATCH 1/2] libsanitizer: Avoid implicit function declaration in
+ configure test
+
+libsanitizer/
+
+ * configure.ac (sanitizer_supported): Include <unistd.h> for
+ syscall prototype.
+ * configure: Regenerate.
+
+From 9a43d0e406c05d2d7136721443192bb6588c3113 Mon Sep 17 00:00:00 2001
+From: Florian Weimer <fweimer@redhat.com>
+Date: Tue, 18 Oct 2022 16:58:48 +0200
+Subject: [PATCH 2/2] libiberty: Fix C89-isms in configure tests
+
+libiberty/
+
+ * acinclude.m4 (ac_cv_func_strncmp_works): Add missing
+ int return type and parameter list to the definition of main.
+ Include <stdlib.h> and <string.h> for prototypes.
+ (ac_cv_c_stack_direction): Add missing
+ int return type and parameter list to the definitions of
+ main, find_stack_direction. Include <stdlib.h> for exit
+ prototype.
+ * configure: Regenerate.
+
+--- a/libiberty/aclocal.m4
++++ b/libiberty/aclocal.m4
+@@ -16,6 +16,8 @@ AC_CACHE_CHECK([for working strncmp], ac_cv_func_strncmp_works,
+ [AC_TRY_RUN([
+ /* Test by Jim Wilson and Kaveh Ghazi.
+ Check whether strncmp reads past the end of its string parameters. */
++#include <stdlib.h>
++#include <string.h>
+ #include <sys/types.h>
+
+ #ifdef HAVE_FCNTL_H
+@@ -43,7 +45,8 @@ AC_CACHE_CHECK([for working strncmp], ac_cv_func_strncmp_works,
+
+ #define MAP_LEN 0x10000
+
+-main ()
++int
++main (void)
+ {
+ #if defined(HAVE_MMAP) || defined(HAVE_MMAP_ANYWHERE)
+ char *p;
+@@ -149,7 +152,10 @@ if test $ac_cv_os_cray = yes; then
+ fi
+
+ AC_CACHE_CHECK(stack direction for C alloca, ac_cv_c_stack_direction,
+-[AC_TRY_RUN([find_stack_direction ()
++[AC_TRY_RUN([#include <stdlib.h>
++
++int
++find_stack_direction (void)
+ {
+ static char *addr = 0;
+ auto char dummy;
+@@ -161,7 +167,9 @@ AC_CACHE_CHECK(stack direction for C alloca, ac_cv_c_stack_direction,
+ else
+ return (&dummy > addr) ? 1 : -1;
+ }
+-main ()
++
++int
++main (void)
+ {
+ exit (find_stack_direction() < 0);
+ }],
+--- a/libiberty/configure
++++ b/libiberty/configure
+@@ -6718,7 +6718,10 @@ else
+ else
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+ /* end confdefs.h. */
+-find_stack_direction ()
++#include <stdlib.h>
++
++int
++find_stack_direction (void)
+ {
+ static char *addr = 0;
+ auto char dummy;
+@@ -6730,7 +6733,9 @@ find_stack_direction ()
+ else
+ return (&dummy > addr) ? 1 : -1;
+ }
+-main ()
++
++int
++main (void)
+ {
+ exit (find_stack_direction() < 0);
+ }
+@@ -7555,6 +7560,8 @@ else
+
+ /* Test by Jim Wilson and Kaveh Ghazi.
+ Check whether strncmp reads past the end of its string parameters. */
++#include <stdlib.h>
++#include <string.h>
+ #include <sys/types.h>
+
+ #ifdef HAVE_FCNTL_H
+@@ -7582,7 +7589,8 @@ else
+
+ #define MAP_LEN 0x10000
+
+-main ()
++int
++main (void)
+ {
+ #if defined(HAVE_MMAP) || defined(HAVE_MMAP_ANYWHERE)
+ char *p;
+--- a/libsanitizer/configure
++++ b/libsanitizer/configure
+@@ -16029,6 +16029,7 @@ case "$target" in
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+ /* end confdefs.h. */
+ #include <sys/syscall.h>
++#include <unistd.h>
+ int
+ main ()
+ {
+--- a/libsanitizer/configure.ac
++++ b/libsanitizer/configure.ac
+@@ -155,7 +155,8 @@ case "$target" in
+ *-*-linux*)
+ # Some old Linux distributions miss required syscalls.
+ sanitizer_supported=no
+- AC_TRY_COMPILE([#include <sys/syscall.h>],[
++ AC_TRY_COMPILE([#include <sys/syscall.h>
++#include <unistd.h>],[
+ syscall (__NR_gettid);
+ syscall (__NR_futex);
+ syscall (__NR_exit_group);
diff --git a/10.5.0/gentoo/README.history b/10.5.0/gentoo/README.history
index 19b1d3a..41e961c 100644
--- a/10.5.0/gentoo/README.history
+++ b/10.5.0/gentoo/README.history
@@ -1,3 +1,6 @@
+1 19 Nov 2022
+ + 76_all_configure-c89.patch
+
0 22 Aug 2022
+ 01_all_default-fortify-source.patch
+ 02_all_default-warn-format-security.patch