aboutsummaryrefslogtreecommitdiff
path: root/8.5.0
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-02-08 01:08:06 +0000
committerSam James <sam@gentoo.org>2023-02-08 01:08:14 +0000
commitbddbb0244be56ccdd3827ee418c651e59f7a0c11 (patch)
tree8212e898db01afa13a8ffa11d3830cf952551af7 /8.5.0
parent12.2.0: drop 76_all_all_PR107461_cxx_equivalence_non_dependent_calls.patch (u... (diff)
downloadgcc-patches-bddbb0244be56ccdd3827ee418c651e59f7a0c11.tar.gz
gcc-patches-bddbb0244be56ccdd3827ee418c651e59f7a0c11.tar.bz2
gcc-patches-bddbb0244be56ccdd3827ee418c651e59f7a0c11.zip
8.5.0: add 33_all_msgfmt-libstdc++-link.patch
Bug: https://bugs.gentoo.org/892816 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to '8.5.0')
-rw-r--r--8.5.0/gentoo/33_all_msgfmt-libstdc++-link.patch39
-rw-r--r--8.5.0/gentoo/README.history3
2 files changed, 41 insertions, 1 deletions
diff --git a/8.5.0/gentoo/33_all_msgfmt-libstdc++-link.patch b/8.5.0/gentoo/33_all_msgfmt-libstdc++-link.patch
new file mode 100644
index 0000000..0d2f113
--- /dev/null
+++ b/8.5.0/gentoo/33_all_msgfmt-libstdc++-link.patch
@@ -0,0 +1,39 @@
+Ensure that msgfmt doesn't encounter problems during gcc bootstrapping.
+
+Solves error messages like the following:
+
+msgfmt: /var/tmp/portage/sys-devel/gcc-4.1.2/work/build/./gcc/libgcc_s.so.1: version `GCC_4.2.0' not found (required by /usr/lib/gcc/x86_64-pc-linux-gnu/4.5.3/libstdc++.so.6)
+
+The libgcc_s.so used during build doesn't satisfy the needs of the
+libstdc++.so that msgfmt is linked against. On the other hand, msgfmt
+is used as a stand-alone application here, and what library it uses
+behind the scenes is of no concern to the gcc build process.
+Therefore, simply invoking it "as usual", i.e. without any special
+library path, will make it work as expected here.
+
+2011-09-19 Martin von Gagern
+
+References:
+https://bugs.gentoo.org/372377
+https://bugs.gentoo.org/295480
+https://bugs.gentoo.org/843119
+--- a/libstdc++-v3/po/Makefile.am
++++ b/libstdc++-v3/po/Makefile.am
+@@ -39,6 +39,7 @@ MSGFMT = msgfmt
+ EXTRA_DIST = string_literals.cc POTFILES.in $(PACKAGE).pot $(LOCALE_IN)
+
+ .po.mo:
++ env --unset=LD_LIBRARY_PATH \
+ $(MSGFMT) -o $@ $<
+
+ all-local: all-local-$(USE_NLS)
+--- a/libstdc++-v3/po/Makefile.in
++++ b/libstdc++-v3/po/Makefile.in
+@@ -419,6 +419,7 @@ uninstall-am: uninstall-info-am
+
+
+ .po.mo:
++ env --unset=LD_LIBRARY_PATH \
+ $(MSGFMT) -o $@ $<
+
+ all-local: all-local-$(USE_NLS)
diff --git a/8.5.0/gentoo/README.history b/8.5.0/gentoo/README.history
index b2d4c99..1466fd7 100644
--- a/8.5.0/gentoo/README.history
+++ b/8.5.0/gentoo/README.history
@@ -1,6 +1,7 @@
-3 TODO
+4 08 Feb 2023
+ 31_all_powerpcspe-pie-crt.patch
+ 32_all_powerpcspe-march-PLATFORM.patch
+ + 33_all_msgfmt-libstdc++-link.patch
2 05 July 2021
+ 30_all_remove-cyclades.patch