aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2024-11-24 07:34:47 -0800
committerBen Kohler <bkohler@gentoo.org>2024-11-25 11:17:56 -0600
commit5e6e0b98c281d149905774b60803435a22cf39a5 (patch)
tree6216efeb326ff1e6be2861f960c5581f34d8e138
parentpatches/kmod: add missing musl patch (diff)
downloadgenkernel-5e6e0b98c281d149905774b60803435a22cf39a5.tar.gz
genkernel-5e6e0b98c281d149905774b60803435a22cf39a5.tar.bz2
genkernel-5e6e0b98c281d149905774b60803435a22cf39a5.zip
Bump eudev to v3.2.14HEADmaster
Update to a version that builds with musl. Signed-off-by: orbea <orbea@riseup.net> Closes: https://github.com/gentoo/genkernel/pull/62 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
-rw-r--r--patches/eudev/3.2.14/eudev-3.2.14-static.patch (renamed from patches/eudev/3.2.10/eudev-3.2.10-static.patch)17
1 files changed, 8 insertions, 9 deletions
diff --git a/patches/eudev/3.2.10/eudev-3.2.10-static.patch b/patches/eudev/3.2.14/eudev-3.2.14-static.patch
index fc36b54..88bc1e1 100644
--- a/patches/eudev/3.2.10/eudev-3.2.10-static.patch
+++ b/patches/eudev/3.2.14/eudev-3.2.14-static.patch
@@ -1,14 +1,14 @@
--- a/configure.ac
+++ b/configure.ac
-@@ -261,7 +261,7 @@ AC_ARG_ENABLE(kmod, AS_HELP_STRING([--disable-kmod], [disable loadable modules s
+@@ -252,7 +252,7 @@ AC_ARG_ENABLE(kmod, AS_HELP_STRING([--disable-kmod], [disable loadable modules s
if test "x$enable_kmod" != "xno"; then
- PKG_CHECK_EXISTS([ libkmod ], have_kmod=yes, have_kmod=no)
- if test "x$have_kmod" = "xyes"; then
-- PKG_CHECK_MODULES(KMOD, [ libkmod >= 15 ],
-+ PKG_CHECK_MODULES_STATIC(KMOD, [ libkmod >= 15 ],
- [AC_DEFINE(HAVE_KMOD, 1, [Define if kmod is available])],
- AC_MSG_ERROR([*** kmod version >= 15 not found]))
- fi
+ PKG_CHECK_EXISTS([ libkmod ], have_kmod=yes, have_kmod=no)
+ if test "x$have_kmod" = "xyes"; then
+- PKG_CHECK_MODULES(KMOD, [ libkmod >= 15 ],
++ PKG_CHECK_MODULES_STATIC(KMOD, [ libkmod >= 15 ],
+ [AC_DEFINE(HAVE_KMOD, 1, [Define if kmod is available])],
+ AC_MSG_ERROR([*** kmod version >= 15 not found]))
+ fi
--- a/src/ata_id/Makefile.am
+++ b/src/ata_id/Makefile.am
@@ -11,6 +11,8 @@ udevlibexec_PROGRAMS = \
@@ -94,4 +94,3 @@
v4l_id_LDADD = \
$(top_builddir)/src/libudev/libudev-private.la \
$(top_builddir)/src/udev/libudev-core.la
-