aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-08-01 15:55:57 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-08-01 22:35:00 +0200
commit9f540e262f18abdfde67d63a7d87da04abc322c8 (patch)
tree54a257655d33388a4c75b6d60174525874a67dd4 /Makefile
parentUnify 'confgrep' handling via new get_grep_cmd_for_file() function (diff)
downloadgenkernel-9f540e262f18abdfde67d63a7d87da04abc322c8.tar.gz
genkernel-9f540e262f18abdfde67d63a7d87da04abc322c8.tar.bz2
genkernel-9f540e262f18abdfde67d63a7d87da04abc322c8.zip
Unify grep usage
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index e423ab0..92d1278 100644
--- a/Makefile
+++ b/Makefile
@@ -1,4 +1,4 @@
-#PACKAGE_VERSION = $(shell /bin/fgrep GK_V= genkernel | sed "s/.*GK_V='\([^']\+\)'/\1/")
+#PACKAGE_VERSION = $(shell /bin/grep -F -- GK_V= genkernel | sed "s/.*GK_V='\([^']\+\)'/\1/")
PACKAGE_VERSION = $(shell git describe --tags |sed 's,^v,,g')
distdir = genkernel-$(PACKAGE_VERSION)
MANPAGE = genkernel.8
@@ -78,7 +78,7 @@ verify-doc: doc/genkernel.8.txt
-e '/ssh-host-keys/s,=\(create\|create-from-host\|runtime\),,g' | \
while read opt ; do \
regex="^*--(...no-...)?$$opt" ; \
- if ! egrep -e "$$regex" $< -sq ; then \
+ if ! grep -Ee "$$regex" $< -sq ; then \
touch faildoc ; \
echo "Undocumented option: $$opt" ; \
fi ; \