summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJavier Villavicencio <the_paya@gentoo.org>2010-10-27 04:49:07 -0300
committerJavier Villavicencio <the_paya@gentoo.org>2010-10-27 04:49:07 -0300
commite100db567eafb82442c76ac8dbfeabf5fa3c84bc (patch)
treeada5529cbfb624be14953da908410de116a4748a /sys-netbsd/netbsd-etc
parentAdded Manifests and files subdirs (diff)
downloadgentoo-bsd-e100db567eafb82442c76ac8dbfeabf5fa3c84bc.tar.gz
gentoo-bsd-e100db567eafb82442c76ac8dbfeabf5fa3c84bc.tar.bz2
gentoo-bsd-e100db567eafb82442c76ac8dbfeabf5fa3c84bc.zip
Relayout the repo as a portage overlay.
Diffstat (limited to 'sys-netbsd/netbsd-etc')
-rw-r--r--sys-netbsd/netbsd-etc/Manifest1
-rw-r--r--sys-netbsd/netbsd-etc/netbsd-etc-5.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/sys-netbsd/netbsd-etc/Manifest b/sys-netbsd/netbsd-etc/Manifest
new file mode 100644
index 0000000..02b03e9
--- /dev/null
+++ b/sys-netbsd/netbsd-etc/Manifest
@@ -0,0 +1 @@
+EBUILD netbsd-etc-5.0.ebuild 952 RMD160 69b5f743b7da84bea8e65735198ca9a990a039eb SHA1 35117eea1fe53a2ee47d2966324ded04f95dc626 SHA256 aca07f7908b162bf82847f0dd7e1c8423941ab1f6fd025ca521b2d4746e1f40d
diff --git a/sys-netbsd/netbsd-etc/netbsd-etc-5.0.ebuild b/sys-netbsd/netbsd-etc/netbsd-etc-5.0.ebuild
new file mode 100644
index 0000000..8107107
--- /dev/null
+++ b/sys-netbsd/netbsd-etc/netbsd-etc-5.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# Gentoo/NetBSD base system etc ebuild
+# Patrice Clement <charlieroot@free.fr>
+inherit netbsd
+
+DESCRIPTION="NetBSD 5.0 base system etc files"
+HOMEPAGE="http://cvsweb.netbsd.org"
+SRC_URI=""
+SLOT="0"
+LICENCE="BSD"
+KEYWORDS="~x86-nbsd"
+
+DEPEND=">=sys-netbsd/netbsd-src-5.0"
+
+src_compile() {
+ cd ${NETBSD_SRC_DIR}/etc
+ netbsd_src_compile
+}
+
+src_install() {
+ cd ${D}
+ for etc_dir in etc etc/atf etc/defaults etc/bluetooth etc/ssh etc/iscsi etc/mtree etc/namedb etc/mail etc/pam.d etc/powerd/scripts etc/rc.d etc/root etc/skel dev var/at var/db var/log var/msgs var/run var/games/hackdir var/games/larn var/cron/tabs var/crash root
+ do
+ dodir ${etc_dir}
+ done
+ cd ${NETBSD_SRC_DIR}/etc
+ # We don't want Postfix and SSL related etc files.
+ mymakeopts="${mymakeopts} MKCRYPTO=no MKPOSTFIX=no"
+ netbsd_src_install install-etc-files
+}