summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Feldman <NP-Hardass@gentoo.org>2021-06-08 21:39:59 -0400
committerAdam Feldman <NP-Hardass@gentoo.org>2021-06-08 22:04:53 -0400
commit6be829cfbd7d85b80ddf85bdd6b08ebbeced4d8b (patch)
tree263aedc7634ae03ef1f78c65d1b81258f9f0f053 /mate-extra
parentmate-base/mate-menus: Sync with ::gentoo (diff)
downloadgentoo-mate-6be829cfbd7d85b80ddf85bdd6b08ebbeced4d8b.tar.gz
gentoo-mate-6be829cfbd7d85b80ddf85bdd6b08ebbeced4d8b.tar.bz2
gentoo-mate-6be829cfbd7d85b80ddf85bdd6b08ebbeced4d8b.zip
mate-extra/mate-system-monitor: Sync with ::gentoo
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Adam Feldman <NP-Hardass@gentoo.org>
Diffstat (limited to 'mate-extra')
-rw-r--r--mate-extra/mate-system-monitor/mate-system-monitor-1.24.0.ebuild9
-rw-r--r--mate-extra/mate-system-monitor/mate-system-monitor-1.24.1.ebuild9
2 files changed, 10 insertions, 8 deletions
diff --git a/mate-extra/mate-system-monitor/mate-system-monitor-1.24.0.ebuild b/mate-extra/mate-system-monitor/mate-system-monitor-1.24.0.ebuild
index d6a7c08..d95368b 100644
--- a/mate-extra/mate-system-monitor/mate-system-monitor-1.24.0.ebuild
+++ b/mate-extra/mate-system-monitor/mate-system-monitor-1.24.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit mate
+inherit mate toolchain-funcs
if [[ ${PV} != 9999 ]]; then
KEYWORDS="amd64 ~arm ~arm64 x86"
@@ -51,9 +51,10 @@ src_configure() {
if use elogind || use systemd; then
myconf+=( --enable-systemd )
if use elogind; then
+ local pkgconfig="$(tc-getPKG_CONFIG)"
myconf+=(
- SYSTEMD_CFLAGS=`pkg-config --cflags "libelogind" 2>/dev/null`
- SYSTEMD_LIBS=`pkg-config --libs "libelogind" 2>/dev/null`
+ SYSTEMD_CFLAGS="$(${pkgconfig} --cflags "libelogind")"
+ SYSTEMD_LIBS="$(${pkgconfig} --libs "libelogind")"
)
fi
else
diff --git a/mate-extra/mate-system-monitor/mate-system-monitor-1.24.1.ebuild b/mate-extra/mate-system-monitor/mate-system-monitor-1.24.1.ebuild
index a489ee3..69e584e 100644
--- a/mate-extra/mate-system-monitor/mate-system-monitor-1.24.1.ebuild
+++ b/mate-extra/mate-system-monitor/mate-system-monitor-1.24.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit mate
+inherit mate toolchain-funcs
if [[ ${PV} != 9999 ]]; then
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
@@ -51,9 +51,10 @@ src_configure() {
if use elogind || use systemd; then
myconf+=( --enable-systemd )
if use elogind; then
+ local pkgconfig="$(tc-getPKG_CONFIG)"
myconf+=(
- SYSTEMD_CFLAGS=`pkg-config --cflags "libelogind" 2>/dev/null`
- SYSTEMD_LIBS=`pkg-config --libs "libelogind" 2>/dev/null`
+ SYSTEMD_CFLAGS="$(${pkgconfig} --cflags "libelogind")"
+ SYSTEMD_LIBS="$(${pkgconfig} --libs "libelogind")"
)
fi
else