aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2015-08-08 16:28:23 -0400
committerAnthony G. Basile <blueness@gentoo.org>2015-08-08 16:28:23 -0400
commit667684192b5578513b05699571bccf588fbb64d4 (patch)
tree7bf4a2d79c332bd683f45a79bcec965dac7597ae
parentgrs/WorldConf.py: remove added files to managed dirs during clean. (diff)
downloadgrss-667684192b5578513b05699571bccf588fbb64d4.tar.gz
grss-667684192b5578513b05699571bccf588fbb64d4.tar.bz2
grss-667684192b5578513b05699571bccf588fbb64d4.zip
Add copyright notice to all files.
-rwxr-xr-xbin/clean-worldconf16
-rwxr-xr-xbin/grsrun16
-rwxr-xr-xbin/grsup16
-rwxr-xr-xbin/install-worldconf16
-rwxr-xr-xbin/make-worldconf16
-rw-r--r--grs/Constants.py16
-rw-r--r--grs/Daemon.py16
-rw-r--r--grs/Execute.py16
-rw-r--r--grs/Interpret.py16
-rw-r--r--grs/Kernel.py16
-rw-r--r--grs/MountDirectories.py16
-rw-r--r--grs/PivotChroot.py16
-rw-r--r--grs/Populate.py16
-rw-r--r--grs/Rotator.py16
-rw-r--r--grs/RunScript.py16
-rw-r--r--grs/Seed.py16
-rw-r--r--grs/Synchronize.py16
-rw-r--r--grs/TarIt.py16
-rw-r--r--grs/WorldConf.py16
-rw-r--r--grs/__init__.py16
-rwxr-xr-xsetup.py16
-rwxr-xr-xtests/test-constants.py16
-rwxr-xr-xtests/test-daemon.py16
-rwxr-xr-xtests/test-log.py16
-rwxr-xr-xtests/test-mountdirectories.py16
-rwxr-xr-xtests/test-tarit.py16
-rwxr-xr-xutils/most-dependant16
27 files changed, 432 insertions, 0 deletions
diff --git a/bin/clean-worldconf b/bin/clean-worldconf
index 2e76f57..3ffb040 100755
--- a/bin/clean-worldconf
+++ b/bin/clean-worldconf
@@ -1,4 +1,20 @@
#!/usr/bin/env python
+#
+# clean-worldconf: this file is part of the GRS suite
+# Copyright (C) 2015 Anthony G. Basile
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
import os
diff --git a/bin/grsrun b/bin/grsrun
index df8803c..541b039 100755
--- a/bin/grsrun
+++ b/bin/grsrun
@@ -1,4 +1,20 @@
#!/usr/bin/env python
+#
+# grsrun: this file is part of the GRS suite
+# Copyright (C) 2015 Anthony G. Basile
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
import os
import re
diff --git a/bin/grsup b/bin/grsup
index 392005c..0e05dbf 100755
--- a/bin/grsup
+++ b/bin/grsup
@@ -1,4 +1,20 @@
#!/usr/bin/env python
+#
+# grsup: this file is part of the GRS suite
+# Copyright (C) 2015 Anthony G. Basile
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
import copy
import os
diff --git a/bin/install-worldconf b/bin/install-worldconf
index bdcc6b9..ef5508e 100755
--- a/bin/install-worldconf
+++ b/bin/install-worldconf
@@ -1,4 +1,20 @@
#!/usr/bin/env python
+#
+# install-worldconf: this file is part of the GRS suite
+# Copyright (C) 2015 Anthony G. Basile
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
from grs import CONST
from grs import WorldConf
diff --git a/bin/make-worldconf b/bin/make-worldconf
index c991817..afedf39 100755
--- a/bin/make-worldconf
+++ b/bin/make-worldconf
@@ -1,4 +1,20 @@
#!/usr/bin/env python
+#
+# make-worldconf: this file is part of the GRS suite
+# Copyright (C) 2015 Anthony G. Basile
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
import configparser
import copy
diff --git a/grs/Constants.py b/grs/Constants.py
index 0eebec0..79551f9 100644
--- a/grs/Constants.py
+++ b/grs/Constants.py
@@ -1,4 +1,20 @@
#!/use/bin/env python
+#
+# Constants.py: this file is part of the GRS suite
+# Copyright (C) 2015 Anthony G. Basile
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
import os
import sys
diff --git a/grs/Daemon.py b/grs/Daemon.py
index 38b7d9a..58927f8 100644
--- a/grs/Daemon.py
+++ b/grs/Daemon.py
@@ -1,4 +1,20 @@
#!/usr/bin/env python
+#
+# Daemon.py: this file is part of the GRS suite
+# Copyright (C) 2015 Anthony G. Basile
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
import atexit
import os
diff --git a/grs/Execute.py b/grs/Execute.py
index 9f59a6f..25f618f 100644
--- a/grs/Execute.py
+++ b/grs/Execute.py
@@ -1,4 +1,20 @@
#!/usr/bin/env python
+#
+# Execute.py: this file is part of the GRS suite
+# Copyright (C) 2015 Anthony G. Basile
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
import os
import signal
diff --git a/grs/Interpret.py b/grs/Interpret.py
index a941f3e..a7c0915 100644
--- a/grs/Interpret.py
+++ b/grs/Interpret.py
@@ -1,4 +1,20 @@
#!/usr/bin/env python
+#
+# Interpret.py: this file is part of the GRS suite
+# Copyright (C) 2015 Anthony G. Basile
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
import os
import re
diff --git a/grs/Kernel.py b/grs/Kernel.py
index cec4a5f..bb76b80 100644
--- a/grs/Kernel.py
+++ b/grs/Kernel.py
@@ -1,4 +1,20 @@
#!/usr/bin/env python
+#
+# Kernel.py: this file is part of the GRS suite
+# Copyright (C) 2015 Anthony G. Basile
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
import os
import re
diff --git a/grs/MountDirectories.py b/grs/MountDirectories.py
index c55c2ca..37d0f5e 100644
--- a/grs/MountDirectories.py
+++ b/grs/MountDirectories.py
@@ -1,4 +1,20 @@
#!/usr/bin/env python
+#
+# MountDirectories.py: this file is part of the GRS suite
+# Copyright (C) 2015 Anthony G. Basile
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
import os
from copy import deepcopy
diff --git a/grs/PivotChroot.py b/grs/PivotChroot.py
index f73c3c8..962f8fa 100644
--- a/grs/PivotChroot.py
+++ b/grs/PivotChroot.py
@@ -1,4 +1,20 @@
#!/usr/bin/env python
+#
+# PivotChroot.py: this file is part of the GRS suite
+# Copyright (C) 2015 Anthony G. Basile
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
import glob
import re
diff --git a/grs/Populate.py b/grs/Populate.py
index f37d70e..c24fd63 100644
--- a/grs/Populate.py
+++ b/grs/Populate.py
@@ -1,4 +1,20 @@
#!/usr/bin/env python
+#
+# Populate.py: this file is part of the GRS suite
+# Copyright (C) 2015 Anthony G. Basile
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
import os
import re
diff --git a/grs/Rotator.py b/grs/Rotator.py
index 0dccdf8..faa49aa 100644
--- a/grs/Rotator.py
+++ b/grs/Rotator.py
@@ -1,4 +1,20 @@
#!/usr/bin/env python
+#
+# Rotator.py: this file is part of the GRS suite
+# Copyright (C) 2015 Anthony G. Basile
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
import glob
import re
diff --git a/grs/RunScript.py b/grs/RunScript.py
index 33efd72..bd8d4f9 100644
--- a/grs/RunScript.py
+++ b/grs/RunScript.py
@@ -1,4 +1,20 @@
#!/usr/bin/env python
+#
+# RunScript.py: this file is part of the GRS suite
+# Copyright (C) 2015 Anthony G. Basile
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
import os
import shutil
diff --git a/grs/Seed.py b/grs/Seed.py
index b5c9a6b..ec6fb77 100644
--- a/grs/Seed.py
+++ b/grs/Seed.py
@@ -1,4 +1,20 @@
#!/usr/bin/env python
+#
+# Seed.py: this file is part of the GRS suite
+# Copyright (C) 2015 Anthony G. Basile
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
import glob
import os
diff --git a/grs/Synchronize.py b/grs/Synchronize.py
index ed8209c..3890196 100644
--- a/grs/Synchronize.py
+++ b/grs/Synchronize.py
@@ -1,4 +1,20 @@
#!/usr/bin/env python
+#
+# Synchronize.py: this file is part of the GRS suite
+# Copyright (C) 2015 Anthony G. Basile
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
import os
from grs.Constants import CONST
diff --git a/grs/TarIt.py b/grs/TarIt.py
index a8b21b3..b63258b 100644
--- a/grs/TarIt.py
+++ b/grs/TarIt.py
@@ -1,4 +1,20 @@
#!/usr/bin/env python
+#
+# TarIt.py: this file is part of the GRS suite
+# Copyright (C) 2015 Anthony G. Basile
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
import os
from datetime import datetime
diff --git a/grs/WorldConf.py b/grs/WorldConf.py
index b005f0e..5930d19 100644
--- a/grs/WorldConf.py
+++ b/grs/WorldConf.py
@@ -1,4 +1,20 @@
#!/usr/bin/env python
+#
+# WorldConf.py: this file is part of the GRS suite
+# Copyright (C) 2015 Anthony G. Basile
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
import configparser
import copy
diff --git a/grs/__init__.py b/grs/__init__.py
index 10831e9..a011b2e 100644
--- a/grs/__init__.py
+++ b/grs/__init__.py
@@ -1,4 +1,20 @@
#!/use/bin/env python
+#
+# __init__.py: this file is part of the GRS suite
+# Copyright (C) 2015 Anthony G. Basile
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
from grs.TarIt import TarIt
from grs.Constants import CONST
diff --git a/setup.py b/setup.py
index 55019db..f265e2f 100755
--- a/setup.py
+++ b/setup.py
@@ -1,4 +1,20 @@
#!/usr/bin/env python
+#
+# setup.py: this file is part of the GRS suite
+# Copyright (C) 2015 Anthony G. Basile
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
from distutils.core import setup
diff --git a/tests/test-constants.py b/tests/test-constants.py
index 1327671..cefb9cb 100755
--- a/tests/test-constants.py
+++ b/tests/test-constants.py
@@ -1,4 +1,20 @@
#!/usr/bin/python
+#
+# test-constants.py: this file is part of the GRS suite
+# Copyright (C) 2015 Anthony G. Basile
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
import os
import sys
diff --git a/tests/test-daemon.py b/tests/test-daemon.py
index f121dae..e7043da 100755
--- a/tests/test-daemon.py
+++ b/tests/test-daemon.py
@@ -1,4 +1,20 @@
#!/usr/bin/python
+#
+# test-daemon.py: this file is part of the GRS suite
+# Copyright (C) 2015 Anthony G. Basile
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
import os
import sys
diff --git a/tests/test-log.py b/tests/test-log.py
index b419fbb..89b2448 100755
--- a/tests/test-log.py
+++ b/tests/test-log.py
@@ -1,4 +1,20 @@
#!/usr/bin/python
+#
+# test-log.py: this file is part of the GRS suite
+# Copyright (C) 2015 Anthony G. Basile
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
import os
import sys
diff --git a/tests/test-mountdirectories.py b/tests/test-mountdirectories.py
index cf8482a..f12819f 100755
--- a/tests/test-mountdirectories.py
+++ b/tests/test-mountdirectories.py
@@ -1,4 +1,20 @@
#!/usr/bin/python
+#
+# test-mountdirectories.py: this file is part of the GRS suite
+# Copyright (C) 2015 Anthony G. Basile
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
import os
import sys
diff --git a/tests/test-tarit.py b/tests/test-tarit.py
index c3369c1..cdbcb6f 100755
--- a/tests/test-tarit.py
+++ b/tests/test-tarit.py
@@ -1,4 +1,20 @@
#!/usr/bin/env python
+#
+# test-tarit.py: this file is part of the GRS suite
+# Copyright (C) 2015 Anthony G. Basile
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
import os
import sys
diff --git a/utils/most-dependant b/utils/most-dependant
index 67cfdbf..869cb26 100755
--- a/utils/most-dependant
+++ b/utils/most-dependant
@@ -1,4 +1,20 @@
#!/usr/bin/env python
+#
+# most-dependant: this file is part of the GRS suite
+# Copyright (C) 2015 Anthony G. Basile
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
import portage
import os