summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-12-07 18:32:16 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-12-07 19:18:57 +0100
commit354671f12c94a8298f17bda5b47619302d87e419 (patch)
tree60a299b4300d01d87338e16430c0fb4eda10db29
parentapp-editors/lfhex: Port EAPI-7, qmake-utils, desktop eclass (diff)
downloadkde-sunset-354671f12c94a8298f17bda5b47619302d87e419.tar.gz
kde-sunset-354671f12c94a8298f17bda5b47619302d87e419.tar.bz2
kde-sunset-354671f12c94a8298f17bda5b47619302d87e419.zip
app-editors/lfhex: Remove unbuildable package
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--app-editors/lfhex/Manifest1
-rw-r--r--app-editors/lfhex/files/01-abs-llabs.dpatch19
-rw-r--r--app-editors/lfhex/files/02-gcc-4.7.dpatch19
-rw-r--r--app-editors/lfhex/lfhex-0.42.ebuild45
-rw-r--r--app-editors/lfhex/metadata.xml5
5 files changed, 0 insertions, 89 deletions
diff --git a/app-editors/lfhex/Manifest b/app-editors/lfhex/Manifest
deleted file mode 100644
index 9369d650..00000000
--- a/app-editors/lfhex/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST lfhex-0.42a.tar.gz 38353 BLAKE2B 9aa143dc3e8d1e2f5bd209d6c4234d52ecc130f00a44043d123834b810b22fcb7a75154ed7af4f54acb241b239b90b0fcef6247e993c6e2ca59e05252e183d47 SHA512 380bd8938675f7aa2dda5ac924b0fbf87e047f4ae6237858dd1db3b3f97b2696a5bd3b2f28a12afe4bfda6017564a1ef28ec83fb57697c42899f2ec21324e829
diff --git a/app-editors/lfhex/files/01-abs-llabs.dpatch b/app-editors/lfhex/files/01-abs-llabs.dpatch
deleted file mode 100644
index b9bf08ca..00000000
--- a/app-editors/lfhex/files/01-abs-llabs.dpatch
+++ /dev/null
@@ -1,19 +0,0 @@
-#!/bin/sh /usr/share/dpatch/dpatch-run
-## 01-abs-llabs.dpatch by Thiemo Seufer
-##
-## DP: Fixes FTBFS due to abs() not being in the global anymore since g++ 4.3
-## (#495467)
-
-diff -up a/reader.cpp b/reader.cpp
---- a/reader.cpp 2008-10-08 19:25:57.000000000 +0200
-+++ b/reader.cpp 2008-10-08 19:26:16.000000000 +0200
-@@ -238,7 +238,7 @@ bool Reader::loadPage(off_t pageIdx)
- // free the page which is the furthest away from the page we are loading
-
- // this could be trouble if off_t is unsigned!
-- if( abs(_firstPage - pageIdx) > abs(_lastPage - pageIdx) )
-+ if( ::llabs(_firstPage - pageIdx) > ::llabs(_lastPage - pageIdx) )
- while(!freePage(_firstPage++));
- else
- while(!freePage(_lastPage--));
-
diff --git a/app-editors/lfhex/files/02-gcc-4.7.dpatch b/app-editors/lfhex/files/02-gcc-4.7.dpatch
deleted file mode 100644
index dd4a1777..00000000
--- a/app-editors/lfhex/files/02-gcc-4.7.dpatch
+++ /dev/null
@@ -1,19 +0,0 @@
-#! /bin/sh /usr/share/dpatch/dpatch-run
-## 02-gcc-4.7.dpatch by gregor herrmann <gregoa@debian.org>
-##
-## All lines beginning with `## DP:' are a description of the patch.
-## DP: add missing include to avoid FTBFS with gcc 4.7
-## DP: Bug-Debian: http://bugs.debian.org/667238
-
-@DPATCH@
-diff -urNad '--exclude=CVS' '--exclude=.svn' '--exclude=.git' '--exclude=.arch' '--exclude=.hg' '--exclude=_darcs' '--exclude=.bzr' a/expr.h b/expr.h
---- a/expr.h 2008-09-19 02:36:49.000000000 +0200
-+++ b/expr.h 2012-05-07 17:03:22.788794002 +0200
-@@ -19,6 +19,7 @@
- */
-
- #include <string>
-+#include <sys/types.h>
-
- bool expr_eval( const std::string &str, off_t &value );
-
diff --git a/app-editors/lfhex/lfhex-0.42.ebuild b/app-editors/lfhex/lfhex-0.42.ebuild
deleted file mode 100644
index 02ac2e9e..00000000
--- a/app-editors/lfhex/lfhex-0.42.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit desktop qmake-utils
-
-DESCRIPTION="Fast hex-editor with support for large files and comparing binary files"
-HOMEPAGE="http://freshmeat.sourceforge.net/projects/lfhex/
-https://github.com/srtlg/lfhex"
-SRC_URI="https://github.com/srtlg/${PN}/archive/v${PV}.tar.gz -> ${P}a.tar.gz"
-S="${WORKDIR}/${P}/src"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~ppc x86"
-IUSE=""
-
-DOCS=( ../README )
-
-RDEPEND="
- dev-qt/qtgui:4
- x11-libs/libXt
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- sys-devel/bison
- sys-devel/flex
-"
-
-PATCHES=(
- # Apply Debian patches to fix compilation errors like gcc-4.7 compat
- "${FILESDIR}"/01-abs-llabs.dpatch
- "${FILESDIR}"/02-gcc-4.7.dpatch
-)
-
-src_configure() {
- eqmake4
-}
-
-src_install() {
- dobin lfhex
- einstalldocs
- make_desktop_entry "${PN}" "${PN}"
-}
diff --git a/app-editors/lfhex/metadata.xml b/app-editors/lfhex/metadata.xml
deleted file mode 100644
index 6f49eba8..00000000
--- a/app-editors/lfhex/metadata.xml
+++ /dev/null
@@ -1,5 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<!-- maintainer-needed -->
-</pkgmetadata>