summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-12-07 22:53:11 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-12-07 23:15:18 +0100
commitd6d150e2b6eb5cfc3658e7bee5c616224edfc56f (patch)
tree545141cf2a1c38389ac2d1eb60122738c506e626
parentqt4-r2.eclass: Remove unused eclass (diff)
downloadkde-sunset-d6d150e2b6eb5cfc3658e7bee5c616224edfc56f.tar.gz
kde-sunset-d6d150e2b6eb5cfc3658e7bee5c616224edfc56f.tar.bz2
kde-sunset-d6d150e2b6eb5cfc3658e7bee5c616224edfc56f.zip
net-libs/telepathy-qt: EAPI-7, cmake.eclass, SLOT="0-qt4", drop IUSE=test
Add missing patches to fix build in the first place. Test dependency is gone from Gentoo ebuild repo so drop all facilities. Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--net-libs/telepathy-qt/files/telepathy-qt-0.9.6.1-qtpath.patch21
-rw-r--r--net-libs/telepathy-qt/files/telepathy-qt-0.9.6.1-yes-release.patch17
-rw-r--r--net-libs/telepathy-qt/metadata.xml2
-rw-r--r--net-libs/telepathy-qt/telepathy-qt-0.9.7-r1.ebuild57
4 files changed, 96 insertions, 1 deletions
diff --git a/net-libs/telepathy-qt/files/telepathy-qt-0.9.6.1-qtpath.patch b/net-libs/telepathy-qt/files/telepathy-qt-0.9.6.1-qtpath.patch
new file mode 100644
index 00000000..a14e1da1
--- /dev/null
+++ b/net-libs/telepathy-qt/files/telepathy-qt-0.9.6.1-qtpath.patch
@@ -0,0 +1,21 @@
+Ensure that the correct version of Qt is always used.
+
+With the introduction qt-4.8.6, Qt binaries were moved from /usr/bin to
+/usr/$(get_libdir)/qt4/bin, leaving behind in their place symlinks to qtchooser.
+
+There is no guarantee to which version of Qt these symlinks might point, so it
+is necessary to find the correct version explicitly.
+
+Once qmake is found, it is queried for the correct location of all other items.
+
+--- a/cmake/modules/FindQt.cmake
++++ b/cmake/modules/FindQt.cmake
+@@ -19,7 +19,7 @@
+ IF(NOT QT5_INSTALLED)
+ IF(NOT QT_QMAKE_EXECUTABLE)
+ FIND_PROGRAM(QT_QMAKE_EXECUTABLE_FINDQT NAMES qmake qmake4 qmake-qt4 qmake5 qmake-qt5
+- PATHS "${QT_SEARCH_PATH}/bin" "$ENV{QTDIR}/bin")
++ PATHS /usr/${CMAKE_INSTALL_LIBDIR}/qt4/bin /usr/bin NO_DEFAULT_PATH)
+ SET(QT_QMAKE_EXECUTABLE ${QT_QMAKE_EXECUTABLE_FINDQT} CACHE PATH "Qt qmake program.")
+ ENDIF(NOT QT_QMAKE_EXECUTABLE)
+
diff --git a/net-libs/telepathy-qt/files/telepathy-qt-0.9.6.1-yes-release.patch b/net-libs/telepathy-qt/files/telepathy-qt-0.9.6.1-yes-release.patch
new file mode 100644
index 00000000..97a880c7
--- /dev/null
+++ b/net-libs/telepathy-qt/files/telepathy-qt-0.9.6.1-yes-release.patch
@@ -0,0 +1,17 @@
+diff --git a/cmake/modules/TelepathyDefaults.cmake b/cmake/modules/TelepathyDefaults.cmake
+index d34b24d..eb51454 100644
+--- a/cmake/modules/TelepathyDefaults.cmake
++++ b/cmake/modules/TelepathyDefaults.cmake
+@@ -59,11 +59,7 @@ if(CMAKE_COMPILER_IS_GNUCXX)
+ set(DEPRECATED_DECLARATIONS_FLAGS)
+ endif (CXX_DEPRECATED_DECLARATIONS)
+
+- if(${TP_QT_NANO_VERSION} EQUAL 0)
+- set(NOT_RELEASE 0)
+- else(${TP_QT_NANO_VERSION} EQUAL 0)
+- set(NOT_RELEASE 1)
+- endif(${TP_QT_NANO_VERSION} EQUAL 0)
++ set(NOT_RELEASE 0)
+
+ set(desired
+ all
diff --git a/net-libs/telepathy-qt/metadata.xml b/net-libs/telepathy-qt/metadata.xml
index fe1485f3..6549ca3d 100644
--- a/net-libs/telepathy-qt/metadata.xml
+++ b/net-libs/telepathy-qt/metadata.xml
@@ -3,6 +3,6 @@
<pkgmetadata>
<!-- maintainer-needed -->
<use>
- <flag name='farstream'>Enable support for audio/video calls via farstream</flag>
+ <flag name="farstream">Enable support for audio/video calls via farstream</flag>
</use>
</pkgmetadata>
diff --git a/net-libs/telepathy-qt/telepathy-qt-0.9.7-r1.ebuild b/net-libs/telepathy-qt/telepathy-qt-0.9.7-r1.ebuild
new file mode 100644
index 00000000..089b2acf
--- /dev/null
+++ b/net-libs/telepathy-qt/telepathy-qt-0.9.7-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 )
+inherit cmake python-any-r1
+
+DESCRIPTION="Qt bindings for the Telepathy D-Bus protocol"
+HOMEPAGE="https://telepathy.freedesktop.org/"
+SRC_URI="https://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0-qt4"
+KEYWORDS="amd64 ~arm x86"
+IUSE="debug farstream"
+
+# test deps are gone
+RESTRICT+=" test"
+
+DEPEND="
+ dev-qt/qtcore:4
+ dev-qt/qtdbus:4
+ farstream? (
+ >=net-libs/telepathy-farstream-0.2.2
+ >=net-libs/telepathy-glib-0.18.0
+ )
+"
+RDEPEND="${DEPEND}
+ !net-libs/telepathy-qt4
+ !<net-libs/telepathy-qt-0.9.8:0
+"
+BDEPEND="${PYTHON_DEPS}
+ virtual/pkgconfig
+"
+
+DOCS=( AUTHORS ChangeLog HACKING NEWS README )
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.9.6.1-yes-release.patch"
+ "${FILESDIR}/${PN}-0.9.6.1-qtpath.patch"
+)
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_DEBUG_OUTPUT=$(usex debug)
+ -DENABLE_FARSTREAM=$(usex farstream)
+ -DENABLE_TESTS=OFF
+ -DENABLE_EXAMPLES=OFF
+ -DDESIRED_QT_VERSION=4
+ )
+ cmake_src_configure
+}