aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-09-15 23:36:19 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-09-15 23:41:11 +0200
commit6aa58594e3b9dd1d09ad1351904049f903fa4969 (patch)
tree1acae317cdcfc119e1c24308ba1c96188312f0b0
parentkde-plasma/ksystemstats: 5.25.90 version bump (diff)
downloadkde-6aa58594e3b9dd1d09ad1351904049f903fa4969.tar.gz
kde-6aa58594e3b9dd1d09ad1351904049f903fa4969.tar.bz2
kde-6aa58594e3b9dd1d09ad1351904049f903fa4969.zip
kde-plasma/kwallet-pam: 5.25.90 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-plasma/kwallet-pam/Manifest1
-rw-r--r--kde-plasma/kwallet-pam/kwallet-pam-5.25.90.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/kde-plasma/kwallet-pam/Manifest b/kde-plasma/kwallet-pam/Manifest
new file mode 100644
index 0000000000..e9f76f7491
--- /dev/null
+++ b/kde-plasma/kwallet-pam/Manifest
@@ -0,0 +1 @@
+DIST kwallet-pam-5.25.90.tar.xz 22820 BLAKE2B 656ef825fcd902417bc09ee23043e1497e9c4606cba88e395a73261f11e430a2ccdc7188d8ef2dee5a14c8a3e92d978468a2420693e09c8fc10cc1372930eb4e SHA512 cdcd38872f28e78326df9c292dbc6de82f919c9f379f3abfa456e17ad0ecaf45768a08232004cbe743a276bc00e6e4ef327cd61d17c0f3a8871aef414b5f6071
diff --git a/kde-plasma/kwallet-pam/kwallet-pam-5.25.90.ebuild b/kde-plasma/kwallet-pam/kwallet-pam-5.25.90.ebuild
new file mode 100644
index 0000000000..04ac6f7cee
--- /dev/null
+++ b/kde-plasma/kwallet-pam/kwallet-pam-5.25.90.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.98.0
+PVCUT=$(ver_cut 1-3)
+inherit ecm plasma.kde.org
+
+DESCRIPTION="PAM module to not enter KWallet password again after login"
+
+LICENSE="LGPL-2.1"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE=""
+
+DEPEND="
+ dev-libs/libgcrypt:0=
+ >=kde-frameworks/kwallet-${KFMIN}:5
+ sys-libs/pam
+"
+RDEPEND="${DEPEND}
+ net-misc/socat
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_LIBDIR="/$(get_libdir)"
+ )
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+ elog "This package enables auto-unlocking of kde-frameworks/kwallet:5."
+ elog "See also: https://wiki.gentoo.org/wiki/KDE#KWallet_auto-unlocking"
+}