aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2012-11-08 18:49:07 +1100
committerMichael Palimaka <kensington@gentoo.org>2012-11-08 18:49:07 +1100
commitdf9e5972985d8cb868aaea7b409d14a1bf15eab0 (patch)
tree8904764798011ea79daed71bf169320e9c5517b9
parent[kde-base/kdelibs] Remove patch merged upstream. (diff)
downloadkde-df9e5972985d8cb868aaea7b409d14a1bf15eab0.tar.gz
kde-df9e5972985d8cb868aaea7b409d14a1bf15eab0.tar.bz2
kde-df9e5972985d8cb868aaea7b409d14a1bf15eab0.zip
[kde-base/kdelibs] Remove -Werror, wrt bug #442278.
Package-Manager: portage-2.1.11.31
-rw-r--r--kde-base/kdelibs/files/kdelibs-4.9.3-werror.patch20
-rw-r--r--kde-base/kdelibs/kdelibs-4.9.3.ebuild1
-rw-r--r--kde-base/kdelibs/kdelibs-4.9.49.9999.ebuild1
-rw-r--r--kde-base/kdelibs/kdelibs-9999.ebuild1
4 files changed, 23 insertions, 0 deletions
diff --git a/kde-base/kdelibs/files/kdelibs-4.9.3-werror.patch b/kde-base/kdelibs/files/kdelibs-4.9.3-werror.patch
new file mode 100644
index 0000000000..6ec0b7d9a3
--- /dev/null
+++ b/kde-base/kdelibs/files/kdelibs-4.9.3-werror.patch
@@ -0,0 +1,20 @@
+--- cmake/modules/FindKDE4Internal.cmake
++++ cmake/modules/FindKDE4Internal.cmake
+@@ -1204,7 +1204,7 @@
+ set(CMAKE_C_FLAGS_DEBUGFULL "-g3 -fno-inline")
+ set(CMAKE_C_FLAGS_PROFILE "-g3 -fno-inline -ftest-coverage -fprofile-arcs")
+
+- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wno-long-long -std=iso9899:1990 -Wundef -Wcast-align -Werror-implicit-function-declaration -Wchar-subscripts -Wall -W -Wpointer-arith -Wwrite-strings -Wformat-security -Wmissing-format-attribute -fno-common")
++ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wno-long-long -std=iso9899:1990 -Wundef -Wcast-align -Wchar-subscripts -Wall -W -Wpointer-arith -Wwrite-strings -Wformat-security -Wmissing-format-attribute -fno-common")
+ # As of Qt 4.6.x we need to override the new exception macros if we want compile with -fno-exceptions
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wnon-virtual-dtor -Wno-long-long -Wundef -Wcast-align -Wchar-subscripts -Wall -W -Wpointer-arith -Wformat-security -fno-exceptions -DQT_NO_EXCEPTIONS -fno-check-new -fno-common")
+
+@@ -1295,7 +1295,7 @@
+ endif(NOT _compile_result)
+
+ if (GCC_IS_NEWER_THAN_4_2)
+- set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Werror=return-type -fvisibility-inlines-hidden")
++ set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fvisibility-inlines-hidden")
+ endif (GCC_IS_NEWER_THAN_4_2)
+ else (__KDE_HAVE_GCC_VISIBILITY AND GCC_IS_NEWER_THAN_4_1 AND NOT _GCC_COMPILED_WITH_BAD_ALLOCATOR AND NOT WIN32)
+ set (__KDE_HAVE_GCC_VISIBILITY 0)
diff --git a/kde-base/kdelibs/kdelibs-4.9.3.ebuild b/kde-base/kdelibs/kdelibs-4.9.3.ebuild
index 48a04783d3..7f74bf08a3 100644
--- a/kde-base/kdelibs/kdelibs-4.9.3.ebuild
+++ b/kde-base/kdelibs/kdelibs-4.9.3.ebuild
@@ -142,6 +142,7 @@ PATCHES=(
"${FILESDIR}/${PN}-4.6.3-no_suid_kdeinit.patch"
"${FILESDIR}/${PN}-4.8.1-norpath.patch"
"${FILESDIR}/${PN}-4.9.3-python-bytecompilation.patch"
+ "${FILESDIR}/${PN}-4.9.3-werror.patch"
)
pkg_pretend() {
diff --git a/kde-base/kdelibs/kdelibs-4.9.49.9999.ebuild b/kde-base/kdelibs/kdelibs-4.9.49.9999.ebuild
index 22e8bb37f1..928a3ce8cc 100644
--- a/kde-base/kdelibs/kdelibs-4.9.49.9999.ebuild
+++ b/kde-base/kdelibs/kdelibs-4.9.49.9999.ebuild
@@ -141,6 +141,7 @@ PATCHES=(
"${FILESDIR}/${PN}-4.4.90-xslt.patch"
"${FILESDIR}/${PN}-4.6.3-no_suid_kdeinit.patch"
"${FILESDIR}/${PN}-4.8.1-norpath.patch"
+ "${FILESDIR}/${PN}-4.9.3-werror.patch"
)
pkg_pretend() {
diff --git a/kde-base/kdelibs/kdelibs-9999.ebuild b/kde-base/kdelibs/kdelibs-9999.ebuild
index e57d8e44c7..6d09d60672 100644
--- a/kde-base/kdelibs/kdelibs-9999.ebuild
+++ b/kde-base/kdelibs/kdelibs-9999.ebuild
@@ -144,6 +144,7 @@ PATCHES=(
"${FILESDIR}/${PN}-4.4.90-xslt.patch"
"${FILESDIR}/${PN}-4.6.3-no_suid_kdeinit.patch"
"${FILESDIR}/${PN}-4.8.1-norpath.patch"
+ "${FILESDIR}/${PN}-4.9.3-werror.patch"
)
pkg_pretend() {