aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-04-15 18:19:04 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-04-15 21:39:31 +0200
commit1f9e7f2ac11694f1d50df2252a0a17124a78f692 (patch)
tree2e94e077655b5bd4a871c6261152f2688bcebd87 /app-cdr
parentkde-apps/umbrello: 23.04.0 version bump (diff)
downloadkde-1f9e7f2ac11694f1d50df2252a0a17124a78f692.tar.gz
kde-1f9e7f2ac11694f1d50df2252a0a17124a78f692.tar.bz2
kde-1f9e7f2ac11694f1d50df2252a0a17124a78f692.zip
app-cdr/dolphin-plugins-mountiso: 23.04.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-cdr')
-rw-r--r--app-cdr/dolphin-plugins-mountiso/Manifest1
-rw-r--r--app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-23.04.0.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/app-cdr/dolphin-plugins-mountiso/Manifest b/app-cdr/dolphin-plugins-mountiso/Manifest
index 07449f44e7..bc83a075fd 100644
--- a/app-cdr/dolphin-plugins-mountiso/Manifest
+++ b/app-cdr/dolphin-plugins-mountiso/Manifest
@@ -1 +1,2 @@
DIST dolphin-plugins-23.03.90.tar.xz 272556 BLAKE2B f0bfe698ff484050d6b68db76ba8922de7995258e518bd1da3a85aede11e998edf888285c580fec5293ae5f25f13c30e4a30c5fbd4690a8e68b7722902d88815 SHA512 00d4d32b08bf7389cc7468b9f9b219ba8ab50ef277b18fcddfa8af21f496d21bd4addd0f6f384593bcaad3406fc970a59ba3cbec21f4c9cea7a20f20c6c761d1
+DIST dolphin-plugins-23.04.0.tar.xz 272516 BLAKE2B b424fc4c1cac1c7109b4ea05d97bc44e348d94d36ea5e7acb06dd171f4eee1c7278b19b004ea175b3e7d567f440a9c4b362726ae051dce061073f59e6cf280f7 SHA512 0ffdeeb9296763ef23d567ddf9929b3c3ac25cebd9d8d409f5afd5cd7765d49845a7806fb718ccee31e778d517c6eb9758fbdb15014a72d1e56083c8dd145d1d
diff --git a/app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-23.04.0.ebuild b/app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-23.04.0.ebuild
new file mode 100644
index 0000000000..f4ba6d3d3e
--- /dev/null
+++ b/app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-23.04.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="false"
+KDE_ORG_CATEGORY="sdk"
+KDE_ORG_NAME="dolphin-plugins"
+MY_PLUGIN_NAME="mountiso"
+KFMIN=5.104.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.15.5
+inherit ecm gear.kde.org
+
+DESCRIPTION="Dolphin plugin for ISO loopback device mounting"
+HOMEPAGE="https://apps.kde.org/dolphin_plugins/"
+
+LICENSE="GPL-2+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-apps/dolphin-${PVCUT}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/ktextwidgets-${KFMIN}:5
+ >=kde-frameworks/solid-${KFMIN}:5
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ ecm_src_prepare
+ # kxmlgui, qtnetwork only required by dropbox
+ ecm_punt_qt_module Network
+ ecm_punt_kf_module XmlGui
+ # delete non-${PN} translations
+ find po -type f -name "*po" -and -not -name "*${MY_PLUGIN_NAME}plugin" -delete || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_${MY_PLUGIN_NAME}=ON
+ -DBUILD_bazaar=OFF
+ -DBUILD_dropbox=OFF
+ -DBUILD_git=OFF
+ -DBUILD_hg=OFF
+ -DBUILD_svn=OFF
+ )
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+ rm "${D}"/usr/share/metainfo/org.kde.dolphin-plugins.metainfo.xml || die
+}