aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-02-01 21:15:26 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-02-01 22:19:15 +0100
commit8e5829f8401504fd675d926212f18cb159f2d505 (patch)
treec8300a1ac88b9d2d6c4b67c18d31debbc149e1e4 /app-cdr
parentkde-apps/umbrello: 24.01.95 version bump (diff)
downloadkde-8e5829f8401504fd675d926212f18cb159f2d505.tar.gz
kde-8e5829f8401504fd675d926212f18cb159f2d505.tar.bz2
kde-8e5829f8401504fd675d926212f18cb159f2d505.zip
app-cdr/dolphin-plugins-mountiso: 24.01.95 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-cdr')
-rw-r--r--app-cdr/dolphin-plugins-mountiso/Manifest1
-rw-r--r--app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-24.01.95.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/app-cdr/dolphin-plugins-mountiso/Manifest b/app-cdr/dolphin-plugins-mountiso/Manifest
index a799832bb8..98fd2f8887 100644
--- a/app-cdr/dolphin-plugins-mountiso/Manifest
+++ b/app-cdr/dolphin-plugins-mountiso/Manifest
@@ -1 +1,2 @@
DIST dolphin-plugins-24.01.90.tar.xz 291068 BLAKE2B 6d09c88e511462dbb82e01e8bec9ca1741ce776060fe46992630e2b159cb0399427aa7fdf9f3d438f9e72feb7622c322fa19677435dfa0283f7253b38c4b356f SHA512 0b9251ea40758b256bf9a63c986d1522ae2317320cdc7b9f064520217692e6df70c724901aa86b4f553224a5f39b8d0f5e01afa442bd9d34b6a6fccd14ba94e4
+DIST dolphin-plugins-24.01.95.tar.xz 293576 BLAKE2B 6c071c7beab47c579fec69d99d512212eb4366c7328c90826b90073e21d1f32715c740d7e71d869c15490396dea20b130c1111cb4164d93491ddc43620831644 SHA512 1608e937be505513f6113f7151fa21fed5af1ef430fe972f2def1912827a4163fd84c36c604527a31b9e9abfcbc9ec6cc22ffd724f31ddee0a489b2112252d04
diff --git a/app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-24.01.95.ebuild b/app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-24.01.95.ebuild
new file mode 100644
index 0000000000..467b44c0e8
--- /dev/null
+++ b/app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-24.01.95.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="false"
+KDE_ORG_CATEGORY="sdk"
+KDE_ORG_NAME="dolphin-plugins"
+MY_PLUGIN_NAME="mountiso"
+KFMIN=5.249.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=6.6.0
+inherit ecm gear.kde.org
+
+DESCRIPTION="Dolphin plugin for ISO loopback device mounting"
+HOMEPAGE="https://apps.kde.org/dolphin_plugins/"
+
+LICENSE="GPL-2+"
+SLOT="6"
+KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[dbus,gui,widgets]
+ >=kde-apps/dolphin-${PVCUT}:6
+ >=kde-frameworks/kcompletion-${KFMIN}:6
+ >=kde-frameworks/kconfig-${KFMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kio-${KFMIN}:6
+ >=kde-frameworks/ktextwidgets-${KFMIN}:6
+ >=kde-frameworks/solid-${KFMIN}:6
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ ecm_src_prepare
+ # kxmlgui, qtnetwork only required by dropbox
+ ecm_punt_qt_module Network
+ ecm_punt_kf_module XmlGui
+ # delete non-${PN} translations
+ find po -type f -name "*po" -and -not -name "*${MY_PLUGIN_NAME}plugin" -delete || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_${MY_PLUGIN_NAME}=ON
+ -DBUILD_bazaar=OFF
+ -DBUILD_dropbox=OFF
+ -DBUILD_git=OFF
+ -DBUILD_hg=OFF
+ -DBUILD_makefileactions=OFF
+ -DBUILD_svn=OFF
+ )
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+ rm "${D}"/usr/share/metainfo/org.kde.dolphin-plugins.metainfo.xml || die
+}