aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2013-03-10 20:03:50 +1100
committerMichael Palimaka <kensington@gentoo.org>2013-03-10 20:03:50 +1100
commit43dc4bb29a1e9174a8d5ccf15ec54610a81e7feb (patch)
tree7308af551418cd0d76bf018a17e1ca39f31883fc /app-office
parent[kde-misc/colord-kde] Moved to main tree (diff)
downloadkde-43dc4bb29a1e9174a8d5ccf15ec54610a81e7feb.tar.gz
kde-43dc4bb29a1e9174a8d5ccf15ec54610a81e7feb.tar.bz2
kde-43dc4bb29a1e9174a8d5ccf15ec54610a81e7feb.zip
[app-office/skrooge] Migrate to EAPI 5. Update LINGUAS. Add missing deps. Improve test handling. Fix handbook handling.
Package-Manager: portage-2.1.11.55
Diffstat (limited to 'app-office')
-rw-r--r--app-office/skrooge/skrooge-9999.ebuild36
1 files changed, 27 insertions, 9 deletions
diff --git a/app-office/skrooge/skrooge-9999.ebuild b/app-office/skrooge/skrooge-9999.ebuild
index 85fd09abbc..f4b0200a24 100644
--- a/app-office/skrooge/skrooge-9999.ebuild
+++ b/app-office/skrooge/skrooge-9999.ebuild
@@ -2,12 +2,11 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=4
+EAPI=5
-KDE_LINGUAS="bg bs ca ca@valencia cs da de el en_GB eo es et fr ga gl hu it ja
-ko lt ms nb nds nl pl pt pt_BR ro ru sk sv tr ug uk zh_CN zh_TW"
-KDE_DOC_DIRS="doc"
-KDE_HANDBOOK=optional
+KDE_LINGUAS="bg bs ca ca@valencia cs da de el en_GB eo es et fi fr ga gl hu it
+ja ko lt ms nb nds nl pl pt pt_BR ro ru sk sv tr ug uk zh_CN zh_TW"
+KDE_HANDBOOK="optional"
inherit kde4-base
DESCRIPTION="personal finances manager for KDE4, aiming at being simple and intuitive"
@@ -19,7 +18,9 @@ KEYWORDS=""
IUSE="debug"
DEPEND="
+ $(add_kdebase_dep kdepimlibs)
app-crypt/qca:2
+ dev-db/sqlite:3
dev-libs/grantlee
>=dev-libs/libofx-0.9.1
dev-qt/qtsql:4[sqlite]
@@ -31,11 +32,28 @@ RDEPEND="${DEPEND}
)
"
+# upstream does not ship tests in releases
+if [[ ${KDE_BUILD_TYPE} != live ]]; then
+ RESTRICT="test"
+fi
+
DOCS=( AUTHORS CHANGELOG README TODO )
-src_configure() {
- mycmakeargs=(
- $(cmake-utils_use test SKG_BUILD_TEST)
+src_prepare() {
+ if [[ ${KDE_BUILD_TYPE} != live ]]; then
+ # KDE_LINGUAS is also used to install appropriate handbooks
+ # since there is no en_US 'translation', it cannot be added
+ # hence making this impossible to install
+ mv doc/en_US doc/en || die "doc move failed"
+ sed -i -e 's/en_US/en/' doc/CMakeLists.txt || die "sed failed"
+ fi
+
+ kde4-base_src_prepare
+}
+
+src_test() {
+ local mycmakeargs=(
+ -DSKG_BUILD_TEST=ON
)
- kde4-base_src_configure
+ kde4-base_src_test
}