aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal (scarabeus) <tomas.chvatal@gmail.com>2008-10-22 17:12:14 +0200
committerTomas Chvatal (scarabeus) <tomas.chvatal@gmail.com>2008-10-22 17:12:14 +0200
commit387dd3881c1b52bd4740faaacecad055524ec889 (patch)
tree9492a7f20cf7f1b6b2bb27929617a0ebdc4181c4 /games-board
parentInitial commit of live branch, not removed anything yet. Needs a hell of clea... (diff)
downloadkde-387dd3881c1b52bd4740faaacecad055524ec889.tar.gz
kde-387dd3881c1b52bd4740faaacecad055524ec889.tar.bz2
kde-387dd3881c1b52bd4740faaacecad055524ec889.zip
Ups i used wrong branch in previous commit.
Revert "Initial commit of live branch, not removed anything yet. Needs a hell of cleanup." This reverts commit 3143e5ad1677a6e7a18b131b5036d31ee9b2c7ae.
Diffstat (limited to 'games-board')
-rw-r--r--games-board/tagua/tagua-9999.ebuild56
1 files changed, 0 insertions, 56 deletions
diff --git a/games-board/tagua/tagua-9999.ebuild b/games-board/tagua/tagua-9999.ebuild
deleted file mode 100644
index 8b821fc9d2..0000000000
--- a/games-board/tagua/tagua-9999.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=1
-
-NEED_KDE="svn"
-
-EGIT_REPO_URI="git://repo.or.cz/tagua.git"
-CPPUNIT_REQUIRED="optional"
-inherit kde4overlay-base git
-
-# Install to KDEDIR rather than /usr, to slot properly.
-PREFIX="${KDEDIR}"
-
-DESCRIPTION="Tagua is a generic board game application for KDE."
-HOMEPAGE="http://www.tagua-project.org/"
-
-LICENSE="GPL-2"
-SLOT="kde-svn"
-KEYWORDS=""
-IUSE="debug mmx sse2"
-
-DEPEND="
- >=dev-lang/lua-5.1.1
- >=dev-libs/boost-1.34
- kde-base/libkdegames:${SLOT}
- kde-base/qimageblitz"
-RDEPEND="${DEPEND}"
-
-src_unpack() {
- git_src_unpack
-
- if ! use test; then
- sed -e "/find_package(CPPUNIT)/s/^/#DONOTFIND /" \
- -i "${S}"/tests/CMakeLists.txt || die "Sed to disable tests failed."
- fi
-}
-
-src_compile() {
- mycmakeargs="${mycmakeargs} -DSYSTEM_LUA=1"
- if ! use mmx; then
- mycmakeargs="${mycmakeargs} -DCOMPILER_HAVE_X86_MMX=0"
- fi
- if ! use sse2; then
- mycmakeargs="${mycmakeargs} -DCOMPILER_HAVE_X86_SSE2=0"
- fi
-
- cmake-utils_src_compile
-}
-
-src_install() {
- cmake-utils_src_install
-
- dodoc AUTHORS CHANGELOG README RELEASE || die "installing docs failed"
-}