aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2014-03-08 14:50:03 +0100
committerJohannes Huber <johu@gentoo.org>2014-03-08 14:50:03 +0100
commitcb2c528d76f32aa1f2939253ba9e1c18d16d1168 (patch)
treecbf1d039562fd8fbaad72704323d8a7ef48e7827 /kde-base/cantor
parent[Documentation] Add KDE 4.13 (diff)
downloadkde-cb2c528d76f32aa1f2939253ba9e1c18d16d1168.tar.gz
kde-cb2c528d76f32aa1f2939253ba9e1c18d16d1168.tar.bz2
kde-cb2c528d76f32aa1f2939253ba9e1c18d16d1168.zip
[kde-base] Add KDE/4.13 stable branch
Package-Manager: portage-2.2.8-r1
Diffstat (limited to 'kde-base/cantor')
-rw-r--r--kde-base/cantor/cantor-4.13.49.9999.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/kde-base/cantor/cantor-4.13.49.9999.ebuild b/kde-base/cantor/cantor-4.13.49.9999.ebuild
new file mode 100644
index 0000000000..6e4a22f604
--- /dev/null
+++ b/kde-base/cantor/cantor-4.13.49.9999.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+PYTHON_COMPAT=( python2_7 )
+inherit kde4-base python-single-r1
+
+DESCRIPTION="KDE4 interface for doing mathematics and scientific computing"
+HOMEPAGE="http://www.kde.org/applications/education/cantor http://edu.kde.org/cantor"
+KEYWORDS=""
+IUSE="analitza debug postscript python qalculate +R"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+# TODO Add Sage Mathematics Software backend (http://www.sagemath.org)
+RDEPEND="
+ analitza? ( $(add_kdebase_dep analitza) )
+ qalculate? (
+ sci-libs/cln
+ sci-libs/libqalculate
+ )
+ postscript? ( app-text/libspectre )
+ python? ( ${PYTHON_DEPS} )
+ R? ( dev-lang/R )
+ dev-qt/qtxmlpatterns:4
+"
+DEPEND="${RDEPEND}
+ >=dev-cpp/eigen-2.0.3:2
+"
+
+RESTRICT="test"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with analitza)
+ $(cmake-utils_use_with postscript LibSpectre)
+ $(cmake-utils_use_with python PythonLibs)
+ $(cmake-utils_use_with qalculate)
+ $(cmake-utils_use_with R)
+ )
+ kde4-base_src_configure
+}
+
+pkg_postinst() {
+ kde4-base_pkg_postinst
+
+ if ! use analitza && ! use python && ! use qalculate && ! use R; then
+ echo
+ ewarn "You have decided to build ${PN} with no backend."
+ ewarn "To have this application functional, please do one of below:"
+ ewarn " # emerge -va1 '='${CATEGORY}/${P} with 'analitza', 'python', 'qalculate' or 'R' USE flag enabled"
+ ewarn " # emerge -vaDu sci-mathematics/maxima"
+ echo
+ fi
+}