aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Callen <abcd@gentoo.org>2009-09-11 17:14:35 -0400
committerJonathan Callen <abcd@gentoo.org>2009-09-11 23:52:47 -0400
commit6658447f57b455e0534415f667137c57691a48ea (patch)
tree52a477bfc7f165ee6379b7731085da538e8842cf /kde-base/kcontrol/kcontrol-9999.ebuild
parentSimplify the add_blocker a bit. (diff)
downloadkde-6658447f57b455e0534415f667137c57691a48ea.tar.gz
kde-6658447f57b455e0534415f667137c57691a48ea.tar.bz2
kde-6658447f57b455e0534415f667137c57691a48ea.zip
Add a new add_kdebase_dep() function, and inject it everywhere
The add_kdebase_dep function takes 1-2 arguments, the first being the name of the package to depend upon, and the second being (optionally) extra USE deps. When given 1 argument, this function will output !kdeprefix? ( >=kde-base/$1-${PV}[-kdeprefix] ) kdeprefix? ( >=kde-base/$1-${PV}:${SLOT}[kdeprefix] ) And 2 arguments outputs !kdeprefix? ( >=kde-base/$1-${PV}[-kdeprefix,$2] ) kdeprefix? ( >=kde-base/$1-${PV}:${SLOT}[kdeprefix,$2] ) These are the proper deps to replace >=kde-base/PKG-${PV}:${SLOT}[kdeprefix=,USEDEPS] as it does not force an all-at-once upgrade of everything. Some of the deps (the ones from kde4-base.eclass) were already in this form, so there was an odd combination of packages that could be installed in separate slots with -kdeprefix, and packages that couldn't.
Diffstat (limited to 'kde-base/kcontrol/kcontrol-9999.ebuild')
-rw-r--r--kde-base/kcontrol/kcontrol-9999.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/kde-base/kcontrol/kcontrol-9999.ebuild b/kde-base/kcontrol/kcontrol-9999.ebuild
index df2e0f41ed..059140fa2c 100644
--- a/kde-base/kcontrol/kcontrol-9999.ebuild
+++ b/kde-base/kcontrol/kcontrol-9999.ebuild
@@ -17,6 +17,6 @@ RDEPEND="
!<kde-base/systemsettings-4.2.91[-kdeprefix]
)
kdeprefix? ( !<kde-base/systemsettings-4.2.91:${SLOT}[kdeprefix] )
- >=kde-base/kdnssd-${PV}:${SLOT}[kdeprefix=]
- >=kde-base/khotkeys-${PV}:${SLOT}[kdeprefix=]
+ $(add_kdebase_dep kdnssd)
+ $(add_kdebase_dep khotkeys)
"