aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2014-01-05 20:23:40 -0500
committerChris Reffett <creffett@gentoo.org>2014-01-05 20:23:53 -0500
commit6c163336b0ea3ea8d8927bdc48c186d982087c60 (patch)
treeb7c605c99f47346b0756009d7526ab4393c1cd37 /kde-base/kdebase-data/kdebase-data-4.11.5.ebuild
parent[Documentation/maintainers/bump_new_revision.sh] Make it not match (diff)
downloadkde-6c163336b0ea3ea8d8927bdc48c186d982087c60.tar.gz
kde-6c163336b0ea3ea8d8927bdc48c186d982087c60.tar.bz2
kde-6c163336b0ea3ea8d8927bdc48c186d982087c60.zip
[kde-base] Bump KDE SC 4.11.5
Package-Manager: portage-2.2.7 RepoMan-Options: --force
Diffstat (limited to 'kde-base/kdebase-data/kdebase-data-4.11.5.ebuild')
-rw-r--r--kde-base/kdebase-data/kdebase-data-4.11.5.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/kde-base/kdebase-data/kdebase-data-4.11.5.ebuild b/kde-base/kdebase-data/kdebase-data-4.11.5.ebuild
new file mode 100644
index 0000000000..332dffe237
--- /dev/null
+++ b/kde-base/kdebase-data/kdebase-data-4.11.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+KMNAME="kde-runtime"
+KMNOMODULE="true"
+inherit kde4-meta
+
+DESCRIPTION="Icons, localization data and various .desktop files from kdebase."
+IUSE="+wallpapers"
+KEYWORDS=" ~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ wallpapers? ( $(add_kdebase_dep kde-wallpapers) )
+ $(add_kdebase_dep oxygen-icons)
+ x11-themes/hicolor-icon-theme
+"
+
+KMEXTRA="
+ l10n/
+ localization/
+ pics/
+"
+# Note that the eclass doesn't do this for us, because of KMNOMODULE="true".
+KMEXTRACTONLY="
+ config-runtime.h.cmake
+ kde4
+"
+
+src_configure() {
+ # Remove remnants of hicolor-icon-theme
+ sed -e "s:add_subdirectory[[:space:]]*([[:space:]]*hicolor[[:space:]]*):#donotwant:g" \
+ -i pics/CMakeLists.txt \
+ || die "failed to remove remnants of hicolor-icon-theme"
+
+ kde4-meta_src_configure
+}