aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2013-06-27 20:31:26 +0200
committerJohannes Huber <johu@gentoo.org>2013-06-27 20:31:26 +0200
commit45431dd6c5c33fee64df49066071af601327e9db (patch)
tree27ada7c57c72ced5e0f8507d8624777626f03eb9 /kde-base/kontact/kontact-4.10.90.ebuild
parent[profiles/package.mask] Mask KDE SC 4.11 beta2. (diff)
downloadkde-45431dd6c5c33fee64df49066071af601327e9db.tar.gz
kde-45431dd6c5c33fee64df49066071af601327e9db.tar.bz2
kde-45431dd6c5c33fee64df49066071af601327e9db.zip
[kde-base] Add KDE SC 4.11 beta2.
Package-Manager: portage-2.2.0_alpha185
Diffstat (limited to 'kde-base/kontact/kontact-4.10.90.ebuild')
-rw-r--r--kde-base/kontact/kontact-4.10.90.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/kde-base/kontact/kontact-4.10.90.ebuild b/kde-base/kontact/kontact-4.10.90.ebuild
new file mode 100644
index 0000000000..38741b92b0
--- /dev/null
+++ b/kde-base/kontact/kontact-4.10.90.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+KMNAME="kdepim"
+inherit kde4-meta
+
+DESCRIPTION="KDE personal information manager"
+KEYWORDS=" ~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+DEPEND="
+ $(add_kdebase_dep kdepimlibs)
+ $(add_kdebase_dep kdepim-common-libs)
+"
+RDEPEND="${DEPEND}"
+
+KMLOADLIBS="kdepim-common-libs"
+KMSAVELIBS="true"
+
+# We remove plugins that are related to external kdepim programs. This way
+# kontact doesn't have to depend on all programs it has plugins for.
+# kcontactmanager gone from kdesvn
+#
+KMEXTRACTONLY="
+ kontact/plugins/akregator/
+ kontact/plugins/kaddressbook/
+ kontact/plugins/kjots/
+ kontact/plugins/kmail/
+ kontact/plugins/knode/
+ kontact/plugins/knotes/
+ kontact/plugins/korganizer/
+ kontact/plugins/ktimetracker/
+ kontact/plugins/planner/
+ kontact/plugins/specialdates/
+ libkdepimdbusinterfaces/
+"
+
+src_unpack() {
+ if use handbook; then
+ KMEXTRA+="
+ doc/kontact-admin/
+ "
+ fi
+
+ kde4-meta_src_unpack
+}