aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2014-03-28 00:30:44 +0100
committerJohannes Huber <johu@gentoo.org>2014-03-28 00:30:44 +0100
commit1dc24bb29215f240192dcaedadc09cbb65d8fa75 (patch)
treecc7dce62d3c673f0da1d252bceb5bba9d6f21ace /kde-base/kopete
parent[kde-frameworks/kio] Add new dependency. (diff)
downloadkde-1dc24bb29215f240192dcaedadc09cbb65d8fa75.tar.gz
kde-1dc24bb29215f240192dcaedadc09cbb65d8fa75.tar.bz2
kde-1dc24bb29215f240192dcaedadc09cbb65d8fa75.zip
[kde-base] Add KDE SC 4.13 rc 1
Package-Manager: portage-2.2.10
Diffstat (limited to 'kde-base/kopete')
-rw-r--r--kde-base/kopete/Manifest1
-rw-r--r--kde-base/kopete/kopete-4.12.97.ebuild159
2 files changed, 160 insertions, 0 deletions
diff --git a/kde-base/kopete/Manifest b/kde-base/kopete/Manifest
index 9464aa746e..ab364cfca2 100644
--- a/kde-base/kopete/Manifest
+++ b/kde-base/kopete/Manifest
@@ -1 +1,2 @@
DIST kopete-4.12.95.tar.xz 6313536 SHA256 3c7e8451c005858210b8e2b908702e0228ab75deea4f29899574a06447c3f914 SHA512 2eb9b7ef86e1b97819871c1eb6c3c7e9f62bab869a7921e711a8c15c4e41f7848e0702ceee73edad025710c56e8fa265623515105265fdd9a6a8d99d5926dc1e WHIRLPOOL 7cba2073b9edda956aeff82c4f0b4e1c018db23ff5397a543f10c79efb8f22be3b244e80ed62b23e55c3cdf1f053797de8247d2bba8461f824a7376b24cc74ce
+DIST kopete-4.12.97.tar.xz 6313424 SHA256 68c56e2c1a8e12461fc4592f5be8d236ebf13e9effcb5a18043ed11e2a77df7c SHA512 ea0f6c19c902c1d92ddf26b95163d79dc690418ac4fb39139ae8a3eea1bce3e6ef6d9e461fe5ea49ad2a89ec2309716ff97d0034f34574557c541a63720111c8 WHIRLPOOL 438198f4ffa74ac4b83e3f53af6bad26067b9ebe7fba804d5652c362ecbb85a994fbc511adfddfbc38f5c89bde25a6b0153647113b9b88b3c0075e176ee13dfe
diff --git a/kde-base/kopete/kopete-4.12.97.ebuild b/kde-base/kopete/kopete-4.12.97.ebuild
new file mode 100644
index 0000000000..1f748f2e99
--- /dev/null
+++ b/kde-base/kopete/kopete-4.12.97.ebuild
@@ -0,0 +1,159 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+inherit kde4-base
+
+DESCRIPTION="KDE multi-protocol IM client"
+HOMEPAGE="http://kopete.kde.org http://www.kde.org/applications/internet/kopete"
+KEYWORDS=" ~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug ssl v4l"
+
+# tests hang, last checked for 4.2.96
+RESTRICT=test
+
+# Available plugins
+#
+# addbookmarks: NO DEPS
+# alias: NO DEPS (disabled upstream)
+# autoreplace: NO DEPS
+# contactnotes: NO DEPS
+# highlight: NO DEPS
+# history: NO DEPS
+# latex: virtual/latex as RDEPEND
+# nowlistening: NO DEPS
+# otr: libotr
+# pipes: NO DEPS
+# privacy: NO DEPS
+# statistics: dev-db/sqlite:3
+# texteffect: NO DEPS
+# translator: NO DEPS
+# urlpicpreview: NO DEPS
+# webpresence: libxml2 libxslt
+# NOTE: By default we enable all plugins that don't have any dependencies
+PLUGINS="+addbookmarks +autoreplace +contactnotes +highlight +history latex
++nowlistening otr +pipes +privacy +statistics +texteffect +translator
++urlpicpreview webpresence"
+
+# Available protocols
+#
+# gadu: net-libs/libgadu @since 4.3
+# groupwise: app-crypt/qca:2
+# irc: NO DEPS, probably will fail so inform user about it
+# xmpp: net-dns/libidn app-crypt/qca:2 ENABLED BY DEFAULT NETWORK
+# jingle: media-libs/speex net-libs/ortp DISABLED BY UPSTREAM
+# meanwhile: net-libs/meanwhile
+# msn: libmsn == this is wlm plugin, we disable msn one
+# oscar: NO DEPS
+# telepathy: net-libs/decibel
+# testbed: NO DEPS
+# winpopup: NO DEPS (we're adding samba as RDEPEND so it works)
+# yahoo: media-libs/jasper
+# zeroconf (bonjour): NO DEPS
+PROTOCOLS="gadu groupwise jingle meanwhile msn oscar skype
+sms testbed winpopup +xmpp yahoo zeroconf"
+
+# disabled protocols
+# telepathy: net-libs/decibel
+# irc: NO DEPS
+# qq: NO DEPS
+
+IUSE="${IUSE} ${PLUGINS} ${PROTOCOLS}"
+
+COMMONDEPEND="
+ dev-libs/libpcre
+ $(add_kdebase_dep kdepimlibs)
+ media-libs/qimageblitz
+ >=dev-qt/qtgui-4.4.0:4[mng]
+ !aqua? ( x11-libs/libXScrnSaver )
+ gadu? ( >=net-libs/libgadu-1.8.0[threads] )
+ groupwise? ( app-crypt/qca:2 )
+ jingle? (
+ >=media-libs/mediastreamer-2.3.0
+ media-libs/speex
+ net-libs/ortp:=
+ )
+ meanwhile? ( net-libs/meanwhile )
+ msn? ( >=net-libs/libmsn-4.1 )
+ otr? ( >=net-libs/libotr-4.0.0 )
+ statistics? ( dev-db/sqlite:3 )
+ v4l? ( media-libs/libv4l )
+ webpresence? (
+ dev-libs/libxml2
+ dev-libs/libxslt
+ )
+ xmpp? (
+ app-crypt/qca:2
+ net-dns/libidn
+ )
+ yahoo? ( media-libs/jasper )
+"
+RDEPEND="${COMMONDEPEND}
+ latex? (
+ || (
+ media-gfx/imagemagick
+ media-gfx/graphicsmagick[imagemagick]
+ )
+ virtual/latex-base
+ )
+ sms? ( app-mobilephone/smssend )
+ ssl? ( app-crypt/qca-ossl )
+ winpopup? ( net-fs/samba )
+"
+# telepathy? ( net-libs/decibel )"
+DEPEND="${COMMONDEPEND}
+ !aqua? ( x11-proto/scrnsaverproto )
+"
+
+src_configure() {
+ local x x2
+ # Handle common stuff
+ mycmakeargs=(
+ $(cmake-utils_use_with jingle GOOGLETALK)
+ $(cmake-utils_use_with jingle LiboRTP)
+ $(cmake-utils_use_with jingle Mediastreamer)
+ $(cmake-utils_use_with jingle Speex)
+ $(cmake-utils_use_disable v4l VIDEOSUPPORT)
+ )
+ # enable protocols
+ for x in ${PROTOCOLS}; do
+ case ${x/+/} in
+ msn) x2=Libmsn ;;
+ zeroconf) x2=bonjour ;;
+ xmpp) x2=jabber ;;
+ *) x2='' ;;
+ esac
+ mycmakeargs+=($(cmake-utils_use_with ${x/+/} ${x2}))
+ done
+
+ mycmakeargs+=( -DWITH_qq=OFF )
+
+ # enable plugins
+ for x in ${PLUGINS}; do
+ mycmakeargs+=($(cmake-utils_use_with ${x/+/}))
+ done
+
+ kde4-base_src_configure
+}
+
+pkg_postinst() {
+ kde4-base_pkg_postinst
+
+ #if use telepathy; then
+ # elog "To use kopete telepathy plugins, you need to start gabble first:"
+ # elog "GABBLE_PERSIST=1 telepathy-gabble &"
+ # elog "export TELEPATHY_DATA_PATH='${EPREFIX}/usr/share/telepathy/managers/'"
+ #fi
+
+ if ! use ssl; then
+ if use xmpp || use msn; then # || use irc; then
+ if ! has_version app-crypt/qca-ossl ; then
+ elog "In order to use ssl in xmpp and msn you'll need to"
+ elog "install app-crypt/qca-ossl package."
+ fi
+ fi
+ fi
+}