aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2012-12-01 17:11:37 +0400
committerAlexey Shvetsov <alexxy@gentoo.org>2012-12-01 17:11:37 +0400
commit33d60ab6fc9c40d1fd636106b70135f49160c0df (patch)
tree85ef248da0c016c0f7b0404ae93a88abab2f3a52 /kde-base/ksysguard
parent[net-libs/libkolab] Fix HOMEPAGE. (diff)
downloadkde-33d60ab6fc9c40d1fd636106b70135f49160c0df.tar.gz
kde-33d60ab6fc9c40d1fd636106b70135f49160c0df.tar.bz2
kde-33d60ab6fc9c40d1fd636106b70135f49160c0df.zip
[kde-base] Add KDE SC 4.9.4
Signed-off-by: Alexey Shvetsov <alexxy@gentoo.org>
Diffstat (limited to 'kde-base/ksysguard')
-rw-r--r--kde-base/ksysguard/Manifest1
-rw-r--r--kde-base/ksysguard/ksysguard-4.9.4.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/kde-base/ksysguard/Manifest b/kde-base/ksysguard/Manifest
index 20ca4df018..8d8a0f7bbe 100644
--- a/kde-base/ksysguard/Manifest
+++ b/kde-base/ksysguard/Manifest
@@ -1 +1,2 @@
+DIST kde-workspace-4.9.4.tar.xz 22465172 SHA256 879afa08125dae6d136d1e4161f83a5c57378337c540c474e1321d75545a1cc7 SHA512 d5f601f5db92ccfd3da2684993210b23162b748ed19ef5ed9390de2dc58534f48d0c60034476548cb64cb80bba92af940337a0de34293afbaf965ff164258ad1 WHIRLPOOL 1d77d37d7a053b6cc43fe91b9a1bb090f51c18dc1c89f4762533ec19bfcf9577f359db0142bda0f2628a0909a56ee85ef4bae413184fad69254ffa3619c69f3e
DIST kde-workspace-4.9.80.tar.xz 22389576 SHA256 a360fd00bb31c5cf1e965cb7ab0fd8c6aa46293304fe2c1a72c80a44e68f9d52 SHA512 98914379f74d37fcadf28627c8ef6cc5002f88b0ec1a1fa302a7cc3c656277231bfa60e340d75c4f160058f2a373246786abeecbb1d10a56d3f3eca59bea0e87 WHIRLPOOL 2116344008f12c214665654ea89fa11373ced1f390e19c9a97acaa5ae35d2760b842c2731535cdb361f9046c6a6076bed4cc4e1c96dc3ddc7942e5d3c9a6be23
diff --git a/kde-base/ksysguard/ksysguard-4.9.4.ebuild b/kde-base/ksysguard/ksysguard-4.9.4.ebuild
new file mode 100644
index 0000000000..73561b7ae2
--- /dev/null
+++ b/kde-base/ksysguard/ksysguard-4.9.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+KMNAME="kde-workspace"
+CPPUNIT_REQUIRED="optional"
+VIRTUALX_REQUIRED=test
+inherit kde4-meta
+
+DESCRIPTION="KSysguard is a network enabled task manager and system monitor application."
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug lm_sensors test"
+
+COMMONDEPEND="
+ x11-libs/libXrender
+ x11-libs/libXres
+ lm_sensors? ( sys-apps/lm_sensors )
+"
+DEPEND="${COMMONDEPEND}
+ x11-proto/renderproto
+"
+RDEPEND="${COMMONDEPEND}"
+
+RESTRICT="test"
+# bug 393091
+
+KMEXTRA="
+ libs/ksysguard/
+"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with lm_sensors Sensors)
+ )
+
+ kde4-meta_src_configure
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+ ewarn "Note that ksysguard has powerful features; one of these is the executing of arbitrary"
+ ewarn "programs with elevated privileges (as data sources). So be careful opening worksheets"
+ ewarn "from untrusted sources!"
+}