aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2013-07-09 21:16:21 +0200
committerJohannes Huber <johu@gentoo.org>2013-07-09 21:16:21 +0200
commit33092a6b61014ba2e3293a7b04be21d77018a6ba (patch)
tree0496ea67458da6b3d8cd5b3cec3785fef84bdc76 /kde-base/phonon-kde
parent[sets] Fix kde-4.11 set. (diff)
downloadkde-33092a6b61014ba2e3293a7b04be21d77018a6ba.tar.gz
kde-33092a6b61014ba2e3293a7b04be21d77018a6ba.tar.bz2
kde-33092a6b61014ba2e3293a7b04be21d77018a6ba.zip
[kde-base] Add KDE/4.11 stable branch (4.11.49.9999).
Package-Manager: portage-2.2.0_alpha187
Diffstat (limited to 'kde-base/phonon-kde')
-rw-r--r--kde-base/phonon-kde/phonon-kde-4.11.49.9999.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/kde-base/phonon-kde/phonon-kde-4.11.49.9999.ebuild b/kde-base/phonon-kde/phonon-kde-4.11.49.9999.ebuild
new file mode 100644
index 0000000000..89e30367bf
--- /dev/null
+++ b/kde-base/phonon-kde/phonon-kde-4.11.49.9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+KMNAME="kde-runtime"
+KMMODULE="phonon"
+inherit kde4-meta
+
+DESCRIPTION="Phonon KDE Integration"
+HOMEPAGE="http://phonon.kde.org"
+KEYWORDS=""
+IUSE="alsa debug pulseaudio"
+
+DEPEND="
+ >=media-libs/phonon-4.4.3
+ alsa? ( media-libs/alsa-lib )
+ pulseaudio? (
+ dev-libs/glib:2
+ media-libs/libcanberra
+ >=media-sound/pulseaudio-0.9.21[glib]
+ )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ -DBUILD_tests=OFF
+ -DWITH_Xine=OFF
+ $(cmake-utils_use_with alsa)
+ $(cmake-utils_use_with pulseaudio PulseAudio)
+ )
+
+ kde4-meta_src_configure
+}