aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-12-05 20:37:01 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-12-05 21:46:44 +0100
commit4bbc4ca196552a94b1e48e37366bdab4f3f62001 (patch)
treeb3b3f8538ca136539ae85cee01e5b388d0b0ae4d /kde-frameworks/kauth
parentkde-frameworks/kactivities: 5.77.0 version bump (diff)
downloadkde-4bbc4ca196552a94b1e48e37366bdab4f3f62001.tar.gz
kde-4bbc4ca196552a94b1e48e37366bdab4f3f62001.tar.bz2
kde-4bbc4ca196552a94b1e48e37366bdab4f3f62001.zip
kde-frameworks/kauth: 5.77.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kauth')
-rw-r--r--kde-frameworks/kauth/Manifest1
-rw-r--r--kde-frameworks/kauth/kauth-5.77.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/kde-frameworks/kauth/Manifest b/kde-frameworks/kauth/Manifest
new file mode 100644
index 0000000000..7aab2a5087
--- /dev/null
+++ b/kde-frameworks/kauth/Manifest
@@ -0,0 +1 @@
+DIST kauth-5.77.0.tar.xz 87984 BLAKE2B 014ce49db855fb7f07874c03fb5d4d49e8dae616c96840eae4c11faeddcd96e7a785b314d1a3119f6c138f7981a3e61e2fd546d40f57fb59d363d87f1c283ce9 SHA512 d135dbbdb3548468e87a2b06e20af3597d8ad3bf22c6e8ede8ebee05173a347205a966abf30db1af5d3e0f316a25807fb18f7219e4c58e4376cb9b749a9c5023
diff --git a/kde-frameworks/kauth/kauth-5.77.0.ebuild b/kde-frameworks/kauth/kauth-5.77.0.ebuild
new file mode 100644
index 0000000000..d2593910f3
--- /dev/null
+++ b/kde-frameworks/kauth/kauth-5.77.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.1
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Framework to let applications perform actions as a privileged user"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="nls +policykit"
+
+BDEPEND="
+ nls? ( >=dev-qt/linguist-tools-${QTMIN}:5 )
+"
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ policykit? ( >=sys-auth/polkit-qt-0.113.0 )
+"
+RDEPEND="${DEPEND}"
+PDEPEND="policykit? ( kde-plasma/polkit-kde-agent )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_PythonModuleGeneration=ON # bug 746866
+ $(cmake_use_find_package policykit PolkitQt5-1)
+ )
+
+ ecm_src_configure
+}
+
+src_test() {
+ # KAuthHelperTest test fails, bug 654842
+ local myctestargs=(
+ -E "(KAuthHelperTest)"
+ )
+
+ ecm_src_test
+}