aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-11-04 16:50:11 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-11-10 18:06:53 +0100
commitcc403116185501b65c67ccfb61515cec1141e668 (patch)
treeb01754f07e6f37012f67f309e854d2ca8de184d2 /kde-frameworks/sonnet/sonnet-9999.ebuild
parentkde-apps: KDE_DESIGNERPLUGIN -> ECM_DESIGNERPLUGIN (diff)
downloadkde-cc403116185501b65c67ccfb61515cec1141e668.tar.gz
kde-cc403116185501b65c67ccfb61515cec1141e668.tar.bz2
kde-cc403116185501b65c67ccfb61515cec1141e668.zip
kde-frameworks: Port 9999 to ecm.eclass and kde.org.eclass
Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/sonnet/sonnet-9999.ebuild')
-rw-r--r--kde-frameworks/sonnet/sonnet-9999.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/kde-frameworks/sonnet/sonnet-9999.ebuild b/kde-frameworks/sonnet/sonnet-9999.ebuild
index d708303c5d..61c74789ac 100644
--- a/kde-frameworks/sonnet/sonnet-9999.ebuild
+++ b/kde-frameworks/sonnet/sonnet-9999.ebuild
@@ -4,8 +4,9 @@
EAPI=7
ECM_DESIGNERPLUGIN="true"
+QTMIN=5.12.3
VIRTUALX_REQUIRED="test"
-inherit kde5
+inherit ecm kde.org
DESCRIPTION="Framework for providing spell-checking through abstraction of popular backends"
LICENSE="LGPL-2+ LGPL-2.1+"
@@ -13,11 +14,11 @@ KEYWORDS=""
IUSE="aspell +hunspell nls"
BDEPEND="
- nls? ( $(add_qt_dep linguist-tools) )
+ nls? ( >=dev-qt/linguist-tools-${QTMIN}:5 )
"
DEPEND="
- $(add_qt_dep qtgui)
- $(add_qt_dep qtwidgets)
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
aspell? ( app-text/aspell )
hunspell? ( app-text/hunspell:= )
"
@@ -29,7 +30,7 @@ src_configure() {
$(cmake-utils_use_find_package hunspell HUNSPELL)
)
- kde5_src_configure
+ ecm_src_configure
}
src_test() {
@@ -38,5 +39,5 @@ src_test() {
-E "(sonnet-test_settings|sonnet-test_highlighter)"
)
- kde5_src_test
+ ecm_src_test
}