aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-09-05 23:13:18 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-09-05 23:40:46 +0200
commit86060148e19c8e4fe2243ac224d14d07dea04517 (patch)
tree034e6b18e4f742155afe6fb030d95550d685b6b9 /kde-frameworks/syntax-highlighting
parentkde-frameworks/sonnet: 5.98.0 version bump (diff)
downloadkde-86060148e19c8e4fe2243ac224d14d07dea04517.tar.gz
kde-86060148e19c8e4fe2243ac224d14d07dea04517.tar.bz2
kde-86060148e19c8e4fe2243ac224d14d07dea04517.zip
kde-frameworks/syntax-highlighting: 5.98.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/syntax-highlighting')
-rw-r--r--kde-frameworks/syntax-highlighting/Manifest1
-rw-r--r--kde-frameworks/syntax-highlighting/syntax-highlighting-5.98.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/kde-frameworks/syntax-highlighting/Manifest b/kde-frameworks/syntax-highlighting/Manifest
new file mode 100644
index 0000000000..0bba2a1353
--- /dev/null
+++ b/kde-frameworks/syntax-highlighting/Manifest
@@ -0,0 +1 @@
+DIST syntax-highlighting-5.98.0.tar.xz 2443264 BLAKE2B d4e49a180d928b8929c1f1716f32deacd9b2769aa58643860ac468dd9c175ec2673dc917c1bb8efd07f51e4734401a8367de987cbbcbad1e13109e6b1220d37e SHA512 7e5ec4e184abedb69c6e31f68cd717ecce2ec0cd5f4b3974bb83426775161951ba346c711da15b15eb3bf2b1b0651954e02de12b8c27f21b7a15f7fae98cb06a
diff --git a/kde-frameworks/syntax-highlighting/syntax-highlighting-5.98.0.ebuild b/kde-frameworks/syntax-highlighting/syntax-highlighting-5.98.0.ebuild
new file mode 100644
index 0000000000..1cb111a4cf
--- /dev/null
+++ b/kde-frameworks/syntax-highlighting/syntax-highlighting-5.98.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="forceoptional"
+QTMIN=5.15.5
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="Framework for syntax highlighting"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="nls"
+
+DEPEND="
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtxmlpatterns-${QTMIN}:5
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-lang/perl
+ nls? ( >=dev-qt/linguist-tools-${QTMIN}:5 )
+"
+
+src_install() {
+ ecm_src_install
+ dobin "${BUILD_DIR}"/bin/katehighlightingindexer
+}