aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-05-24 20:47:15 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-05-24 21:25:48 +0200
commit157f852d28afbbfa53f6ae9e69a18883ee586702 (patch)
tree10239619bcc00ee7904108639974f50bce2a1978 /kde-plasma/kwallet-pam
parentkde-plasma/ksystemstats: 6.1.49.9999 version bump (diff)
downloadkde-157f852d28afbbfa53f6ae9e69a18883ee586702.tar.gz
kde-157f852d28afbbfa53f6ae9e69a18883ee586702.tar.bz2
kde-157f852d28afbbfa53f6ae9e69a18883ee586702.zip
kde-plasma/kwallet-pam: 6.1.49.9999 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kwallet-pam')
-rw-r--r--kde-plasma/kwallet-pam/kwallet-pam-6.1.49.9999.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/kde-plasma/kwallet-pam/kwallet-pam-6.1.49.9999.ebuild b/kde-plasma/kwallet-pam/kwallet-pam-6.1.49.9999.ebuild
new file mode 100644
index 0000000000..e26da93bce
--- /dev/null
+++ b/kde-plasma/kwallet-pam/kwallet-pam-6.1.49.9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=6.2.0
+inherit ecm plasma.kde.org
+
+DESCRIPTION="PAM module to not enter KWallet password again after login"
+
+LICENSE="LGPL-2.1"
+SLOT="6"
+KEYWORDS=""
+IUSE=""
+
+DEPEND="
+ dev-libs/libgcrypt:0=
+ >=kde-frameworks/kwallet-${KFMIN}:6
+ sys-libs/pam
+"
+RDEPEND="${DEPEND}
+ net-misc/socat
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_LIBDIR="/$(get_libdir)"
+ )
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+ elog "This package enables auto-unlocking of kde-frameworks/kwallet:6."
+ elog "See also: https://wiki.gentoo.org/wiki/KDE#KWallet_auto-unlocking"
+}