aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-10-06 15:53:18 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-10-06 16:48:06 +0200
commit51b0681b60cb2dc10544967d898adf37db77738d (patch)
treeed3272d1105f39620cb84f7262444041034fe137 /kde-plasma/plasma-firewall
parentkde-plasma/plasma-disks: 5.26.0 version bump (diff)
downloadkde-51b0681b60cb2dc10544967d898adf37db77738d.tar.gz
kde-51b0681b60cb2dc10544967d898adf37db77738d.tar.bz2
kde-51b0681b60cb2dc10544967d898adf37db77738d.zip
kde-plasma/plasma-firewall: 5.26.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/plasma-firewall')
-rw-r--r--kde-plasma/plasma-firewall/Manifest1
-rw-r--r--kde-plasma/plasma-firewall/plasma-firewall-5.26.0.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/kde-plasma/plasma-firewall/Manifest b/kde-plasma/plasma-firewall/Manifest
index 6e3ff163f7..7cd73284f4 100644
--- a/kde-plasma/plasma-firewall/Manifest
+++ b/kde-plasma/plasma-firewall/Manifest
@@ -1 +1,2 @@
DIST plasma-firewall-5.25.90.tar.xz 358344 BLAKE2B 60d85fdb6d4355607cf2eb00a1bb923e2f6a5c0e5cd4dc2a56c0e4ea8d87699303669b5f3e30be9f4679574f3bf20078ea749809e5d3a07294c7568ec7f34fa3 SHA512 5e50eb8d2f9c3569dea3dd1ab387d54f216480413504c48f1d39f0a99b95aab3b38a17445d4358f69f4024f4dc044fae2fa36aec037211e790324b7a5c2baa96
+DIST plasma-firewall-5.26.0.tar.xz 358416 BLAKE2B eee92edd9cc2e766d5e01991921b35af4edb4d662b7b3c76dd54bbddbeecfb53197d93baa4f12ad8f09e9b1291150efad80153d5fa0f243ccfed82fd6a2caecb SHA512 38078dc4039424f09a879663b8129ba91725bb52e3a599a30618b129d01281c0538bb37995d43e6e00055961700e91d6caa78eadc51ff5262d1e4c19cd047dca
diff --git a/kde-plasma/plasma-firewall/plasma-firewall-5.26.0.ebuild b/kde-plasma/plasma-firewall/plasma-firewall-5.26.0.ebuild
new file mode 100644
index 0000000000..6523986c69
--- /dev/null
+++ b/kde-plasma/plasma-firewall/plasma-firewall-5.26.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+KFMIN=5.98.0
+QTMIN=5.15.5
+inherit ecm plasma.kde.org python-single-r1
+
+DESCRIPTION="Plasma frontend for Firewalld or UFW"
+HOMEPAGE="https://invent.kde.org/network/plasma-firewall"
+
+LICENSE="GPL-2+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="firewalld +ufw"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE} || ( firewalld ufw )"
+
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtx11extras-${QTMIN}:5
+ >=dev-qt/qtxml-${QTMIN}:5
+ >=kde-frameworks/kauth-${KFMIN}:5
+ >=kde-frameworks/kcmutils-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdeclarative-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+"
+RDEPEND="${DEPEND}
+ ${PYTHON_DEPS}
+ firewalld? ( net-firewall/firewalld )
+ ufw? ( net-firewall/ufw )
+"
+
+src_prepare() {
+ ecm_src_prepare
+ # this kind of cmake magic doesn't work for us at all.
+ sed -e "1 s:^.*$:\#\!/usr/bin/env ${EPYTHON}:" \
+ -i kcm/backends/ufw/helper/kcm_ufw_helper.py.cmake || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_FIREWALLD_BACKEND=$(usex firewalld)
+ -DBUILD_UFW_BACKEND=$(usex ufw)
+ )
+ ecm_src_configure
+}
+
+pkg_postinst () {
+ ecm_pkg_postinst
+
+ if ! has_version sys-apps/systemd; then
+ ewarn "${PN} is not functional without sys-apps/systemd at this point."
+ ewarn "See also: https://bugs.gentoo.org/778527"
+ fi
+}