aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-text/kbibtex/kbibtex-9999.ebuild33
-rw-r--r--app-text/kbibtex/metadata.xml5
-rw-r--r--profiles/categories1
3 files changed, 39 insertions, 0 deletions
diff --git a/app-text/kbibtex/kbibtex-9999.ebuild b/app-text/kbibtex/kbibtex-9999.ebuild
new file mode 100644
index 0000000000..8bb05a650b
--- /dev/null
+++ b/app-text/kbibtex/kbibtex-9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit versionator kde4-base
+
+DESCRIPTION="BibTeX editor for KDE to edit bibliographies used with LaTeX"
+HOMEPAGE="http://home.gna.org/kbibtex/"
+if [[ ${PV} != *9999* ]]; then
+ SRC_URI="http://download.gna.org/${PN}/$(get_version_component_range 1-2)/${P/_/-}.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+else
+ ESVN_REPO_URI="svn://svn.gna.org/svn/${PN}/trunk"
+ ESVN_PROJECT="${PN}"
+ KEYWORDS=""
+fi
+
+LICENSE="GPL-2"
+SLOT="4"
+IUSE="debug"
+
+DEPEND="
+ app-text/poppler[qt4]
+ dev-libs/libxml2
+ dev-libs/libxslt
+ virtual/tex-base
+"
+RDEPEND="${DEPEND}
+ dev-tex/bibtex2html"
+
+S=${WORKDIR}/${P/_/-}
diff --git a/app-text/kbibtex/metadata.xml b/app-text/kbibtex/metadata.xml
new file mode 100644
index 0000000000..8d1e86a9ce
--- /dev/null
+++ b/app-text/kbibtex/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>kde</herd>
+</pkgmetadata>
diff --git a/profiles/categories b/profiles/categories
index 557bbf3fc2..79989028e2 100644
--- a/profiles/categories
+++ b/profiles/categories
@@ -6,6 +6,7 @@ app-misc
app-office
app-pda
app-portage
+app-text
dev-cpp
dev-db
dev-libs