aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/dolphin/dolphin-4.10.90.ebuild')
-rw-r--r--kde-base/dolphin/dolphin-4.10.90.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/kde-base/dolphin/dolphin-4.10.90.ebuild b/kde-base/dolphin/dolphin-4.10.90.ebuild
new file mode 100644
index 0000000000..b0d487933c
--- /dev/null
+++ b/kde-base/dolphin/dolphin-4.10.90.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+KMNAME="kde-baseapps"
+inherit kde4-meta
+
+DESCRIPTION="A KDE filemanager focusing on usability"
+KEYWORDS=" ~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug thumbnail"
+
+DEPEND="
+ $(add_kdebase_dep kactivities)
+ $(add_kdebase_dep libkonq)
+ $(add_kdebase_dep nepomuk-core)
+ $(add_kdebase_dep nepomuk-widgets)
+ >=dev-libs/shared-desktop-ontologies-0.11.0
+ dev-libs/soprano
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep kfind)
+"
+PDEPEND="
+ thumbnail? (
+ $(add_kdebase_dep thumbnailers)
+ || (
+ $(add_kdebase_dep ffmpegthumbs)
+ $(add_kdebase_dep mplayerthumbs)
+ )
+ )
+"
+
+KMLOADLIBS="libkonq"
+
+RESTRICT="test"
+# bug 393129
+
+pkg_postinst() {
+ kde4-base_pkg_postinst
+
+ if ! has_version media-gfx/icoutils ; then
+ elog "For .exe file preview support, install media-gfx/icoutils."
+ fi
+}