aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kajongg/kajongg-4.10.90.ebuild')
-rw-r--r--kde-base/kajongg/kajongg-4.10.90.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/kde-base/kajongg/kajongg-4.10.90.ebuild b/kde-base/kajongg/kajongg-4.10.90.ebuild
new file mode 100644
index 0000000000..bae0410eb3
--- /dev/null
+++ b/kde-base/kajongg/kajongg-4.10.90.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+PYTHON_DEPEND="2:2.6"
+inherit kde4-base python
+
+DESCRIPTION="The classical Mah Jongg for four players"
+KEYWORDS=" ~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+DEPEND="
+ dev-db/sqlite:3
+ $(add_kdebase_dep libkdegames)
+ $(add_kdebase_dep pykde4)
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep libkmahjongg)
+ >=dev-python/twisted-8.2.0
+"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+ kde4-base_pkg_setup
+}
+
+src_prepare() {
+ python_convert_shebangs -r 2 src
+ kde4-base_src_prepare
+}