summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-arcade/flyinggame/ChangeLog6
-rw-r--r--games-arcade/flyinggame/Manifest1
-rw-r--r--games-arcade/flyinggame/flyinggame-0.ebuild27
-rw-r--r--games-arcade/flyinggame/metadata.xml14
-rw-r--r--games-arcade/mari0/mari0-1.6.ebuild4
-rw-r--r--games-arcade/nottetris/ChangeLog6
-rw-r--r--games-arcade/nottetris/Manifest1
-rw-r--r--games-arcade/nottetris/metadata.xml14
-rw-r--r--games-arcade/nottetris/nottetris-2.ebuild44
-rw-r--r--games-arcade/orthorobot/ChangeLog6
-rw-r--r--games-arcade/orthorobot/Manifest1
-rw-r--r--games-arcade/orthorobot/metadata.xml14
-rw-r--r--games-arcade/orthorobot/orthorobot-0.ebuild40
-rw-r--r--games-arcade/rimshot/ChangeLog6
-rw-r--r--games-arcade/rimshot/Manifest1
-rw-r--r--games-arcade/rimshot/metadata.xml14
-rw-r--r--games-arcade/rimshot/rimshot-0.ebuild41
-rw-r--r--games-arcade/shoothookers/ChangeLog6
-rw-r--r--games-arcade/shoothookers/Manifest1
-rw-r--r--games-arcade/shoothookers/metadata.xml14
-rw-r--r--games-arcade/shoothookers/shoothookers-0.ebuild27
-rw-r--r--games-arcade/snayke/snayke-2.4.ebuild2
22 files changed, 287 insertions, 3 deletions
diff --git a/games-arcade/flyinggame/ChangeLog b/games-arcade/flyinggame/ChangeLog
new file mode 100644
index 0000000..6318f81
--- /dev/null
+++ b/games-arcade/flyinggame/ChangeLog
@@ -0,0 +1,6 @@
+*snayke-2.4 (22 Apr 2012)
+
+ 22 Apr 2012; Misbakh-Soloviov Vadim A. <mva@gentoo.org> +metadata.xml,
+ +snayke-2.4.ebuild:
+ bump!
+
diff --git a/games-arcade/flyinggame/Manifest b/games-arcade/flyinggame/Manifest
new file mode 100644
index 0000000..1cc4978
--- /dev/null
+++ b/games-arcade/flyinggame/Manifest
@@ -0,0 +1 @@
+DIST flyinggame-0.zip 133179 SHA256 a5b86e0c212f5d6043f0e5637a5fad684d79cab4f05e999b6228d2550928d40f SHA512 d8d92a6cfb00298b71be5c73e16b7bab5c593ff373090045bf97d4d92c5511444edd26d1392b795aa482ade43bd61243cd36b4056b39791ef9db230da4b6a654 WHIRLPOOL 855736e45bf5280ed9606be3e8ddfb71584b66e546a06abbcc94356e3808e68f41a4761aa3a56612b6ca8356c67b08d081cf588bd7f53d95ad0328834a2ff142
diff --git a/games-arcade/flyinggame/flyinggame-0.ebuild b/games-arcade/flyinggame/flyinggame-0.ebuild
new file mode 100644
index 0000000..6c847bd
--- /dev/null
+++ b/games-arcade/flyinggame/flyinggame-0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: This ebuild is from Lua overlay; Bumped by mva; $
+
+EAPI="3"
+
+inherit eutils games
+
+DESCRIPTION="A game prototype by Maurice (mari0 author)"
+HOMEPAGE="http://stabyourself.net/other/"
+SRC_URI="http://stabyourself.net/dl.php?file=${PN}/${PN}.love -> ${P}.zip"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT=""
+
+DEPEND=">=games-engines/love-0.8.0"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+src_install() {
+ insinto "/usr/share/games/love/${P}"
+ doins -r .
+ games_make_wrapper "${PN}" "love /usr/share/games/love/${P}"
+}
diff --git a/games-arcade/flyinggame/metadata.xml b/games-arcade/flyinggame/metadata.xml
new file mode 100644
index 0000000..23da526
--- /dev/null
+++ b/games-arcade/flyinggame/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>mva@mva.name</email>
+ <description>
+ If you have any issues, please contact me, or try to find me in IRC on Freenode, OFTC or RusNet.
+ </description>
+ <name>Vadim A. Misbakh-Soloviov</name>
+</maintainer>
+<longdescription>FIXME</longdescription>
+<use>
+</use>
+</pkgmetadata>
diff --git a/games-arcade/mari0/mari0-1.6.ebuild b/games-arcade/mari0/mari0-1.6.ebuild
index b97e526..0993802 100644
--- a/games-arcade/mari0/mari0-1.6.ebuild
+++ b/games-arcade/mari0/mari0-1.6.ebuild
@@ -7,7 +7,7 @@ EAPI="3"
inherit eutils games
DESCRIPTION="A 2D SuperMarioBros. + p0rtal clone"
-HOMEPAGE="http://stabyourself.net/mari0/"
+HOMEPAGE="http://stabyourself.net/${PN}/"
SRC_URI="http://stabyourself.net/dl.php?file=${PN}-1006/${PN}-source.zip -> ${P}.zip"
LICENSE="GPL-2"
SLOT="0"
@@ -35,5 +35,5 @@ src_prepare() {
src_install() {
insinto "/usr/share/games/love/${P}"
doins -r .
- games_make_wrapper mari0 "love /usr/share/games/love/${P}"
+ games_make_wrapper "${PN}" "love /usr/share/games/love/${P}"
}
diff --git a/games-arcade/nottetris/ChangeLog b/games-arcade/nottetris/ChangeLog
new file mode 100644
index 0000000..fbfd9bf
--- /dev/null
+++ b/games-arcade/nottetris/ChangeLog
@@ -0,0 +1,6 @@
+*mari0-1.6 (22 Apr 2012)
+
+ 22 Apr 2012; Misbakh-Soloviov Vadim A. <mva@gentoo.org> +mari0-1.6.ebuild,
+ +metadata.xml:
+ bump!
+
diff --git a/games-arcade/nottetris/Manifest b/games-arcade/nottetris/Manifest
new file mode 100644
index 0000000..1297aaa
--- /dev/null
+++ b/games-arcade/nottetris/Manifest
@@ -0,0 +1 @@
+DIST nottetris-2.zip 2773694 SHA256 362cb0e68235bb3301adfb284c559fa796a05f43f9c8ec01723db4352e539a8e SHA512 475061353217f99e0dd35a34097b6b35275a350ab112bfd27d85ea5fe32434c6b4ed107056af5a243d06d2b5988d2bf73776c01077ba2a17e223e8bd0778b563 WHIRLPOOL ee854e6b8e49eef3129334a08e15be66ae24f5782aee4453497b034a6dafa11d576033b2e74b8a32bff1e822bf8b8cc486eb86a686535545c8e99f447668b997
diff --git a/games-arcade/nottetris/metadata.xml b/games-arcade/nottetris/metadata.xml
new file mode 100644
index 0000000..23da526
--- /dev/null
+++ b/games-arcade/nottetris/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>mva@mva.name</email>
+ <description>
+ If you have any issues, please contact me, or try to find me in IRC on Freenode, OFTC or RusNet.
+ </description>
+ <name>Vadim A. Misbakh-Soloviov</name>
+</maintainer>
+<longdescription>FIXME</longdescription>
+<use>
+</use>
+</pkgmetadata>
diff --git a/games-arcade/nottetris/nottetris-2.ebuild b/games-arcade/nottetris/nottetris-2.ebuild
new file mode 100644
index 0000000..f115a3d
--- /dev/null
+++ b/games-arcade/nottetris/nottetris-2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: This ebuild is from Lua overlay; Bumped by mva; $
+
+EAPI="3"
+
+inherit eutils games
+
+DESCRIPTION="A tetris game with physics"
+HOMEPAGE="http://stabyourself.net/${PN}2/"
+SRC_URI="http://stabyourself.net/dl.php?file=${PN}2/${PN}2-source.zip -> ${P}.zip"
+LICENSE="GPL-2"
+SLOT="0"
+
+# Currently not usable with love-0.8.0.
+# Waiting for fixes from upstream.
+KEYWORDS="-*"
+
+IUSE=""
+RESTRICT=""
+
+DEPEND=">=games-engines/love-0.8.0"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ default
+ #it is only one .love file, so we can use asterisk
+ mv *.love "${P}.zip"
+ unpack "./${P}.zip"
+ rm "${P}.zip"
+}
+
+src_prepare() {
+ default
+ epatch_user
+}
+
+src_install() {
+ insinto "/usr/share/games/love/${P}"
+ doins -r .
+ games_make_wrapper "${PN}" "love /usr/share/games/love/${P}"
+}
diff --git a/games-arcade/orthorobot/ChangeLog b/games-arcade/orthorobot/ChangeLog
new file mode 100644
index 0000000..fbfd9bf
--- /dev/null
+++ b/games-arcade/orthorobot/ChangeLog
@@ -0,0 +1,6 @@
+*mari0-1.6 (22 Apr 2012)
+
+ 22 Apr 2012; Misbakh-Soloviov Vadim A. <mva@gentoo.org> +mari0-1.6.ebuild,
+ +metadata.xml:
+ bump!
+
diff --git a/games-arcade/orthorobot/Manifest b/games-arcade/orthorobot/Manifest
new file mode 100644
index 0000000..38593d0
--- /dev/null
+++ b/games-arcade/orthorobot/Manifest
@@ -0,0 +1 @@
+DIST orthorobot-0.zip 3429026 SHA256 744d70b492b9f9ebc8adf43f9131be3f9957d378ae1a8e18f1754dc9ff607608 SHA512 cf73bfd7d136c0d408dcee80db1193c4ae1d418128b8879a67c5fbfc013ce33ffab4255c0ea2e7d2a70f22301192fb77bd5b3105d69ff511d2d5a5b99fbd0cf0 WHIRLPOOL 4ee2364943cf835b84d5ad0daca1f3d204254ae8df4f272cc773da3d7d6561b92804cf26a99158a27622eee61e6f77eebcf50a10152583d8eb4b2d600e7c1e86
diff --git a/games-arcade/orthorobot/metadata.xml b/games-arcade/orthorobot/metadata.xml
new file mode 100644
index 0000000..23da526
--- /dev/null
+++ b/games-arcade/orthorobot/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>mva@mva.name</email>
+ <description>
+ If you have any issues, please contact me, or try to find me in IRC on Freenode, OFTC or RusNet.
+ </description>
+ <name>Vadim A. Misbakh-Soloviov</name>
+</maintainer>
+<longdescription>FIXME</longdescription>
+<use>
+</use>
+</pkgmetadata>
diff --git a/games-arcade/orthorobot/orthorobot-0.ebuild b/games-arcade/orthorobot/orthorobot-0.ebuild
new file mode 100644
index 0000000..33c3573
--- /dev/null
+++ b/games-arcade/orthorobot/orthorobot-0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: This ebuild is from Lua overlay; Bumped by mva; $
+
+EAPI="3"
+
+inherit eutils games
+
+DESCRIPTION="Nice perspective based puzzle game, where you flatten the view to move across gaps."
+HOMEPAGE="http://stabyourself.net/${PN}/"
+SRC_URI="http://stabyourself.net/dl.php?file=${PN}/${PN}-source.zip -> ${P}.zip"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT=""
+
+DEPEND=">=games-engines/love-0.8.0"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ default
+ #it is only one .love file, so we can use asterisk
+ mv *.love "${P}.zip"
+ unpack "./${P}.zip"
+ rm "${P}.zip"
+}
+
+src_prepare() {
+ default
+ epatch_user
+}
+
+src_install() {
+ insinto "/usr/share/games/love/${P}"
+ doins -r .
+ games_make_wrapper "${PN}" "love /usr/share/games/love/${P}"
+}
diff --git a/games-arcade/rimshot/ChangeLog b/games-arcade/rimshot/ChangeLog
new file mode 100644
index 0000000..fbfd9bf
--- /dev/null
+++ b/games-arcade/rimshot/ChangeLog
@@ -0,0 +1,6 @@
+*mari0-1.6 (22 Apr 2012)
+
+ 22 Apr 2012; Misbakh-Soloviov Vadim A. <mva@gentoo.org> +mari0-1.6.ebuild,
+ +metadata.xml:
+ bump!
+
diff --git a/games-arcade/rimshot/Manifest b/games-arcade/rimshot/Manifest
new file mode 100644
index 0000000..c548d72
--- /dev/null
+++ b/games-arcade/rimshot/Manifest
@@ -0,0 +1 @@
+DIST rimshot-0.zip 2374331 SHA256 b1be4ca242d9e2f6942a79da72275ff34622b2c52bd5024c2245a438b79fed22 SHA512 06eee4c8fd49b23b646ba51f85dad54ec0afde1a502234b737f80c57f06dc7ad7d667e4defcd8316ce6dc9e2316e908b42040191daeaae29c6f4c7013bd33e8b WHIRLPOOL 0b1a8f480601efc8a94bf2b2b32b57fdf62d52b9d273eb8a36df7d2f54fdd23b63ab1fe1a29c71d064d60e80e2a02e7d9c1ba997e637069a63ee5325140f8ac8
diff --git a/games-arcade/rimshot/metadata.xml b/games-arcade/rimshot/metadata.xml
new file mode 100644
index 0000000..23da526
--- /dev/null
+++ b/games-arcade/rimshot/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>mva@mva.name</email>
+ <description>
+ If you have any issues, please contact me, or try to find me in IRC on Freenode, OFTC or RusNet.
+ </description>
+ <name>Vadim A. Misbakh-Soloviov</name>
+</maintainer>
+<longdescription>FIXME</longdescription>
+<use>
+</use>
+</pkgmetadata>
diff --git a/games-arcade/rimshot/rimshot-0.ebuild b/games-arcade/rimshot/rimshot-0.ebuild
new file mode 100644
index 0000000..d9e2008
--- /dev/null
+++ b/games-arcade/rimshot/rimshot-0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: This ebuild is from Lua overlay; Bumped by mva; $
+
+EAPI="3"
+
+inherit eutils games
+
+DESCRIPTION="Nice application to work with drumbeats and play in 'Guitar Anti-Hero'"
+HOMEPAGE="http://stabyourself.net/${PN}/"
+SRC_URI="http://stabyourself.net/dl.php?file=${PN}/${PN}-source.zip -> ${P}.zip"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT=""
+
+DEPEND=">=games-engines/love-0.8.0"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ default
+ #it is only one .love file, so we can use asterisk
+ mv *.love "${P}.zip"
+ unpack "./${P}.zip"
+ rm "${P}.zip"
+}
+
+src_prepare() {
+ default
+ sed -r -e 's#(\trequire.*)(.lua)(.*)#\1\3#g' -i main.lua
+ epatch_user
+}
+
+src_install() {
+ insinto "/usr/share/games/love/${P}"
+ doins -r .
+ games_make_wrapper "${PN}" "love /usr/share/games/love/${P}"
+}
diff --git a/games-arcade/shoothookers/ChangeLog b/games-arcade/shoothookers/ChangeLog
new file mode 100644
index 0000000..6318f81
--- /dev/null
+++ b/games-arcade/shoothookers/ChangeLog
@@ -0,0 +1,6 @@
+*snayke-2.4 (22 Apr 2012)
+
+ 22 Apr 2012; Misbakh-Soloviov Vadim A. <mva@gentoo.org> +metadata.xml,
+ +snayke-2.4.ebuild:
+ bump!
+
diff --git a/games-arcade/shoothookers/Manifest b/games-arcade/shoothookers/Manifest
new file mode 100644
index 0000000..facd319
--- /dev/null
+++ b/games-arcade/shoothookers/Manifest
@@ -0,0 +1 @@
+DIST shoothookers-0.zip 532158 SHA256 42c59f6aab35c5bdb14b5f4c81415c681dabd0eb5c5ba8a3f20164d5f8d258ab SHA512 3ffe2b2862ffacfccd96b03511fc26801a42a0bd7c01bb8f244a342434a24ade4eb42833289c41600ba46eff406c2cf64d4bec0235c3d7e7767d0809e0278a58 WHIRLPOOL 6830544840355cb031dd5a48e4d29f25880f7eadefadb5156c78260cdf841b166a2fc72a72670f4e4e291395e9ed1d3e1cf0b6dd8aa2079a524d01cd5ae31341
diff --git a/games-arcade/shoothookers/metadata.xml b/games-arcade/shoothookers/metadata.xml
new file mode 100644
index 0000000..23da526
--- /dev/null
+++ b/games-arcade/shoothookers/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>mva@mva.name</email>
+ <description>
+ If you have any issues, please contact me, or try to find me in IRC on Freenode, OFTC or RusNet.
+ </description>
+ <name>Vadim A. Misbakh-Soloviov</name>
+</maintainer>
+<longdescription>FIXME</longdescription>
+<use>
+</use>
+</pkgmetadata>
diff --git a/games-arcade/shoothookers/shoothookers-0.ebuild b/games-arcade/shoothookers/shoothookers-0.ebuild
new file mode 100644
index 0000000..6c847bd
--- /dev/null
+++ b/games-arcade/shoothookers/shoothookers-0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: This ebuild is from Lua overlay; Bumped by mva; $
+
+EAPI="3"
+
+inherit eutils games
+
+DESCRIPTION="A game prototype by Maurice (mari0 author)"
+HOMEPAGE="http://stabyourself.net/other/"
+SRC_URI="http://stabyourself.net/dl.php?file=${PN}/${PN}.love -> ${P}.zip"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT=""
+
+DEPEND=">=games-engines/love-0.8.0"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+src_install() {
+ insinto "/usr/share/games/love/${P}"
+ doins -r .
+ games_make_wrapper "${PN}" "love /usr/share/games/love/${P}"
+}
diff --git a/games-arcade/snayke/snayke-2.4.ebuild b/games-arcade/snayke/snayke-2.4.ebuild
index 04abb76..16d6ac3 100644
--- a/games-arcade/snayke/snayke-2.4.ebuild
+++ b/games-arcade/snayke/snayke-2.4.ebuild
@@ -26,5 +26,5 @@ S="${WORKDIR}"
src_install() {
insinto "/usr/share/games/love/${P}"
doins -r .
- games_make_wrapper snayke "love /usr/share/games/love/${P}"
+ games_make_wrapper "${P}" "love /usr/share/games/love/${P}"
}