summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lua/lua-std-functional/lua-std-functional-9999.ebuild')
-rw-r--r--dev-lua/lua-std-functional/lua-std-functional-9999.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-lua/lua-std-functional/lua-std-functional-9999.ebuild b/dev-lua/lua-std-functional/lua-std-functional-9999.ebuild
new file mode 100644
index 0000000..206f8e2
--- /dev/null
+++ b/dev-lua/lua-std-functional/lua-std-functional-9999.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+VCS="git"
+GITHUB_A="lua-stdlib"
+GITHUB_PN="${PN#lua-std-}"
+
+inherit lua
+
+DESCRIPTION="Functional Programming with Lua"
+HOMEPAGE="https://github.com/lua-stdlib/functional"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+IUSE="doc"
+
+HTML_DOCS=(doc/.)
+DOCS=(README.md NEWS.md)
+
+lua_add_bdepend "doc? ( dev-lua/ldoc )"
+lua_add_rdepend "dev-lua/lua-std-normalize"
+
+each_lua_compile() {
+ if [[ "${PV}" == "9999" ]]; then
+ ver="git:$(git rev-parse --short @):${LUA_IMPL}"
+ fi
+ lua_default
+}
+
+each_lua_install() {
+ dolua lib/std
+}