aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAric Belsito <lluixhi@gmail.com>2016-12-04 21:41:28 -0800
committerAric Belsito <lluixhi@gmail.com>2016-12-04 21:41:28 -0800
commit8f518cf1cba4e2a9a6b3daeb5da00a5d4d36dd40 (patch)
tree8599c1004e60083b9a79cf9877938e1d150c260d /dev-util
parentdev-util/valgrind: add stable and unstable version (diff)
downloadmusl-8f518cf1cba4e2a9a6b3daeb5da00a5d4d36dd40.tar.gz
musl-8f518cf1cba4e2a9a6b3daeb5da00a5d4d36dd40.tar.bz2
musl-8f518cf1cba4e2a9a6b3daeb5da00a5d4d36dd40.zip
dev-util/strace: Sync with upstream
Drop r99 suffix
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/strace/Manifest2
-rw-r--r--dev-util/strace/strace-4.11.ebuild (renamed from dev-util/strace/strace-4.11-r99.ebuild)11
2 files changed, 7 insertions, 6 deletions
diff --git a/dev-util/strace/Manifest b/dev-util/strace/Manifest
index ca018d8f..c4329108 100644
--- a/dev-util/strace/Manifest
+++ b/dev-util/strace/Manifest
@@ -1,3 +1,3 @@
DIST strace-4.11.tar.xz 679924 SHA256 e86a5f6cd8f941f67f3e4b28f4e60f3d9185c951cf266404533210a2e5cd8152 SHA512 e1e07ed427f504f53bcd117b61bb96a780b0f531010856ed157e4d8c2090371bf320ab59a02b88e67bf2afd443fba67e12f90e53afeab795188c89c6496daecd WHIRLPOOL eee2ae13670dc6f52c45e8275e54655216bd63f1bba2b056a31cb2ee1431f3f15060112a4807eb552a36429bee5d358a5ac3290d25f8875ffd818bb6fcb21a2f
-EBUILD strace-4.11-r99.ebuild 1429 SHA256 6cf6c6334dfd175471ff430a3c68d302e576adf9052830171454e36d6ef6ad2f SHA512 0caca3d6e31726b26092bebe765d71f69dc550367477158339b9f3d9c00c1979fb02c79ceb13b6f4933992233de524e3f069202b8baa4fc15b20f098f59b949b WHIRLPOOL 901db0e1c1740a9cd5c986ea0bd15a05d0cd167d4dcdf99aa107994203cd540b8de7ccd8a3958690e59c99c9d076d511816eef769dc2517ff24a02b946d10014
+EBUILD strace-4.11.ebuild 1467 SHA256 d7b27a303b5d43c8e53a4ed282372ce010229ea90ebc2112174ecce6a5d74e9b SHA512 f24b9649ad3baf40964675e13d939166b36b1fa9943c5433aa7d9feb193f15e720b13d34939b478fdbe2551725b5a8a0394c8946055c2cff2d8a9b7c59611c6b WHIRLPOOL d92169bcaccbc82ebbabceaaa0ec45b7556db82ab4b16036e7ab633b9162d11e6e725f8e208dbb3f4f0fc81167c02ed9f0babfce492b2f907c2f2a391319cec6
MISC metadata.xml 593 SHA256 e109b90d149d7f0a92316f83f9695c40f2d702625c274b3a9c48bfab2b38dd53 SHA512 67300cfcaba830a47e49cd327bf2d8490b084b016a321fd6e19e52d8dc28968395b3ffc114675a7d4dc723a9ddd7b57c3ede10207a226d60a2225f88aceb59e4 WHIRLPOOL 1af581a8525b849b93b4e2f1c7106fb4805c61818d374e451b5cdf88d7e0d87a41e5175d08e789daab6daf4832ed4b055e9b7de4ad7516220c9da0c203bdc910
diff --git a/dev-util/strace/strace-4.11-r99.ebuild b/dev-util/strace/strace-4.11.ebuild
index 87e54774..0139ab8f 100644
--- a/dev-util/strace/strace-4.11-r99.ebuild
+++ b/dev-util/strace/strace-4.11.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Id$
-EAPI=5
+EAPI="5"
inherit flag-o-matic eutils
if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="git://strace.git.sourceforge.net/gitroot/strace/strace"
+ EGIT_REPO_URI="git://git.code.sf.net/p/strace/code"
+ EGIT_PROJECT="${PN}"
inherit git-2 autotools
else
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
@@ -15,7 +15,7 @@ else
fi
DESCRIPTION="A useful diagnostic, instructional, and debugging tool"
-HOMEPAGE="http://sourceforge.net/projects/strace/"
+HOMEPAGE="https://sourceforge.net/projects/strace/"
LICENSE="BSD"
SLOT="0"
@@ -32,7 +32,8 @@ RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )
src_prepare() {
if epatch_user || [[ ! -e configure ]] ; then
# git generation
- ./xlat/gen.sh
+ ./xlat/gen.sh || die
+ ./generate_mpers_am.sh || die
eautoreconf
[[ ! -e CREDITS ]] && cp CREDITS{.in,}
fi