aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorstefson <herrtimson@yahoo.de>2020-07-10 13:30:51 +0200
committerAnthony G. Basile <blueness@gentoo.org>2020-07-17 08:42:59 -0400
commit7fb72f89c08477fe5c7ef19228bd0cbc268cf030 (patch)
treebd88eea9f7c34d92ebf626d51b64db3ba512ccaa /sys-auth
parentsys-auth/polkit: add upstream fix for mozjs-68 (diff)
downloadmusl-7fb72f89c08477fe5c7ef19228bd0cbc268cf030.tar.gz
musl-7fb72f89c08477fe5c7ef19228bd0cbc268cf030.tar.bz2
musl-7fb72f89c08477fe5c7ef19228bd0cbc268cf030.zip
sys-auth/polkit: refresh mozjs-68 patch from upstream
Signed-off-by: Steffen Kuhn <nielson2@yandex.com> Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/polkit/files/polkit-0.116-spidermonkey-68.patch96
1 files changed, 79 insertions, 17 deletions
diff --git a/sys-auth/polkit/files/polkit-0.116-spidermonkey-68.patch b/sys-auth/polkit/files/polkit-0.116-spidermonkey-68.patch
index e57dfd7d..d944c24b 100644
--- a/sys-auth/polkit/files/polkit-0.116-spidermonkey-68.patch
+++ b/sys-auth/polkit/files/polkit-0.116-spidermonkey-68.patch
@@ -1,7 +1,7 @@
From 12f3d25fb73c68151f84c97c79acab7d5344f606 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?X=E2=84=B9=20Ruoyao?= <xry111@mengyan1223.wang>
Date: Fri, 13 Mar 2020 14:55:44 +0800
-Subject: [PATCH 1/3] Port JavaScript authority to mozjs-68
+Subject: [PATCH 1/5] Port JavaScript authority to mozjs-68
---
configure.ac | 2 +-
@@ -9,7 +9,7 @@ Subject: [PATCH 1/3] Port JavaScript authority to mozjs-68
2 files changed, 76 insertions(+), 62 deletions(-)
diff --git a/configure.ac b/configure.ac
-index 5cedb4e..cd678f1 100644
+index 5cedb4ec..cd678f1c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -79,7 +79,7 @@ PKG_CHECK_MODULES(GLIB, [gmodule-2.0 gio-unix-2.0 >= 2.30.0])
@@ -22,7 +22,7 @@ index 5cedb4e..cd678f1 100644
AC_SUBST(LIBJS_CFLAGS)
AC_SUBST(LIBJS_CXXFLAGS)
diff --git a/src/polkitbackend/polkitbackendjsauthority.cpp b/src/polkitbackend/polkitbackendjsauthority.cpp
-index 0f18085..d5113cb 100644
+index 0f180856..d5113cb0 100644
--- a/src/polkitbackend/polkitbackendjsauthority.cpp
+++ b/src/polkitbackend/polkitbackendjsauthority.cpp
@@ -43,7 +43,12 @@
@@ -391,22 +391,13 @@ index 0f18085..d5113cb 100644
args.rval ().setBoolean (is_in_netgroup);
--
-2.24.1
+GitLab
-From 2e6787ead894911e9172e873d15b84dc237ff209 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?X=E2=84=B9=20Ruoyao?= <xry111@mengyan1223.wang>
-Date: Fri, 13 Mar 2020 15:06:44 +0800
-Subject: [PATCH 2/3] ci: update to mozjs-68
-
----
- .gitlab-ci.yml | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
From cf22af32577cf49b4e5ed9945ec9cca862c45b3e Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?X=E2=84=B9=20Ruoyao?= <xry111@mengyan1223.wang>
Date: Fri, 3 Apr 2020 23:47:38 +0800
-Subject: [PATCH 3/3] ensure to use C++14
+Subject: [PATCH 3/5] ensure to use C++14
---
buildutil/ax_cxx_compile_stdcxx.m4 | 948 +++++++++++++++++++++++++++++
@@ -416,7 +407,7 @@ Subject: [PATCH 3/3] ensure to use C++14
diff --git a/buildutil/ax_cxx_compile_stdcxx.m4 b/buildutil/ax_cxx_compile_stdcxx.m4
new file mode 100644
-index 0000000..9e9eaed
+index 00000000..9e9eaeda
--- /dev/null
+++ b/buildutil/ax_cxx_compile_stdcxx.m4
@@ -0,0 +1,948 @@
@@ -1369,7 +1360,7 @@ index 0000000..9e9eaed
+
+]])
diff --git a/configure.ac b/configure.ac
-index cd678f1..3d50641 100644
+index cd678f1c..3d50641e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5,6 +5,7 @@ AC_INIT([polkit], [0.116], [http://lists.freedesktop.org/mailman/listinfo/polkit
@@ -1390,6 +1381,77 @@ index cd678f1..3d50641 100644
# Taken from dbus
AC_ARG_ENABLE(ansi, [ --enable-ansi enable -ansi -pedantic gcc flags],enable_ansi=$enableval,enable_ansi=no)
--
-2.24.1
+GitLab
+
+
+From 14444004e60755d9aa362d30c8909460b8f9b824 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?X=E2=84=B9=20Ruoyao?= <xry111@mengyan1223.wang>
+Date: Mon, 8 Jun 2020 20:46:43 +0800
+Subject: [PATCH 4/5] remove an unused variable
+
+---
+ src/polkitbackend/polkitbackendjsauthority.cpp | 3 ---
+ 1 file changed, 3 deletions(-)
+
+diff --git a/src/polkitbackend/polkitbackendjsauthority.cpp b/src/polkitbackend/polkitbackendjsauthority.cpp
+index d5113cb0..61088a1d 100644
+--- a/src/polkitbackend/polkitbackendjsauthority.cpp
++++ b/src/polkitbackend/polkitbackendjsauthority.cpp
+@@ -470,7 +470,6 @@ static void
+ polkit_backend_js_authority_constructed (GObject *object)
+ {
+ PolkitBackendJsAuthority *authority = POLKIT_BACKEND_JS_AUTHORITY (object);
+- gboolean entered_request = FALSE;
+
+ authority->priv->cx = JS_NewContext (8L * 1024L * 1024L);
+ if (authority->priv->cx == NULL)
+@@ -486,7 +485,6 @@ polkit_backend_js_authority_constructed (GObject *object)
+ JS::SetWarningReporter(authority->priv->cx, report_error);
+ JS_SetContextPrivate (authority->priv->cx, authority);
+
+- entered_request = TRUE;
+
+ {
+ JS::RealmOptions compart_opts;
+@@ -552,7 +550,6 @@ polkit_backend_js_authority_constructed (GObject *object)
+ setup_file_monitors (authority);
+ load_scripts (authority);
+ }
+- entered_request = FALSE;
+
+ G_OBJECT_CLASS (polkit_backend_js_authority_parent_class)->constructed (object);
+
+--
+GitLab
+
+
+From 3245061595a10644f8d32e48eeaaf6fbf0364c70 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?X=E2=84=B9=20Ruoyao?= <xry111@mengyan1223.wang>
+Date: Mon, 8 Jun 2020 21:25:33 +0800
+Subject: [PATCH 5/5] do not leak GFile
+
+---
+ src/polkitbackend/polkitbackendjsauthority.cpp | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/src/polkitbackend/polkitbackendjsauthority.cpp b/src/polkitbackend/polkitbackendjsauthority.cpp
+index 61088a1d..25bd1f93 100644
+--- a/src/polkitbackend/polkitbackendjsauthority.cpp
++++ b/src/polkitbackend/polkitbackendjsauthority.cpp
+@@ -311,8 +311,12 @@ load_scripts (PolkitBackendJsAuthority *authority)
+ polkit_backend_authority_log (POLKIT_BACKEND_AUTHORITY (authority),
+ "Error compiling script %s",
+ filename);
++ g_object_unref (file);
+ continue;
+ }
++
++ g_object_unref (file);
++
+ JS::SourceText<mozilla::Utf8Unit> source;
+ if (!source.init (authority->priv->cx, contents, len,
+ JS::SourceOwnership::Borrowed))
+--
+GitLab