aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2019-04-14 17:13:18 -0400
committerAnthony G. Basile <blueness@gentoo.org>2019-04-14 17:13:18 -0400
commit60a1a12bb194551d225f12a18eb099e3aeabea4d (patch)
tree2ebeb854c168b85c9bb0d4a2c5bfa1e5e53e2852 /sys-devel
parentsys-devel/gcc: remove older versions (diff)
downloadmusl-60a1a12bb194551d225f12a18eb099e3aeabea4d.tar.gz
musl-60a1a12bb194551d225f12a18eb099e3aeabea4d.tar.bz2
musl-60a1a12bb194551d225f12a18eb099e3aeabea4d.zip
sys-devel/gcc: backport gcc-pure64.patch to gcc-8.2.0
Signed-off-by: Anthony G. Basile <blueness@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/gcc-8.2.0-r6.ebuild3
-rw-r--r--sys-devel/gcc/gcc-8.3.0.ebuild3
2 files changed, 6 insertions, 0 deletions
diff --git a/sys-devel/gcc/gcc-8.2.0-r6.ebuild b/sys-devel/gcc/gcc-8.2.0-r6.ebuild
index 9d37041a..3b0093a4 100644
--- a/sys-devel/gcc/gcc-8.2.0-r6.ebuild
+++ b/sys-devel/gcc/gcc-8.2.0-r6.ebuild
@@ -25,5 +25,8 @@ src_prepare() {
if use elibc_musl || [[ ${CATEGORY} = cross-*-musl* ]]; then
epatch "${FILESDIR}"/6.3.0/cpu_indicator.patch
epatch "${FILESDIR}"/7.1.0/posix_memalign.patch
+ case $(tc-arch) in
+ amd64|arm64) epatch "${FILESDIR}"/8.3.0/gcc-pure64.patch ;;
+ esac
fi
}
diff --git a/sys-devel/gcc/gcc-8.3.0.ebuild b/sys-devel/gcc/gcc-8.3.0.ebuild
index 269083e2..33f446c0 100644
--- a/sys-devel/gcc/gcc-8.3.0.ebuild
+++ b/sys-devel/gcc/gcc-8.3.0.ebuild
@@ -24,5 +24,8 @@ src_prepare() {
if use elibc_musl || [[ ${CATEGORY} = cross-*-musl* ]]; then
epatch "${FILESDIR}"/6.3.0/cpu_indicator.patch
epatch "${FILESDIR}"/7.1.0/posix_memalign.patch
+ case $(tc-arch) in
+ amd64|arm64) epatch "${FILESDIR}"/8.3.0/gcc-pure64.patch ;;
+ esac
fi
}