aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory Pratt <anarchy@gentoo.org>2020-01-28 13:14:19 -0600
committerJory Pratt <anarchy@gentoo.org>2020-01-28 13:14:19 -0600
commit75077f2c46d5c86c238d0dcedf9953d3e0ef4a79 (patch)
tree4bbbefc88c3ac0fd9700f4dc6e5b10fe286c9adc /sys-devel
parentdev-libs/weston: adjust cairo dep (diff)
downloadmusl-75077f2c46d5c86c238d0dcedf9953d3e0ef4a79.tar.gz
musl-75077f2c46d5c86c238d0dcedf9953d3e0ef4a79.tar.bz2
musl-75077f2c46d5c86c238d0dcedf9953d3e0ef4a79.zip
*/*: [QA] Fix trivial cases of MissingTestRestrict
The result was achieved via the following pipeline: pkgcheck scan -c RestrictTestCheck -R FormatReporter \ --format '{category}/{package}/{package}-{version}.ebuild' | xargs -n32 grep -L RESTRICT | xargs -n32 sed -i -e '/^IUSE=.*test/aRESTRICT="!test? ( test )"' The resulting metadata was compared before and after the change. Few Go ebuilds had to be fixed manually due to implicit RESTRICT=strip added by the eclass. Two ebuilds have to be fixed because of multiline IUSE. Signed-off-by: Jory Pratt <anarchy@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gdb/gdb-8.1-r1.ebuild1
-rw-r--r--sys-devel/gdb/gdb-8.1-r2.ebuild1
2 files changed, 2 insertions, 0 deletions
diff --git a/sys-devel/gdb/gdb-8.1-r1.ebuild b/sys-devel/gdb/gdb-8.1-r1.ebuild
index accc2cfc..955f0d1a 100644
--- a/sys-devel/gdb/gdb-8.1-r1.ebuild
+++ b/sys-devel/gdb/gdb-8.1-r1.ebuild
@@ -63,6 +63,7 @@ if [[ ${PV} != 9999* ]] ; then
KEYWORDS="amd64 ~arm ~arm64 arm64 ~mips ppc x86"
fi
IUSE="+client lzma multitarget nls +python +server test vanilla xml"
+RESTRICT="!test? ( test )"
REQUIRED_USE="
python? ( ${PYTHON_REQUIRED_USE} )
|| ( client server )
diff --git a/sys-devel/gdb/gdb-8.1-r2.ebuild b/sys-devel/gdb/gdb-8.1-r2.ebuild
index 6e7b8df4..d770582d 100644
--- a/sys-devel/gdb/gdb-8.1-r2.ebuild
+++ b/sys-devel/gdb/gdb-8.1-r2.ebuild
@@ -63,6 +63,7 @@ if [[ ${PV} != 9999* ]] ; then
KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~x86"
fi
IUSE="+client lzma multitarget nls +python +server test vanilla xml"
+RESTRICT="!test? ( test )"
REQUIRED_USE="
python? ( ${PYTHON_REQUIRED_USE} )
|| ( client server )