aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2019-04-13 15:47:39 -0400
committerAnthony G. Basile <blueness@gentoo.org>2019-04-13 15:47:39 -0400
commita0b6b1502d98142ebce05ac6c81609b436e1b0b8 (patch)
treec0b53eb0e9cd5187f471776886c57c2d604d1367 /sys-devel
parentsys-devel/gcc: fix patch (diff)
downloadmusl-a0b6b1502d98142ebce05ac6c81609b436e1b0b8.tar.gz
musl-a0b6b1502d98142ebce05ac6c81609b436e1b0b8.tar.bz2
musl-a0b6b1502d98142ebce05ac6c81609b436e1b0b8.zip
sys-devel/gcc: migrate to eapply
Signed-off-by: Anthony G. Basile <blueness@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/gcc-8.3.0-r1.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/sys-devel/gcc/gcc-8.3.0-r1.ebuild b/sys-devel/gcc/gcc-8.3.0-r1.ebuild
index 1cf74d8f..313196d9 100644
--- a/sys-devel/gcc/gcc-8.3.0-r1.ebuild
+++ b/sys-devel/gcc/gcc-8.3.0-r1.ebuild
@@ -22,8 +22,10 @@ src_prepare() {
toolchain_src_prepare
if use elibc_musl || [[ ${CATEGORY} = cross-*-musl* ]]; then
- epatch "${FILESDIR}"/6.3.0/cpu_indicator.patch
- epatch "${FILESDIR}"/7.1.0/posix_memalign.patch
- epatch "${FILESDIR}"/8.3.0/gcc-pure64.patch
+ eapply "${FILESDIR}"/6.3.0/cpu_indicator.patch
+ eapply "${FILESDIR}"/7.1.0/posix_memalign.patch
+ eapply "${FILESDIR}"/8.3.0/gcc-pure64.patch
fi
+
+ eapply_user
}