summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2010-03-21 03:18:14 -0100
committerJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2010-03-21 03:18:14 -0100
commitb523bc4ced7597646127979115fed2d534ea01ef (patch)
tree9dcfd444c92b2a873e927949a6c7e957c121ccb0 /02040_all_embedded-library-shared-5.1.43.patch
parentMore updates for the embedded library patch for 5.1. (diff)
downloadmysql-extras-b523bc4ced7597646127979115fed2d534ea01ef.tar.gz
mysql-extras-b523bc4ced7597646127979115fed2d534ea01ef.tar.bz2
mysql-extras-b523bc4ced7597646127979115fed2d534ea01ef.zip
More updates for the embedded library patch for 5.1.
Diffstat (limited to '02040_all_embedded-library-shared-5.1.43.patch')
-rw-r--r--02040_all_embedded-library-shared-5.1.43.patch107
1 files changed, 54 insertions, 53 deletions
diff --git a/02040_all_embedded-library-shared-5.1.43.patch b/02040_all_embedded-library-shared-5.1.43.patch
index 95aaed1..1a96b5e 100644
--- a/02040_all_embedded-library-shared-5.1.43.patch
+++ b/02040_all_embedded-library-shared-5.1.43.patch
@@ -20,7 +20,7 @@ Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
diff -ur mysql/client/Makefile.am mysql-new/client/Makefile.am
--- mysql/client/Makefile.am 2010-02-04 10:36:51.000000000 -0100
-+++ mysql-new/client/Makefile.am 2010-03-21 02:24:07.000000000 -0100
++++ mysql-new/client/Makefile.am 2010-03-21 03:16:42.000000000 -0100
@@ -75,7 +75,7 @@
mysqlimport_LDADD = $(CXXLDFLAGS) $(CLIENT_THREAD_LIBS) \
@CLIENT_EXTRA_LDFLAGS@ \
@@ -51,7 +51,7 @@ diff -ur mysql/client/Makefile.am mysql-new/client/Makefile.am
mysql_upgrade_SOURCES= mysql_upgrade.c \
diff -ur mysql/configure.in mysql-new/configure.in
--- mysql/configure.in 2010-02-04 10:36:59.000000000 -0100
-+++ mysql-new/configure.in 2010-03-21 02:24:07.000000000 -0100
++++ mysql-new/configure.in 2010-03-21 03:16:42.000000000 -0100
@@ -2784,7 +2784,7 @@
dnl This probably should be cleaned up more - for now the threaded
@@ -86,7 +86,7 @@ diff -ur mysql/configure.in mysql-new/configure.in
fi
diff -ur mysql/dbug/Makefile.am mysql-new/dbug/Makefile.am
--- mysql/dbug/Makefile.am 2010-02-04 10:36:59.000000000 -0100
-+++ mysql-new/dbug/Makefile.am 2010-03-21 02:24:07.000000000 -0100
++++ mysql-new/dbug/Makefile.am 2010-03-21 03:16:42.000000000 -0100
@@ -16,10 +16,10 @@
# MA 02111-1307, USA
@@ -117,7 +117,7 @@ diff -ur mysql/dbug/Makefile.am mysql-new/dbug/Makefile.am
-nroff -mm user.r > $@
diff -ur mysql/extra/Makefile.am mysql-new/extra/Makefile.am
--- mysql/extra/Makefile.am 2010-02-04 10:37:00.000000000 -0100
-+++ mysql-new/extra/Makefile.am 2010-03-21 02:24:07.000000000 -0100
++++ mysql-new/extra/Makefile.am 2010-03-21 03:16:42.000000000 -0100
@@ -15,8 +15,8 @@
INCLUDES = -I$(top_builddir)/include -I$(top_srcdir)/include \
@@ -131,7 +131,7 @@ diff -ur mysql/extra/Makefile.am mysql-new/extra/Makefile.am
$(top_builddir)/include/sql_state.h \
diff -ur mysql/libmysql/Makefile.am mysql-new/libmysql/Makefile.am
--- mysql/libmysql/Makefile.am 2010-02-04 10:37:07.000000000 -0100
-+++ mysql-new/libmysql/Makefile.am 2010-03-21 02:24:07.000000000 -0100
++++ mysql-new/libmysql/Makefile.am 2010-03-21 03:16:42.000000000 -0100
@@ -106,8 +106,8 @@
echo "# This file is autogenerated from Makefile.am" >> $$dir/Makefile; \
echo 'CFLAGS= -I. -DMYSQL_CLIENT_NO_THREADS' >>$$dir/Makefile; \
@@ -145,15 +145,16 @@ diff -ur mysql/libmysql/Makefile.am mysql-new/libmysql/Makefile.am
cd $$dir; gmake
diff -ur mysql/libmysqld/examples/Makefile.am mysql-new/libmysqld/examples/Makefile.am
--- mysql/libmysqld/examples/Makefile.am 2010-02-04 10:37:08.000000000 -0100
-+++ mysql-new/libmysqld/examples/Makefile.am 2010-03-21 03:09:55.000000000 -0100
-@@ -37,12 +37,12 @@
++++ mysql-new/libmysqld/examples/Makefile.am 2010-03-21 03:17:16.000000000 -0100
+@@ -37,12 +37,13 @@
-I$(top_srcdir) -I$(top_srcdir)/client -I$(top_srcdir)/regex \
$(openssl_includes)
LIBS = @LIBS@ @WRAPLIBS@ @CLIENT_LIBS@ $(yassl_libs)
-LDADD = @CLIENT_EXTRA_LDFLAGS@ ../libmysqld.a @LIBDL@ $(CXXLDFLAGS) \
- @NDB_SCI_LIBS@
+LDADD = @CLIENT_EXTRA_LDFLAGS@ ../libmysqld.la @LIBDL@ $(CXXLDFLAGS) \
-+ @NDB_SCI_LIBS@ ../../libmysql/libmysqlclient.la -static
++ @NDB_SCI_LIBS@ ../../libmysql/libmysqlclient.la
++LDFLAGS = -static
mysqltest_embedded_LINK = $(CXXLINK)
nodist_mysqltest_embedded_SOURCES = mysqltest.cc
@@ -164,7 +165,7 @@ diff -ur mysql/libmysqld/examples/Makefile.am mysql-new/libmysqld/examples/Makef
my_readline.h sql_string.h completion_hash.h
diff -ur mysql/libmysqld/Makefile.am mysql-new/libmysqld/Makefile.am
--- mysql/libmysqld/Makefile.am 2010-02-04 10:37:08.000000000 -0100
-+++ mysql-new/libmysqld/Makefile.am 2010-03-21 02:24:07.000000000 -0100
++++ mysql-new/libmysqld/Makefile.am 2010-03-21 03:16:42.000000000 -0100
@@ -36,10 +36,10 @@
$(openssl_includes) @ZLIB_INCLUDES@ \
@condition_dependent_plugin_includes@
@@ -273,7 +274,7 @@ diff -ur mysql/libmysqld/Makefile.am mysql-new/libmysqld/Makefile.am
## libmysqld interface to change without affecting the standard
diff -ur mysql/mysys/Makefile.am mysql-new/mysys/Makefile.am
--- mysql/mysys/Makefile.am 2010-02-04 10:38:50.000000000 -0100
-+++ mysql-new/mysys/Makefile.am 2010-03-21 02:24:07.000000000 -0100
++++ mysql-new/mysys/Makefile.am 2010-03-21 03:16:42.000000000 -0100
@@ -18,10 +18,9 @@
MYSQLBASEdir= $(prefix)
INCLUDES = @ZLIB_INCLUDES@ -I$(top_builddir)/include \
@@ -395,7 +396,7 @@ diff -ur mysql/mysys/Makefile.am mysql-new/mysys/Makefile.am
$(RM) -f ./test_base64.c
diff -ur mysql/netware/Makefile.am mysql-new/netware/Makefile.am
--- mysql/netware/Makefile.am 2010-02-04 10:38:51.000000000 -0100
-+++ mysql-new/netware/Makefile.am 2010-03-21 02:24:07.000000000 -0100
++++ mysql-new/netware/Makefile.am 2010-03-21 03:16:42.000000000 -0100
@@ -16,14 +16,13 @@
if HAVE_NETWARE
@@ -415,7 +416,7 @@ diff -ur mysql/netware/Makefile.am mysql-new/netware/Makefile.am
netware_build_files = client/mysql.def client/mysqladmin.def \
diff -ur mysql/pstack/Makefile.am mysql-new/pstack/Makefile.am
--- mysql/pstack/Makefile.am 2010-02-04 10:38:52.000000000 -0100
-+++ mysql-new/pstack/Makefile.am 2010-03-21 02:24:07.000000000 -0100
++++ mysql-new/pstack/Makefile.am 2010-03-21 03:16:42.000000000 -0100
@@ -22,8 +22,8 @@
INCLUDES = -I$(top_builddir)/include -I$(top_srcdir)/include
@@ -429,7 +430,7 @@ diff -ur mysql/pstack/Makefile.am mysql-new/pstack/Makefile.am
linuxthreads.h pstack.h pstacktrace.h
diff -ur mysql/regex/Makefile.am mysql-new/regex/Makefile.am
--- mysql/regex/Makefile.am 2010-02-04 10:38:52.000000000 -0100
-+++ mysql-new/regex/Makefile.am 2010-03-21 02:24:07.000000000 -0100
++++ mysql-new/regex/Makefile.am 2010-03-21 03:16:42.000000000 -0100
@@ -16,10 +16,10 @@
# MA 02111-1307, USA
@@ -446,7 +447,7 @@ diff -ur mysql/regex/Makefile.am mysql-new/regex/Makefile.am
re_LDFLAGS= @NOINST_LDFLAGS@
diff -ur mysql/server-tools/instance-manager/Makefile.am mysql-new/server-tools/instance-manager/Makefile.am
--- mysql/server-tools/instance-manager/Makefile.am 2010-02-04 10:38:53.000000000 -0100
-+++ mysql-new/server-tools/instance-manager/Makefile.am 2010-03-21 02:24:07.000000000 -0100
++++ mysql-new/server-tools/instance-manager/Makefile.am 2010-03-21 03:16:42.000000000 -0100
@@ -23,8 +23,7 @@
# default_options.h, generated from default_options.h.in)
# See automake/autoconf docs for details
@@ -501,7 +502,7 @@ diff -ur mysql/server-tools/instance-manager/Makefile.am mysql-new/server-tools/
EXTRA_DIST = WindowsService.cpp WindowsService.h IMService.cpp \
diff -ur mysql/sql/Makefile.am mysql-new/sql/Makefile.am
--- mysql/sql/Makefile.am 2010-02-04 10:38:53.000000000 -0100
-+++ mysql-new/sql/Makefile.am 2010-03-21 02:24:07.000000000 -0100
++++ mysql-new/sql/Makefile.am 2010-03-21 03:16:42.000000000 -0100
@@ -32,11 +32,11 @@
noinst_LTLIBRARIES= libndb.la \
udf_example.la
@@ -521,7 +522,7 @@ diff -ur mysql/sql/Makefile.am mysql-new/sql/Makefile.am
mysqld_LDADD = libndb.la \
diff -ur mysql/storage/archive/Makefile.am mysql-new/storage/archive/Makefile.am
--- mysql/storage/archive/Makefile.am 2010-02-04 10:39:55.000000000 -0100
-+++ mysql-new/storage/archive/Makefile.am 2010-03-21 02:24:07.000000000 -0100
++++ mysql-new/storage/archive/Makefile.am 2010-03-21 03:16:42.000000000 -0100
@@ -23,7 +23,7 @@
INCLUDES = -I$(top_srcdir)/include -I$(top_builddir)/include \
-I$(top_srcdir)/regex \
@@ -579,7 +580,7 @@ diff -ur mysql/storage/archive/Makefile.am mysql-new/storage/archive/Makefile.am
diff -ur mysql/storage/archive/plug.in mysql-new/storage/archive/plug.in
--- mysql/storage/archive/plug.in 2010-02-04 10:39:55.000000000 -0100
-+++ mysql-new/storage/archive/plug.in 2010-03-21 02:24:07.000000000 -0100
++++ mysql-new/storage/archive/plug.in 2010-03-21 03:16:42.000000000 -0100
@@ -1,4 +1,4 @@
MYSQL_STORAGE_ENGINE(archive,, [Archive Storage Engine],
[Archive Storage Engine], [max,max-no-ndb])
@@ -588,7 +589,7 @@ diff -ur mysql/storage/archive/plug.in mysql-new/storage/archive/plug.in
MYSQL_PLUGIN_DYNAMIC(archive, [ha_archive.la])
diff -ur mysql/storage/blackhole/Makefile.am mysql-new/storage/blackhole/Makefile.am
--- mysql/storage/blackhole/Makefile.am 2010-02-04 10:39:55.000000000 -0100
-+++ mysql-new/storage/blackhole/Makefile.am 2010-03-21 02:24:07.000000000 -0100
++++ mysql-new/storage/blackhole/Makefile.am 2010-03-21 03:16:42.000000000 -0100
@@ -32,7 +32,7 @@
noinst_HEADERS = ha_blackhole.h
@@ -616,7 +617,7 @@ diff -ur mysql/storage/blackhole/Makefile.am mysql-new/storage/blackhole/Makefil
EXTRA_DIST = CMakeLists.txt plug.in
diff -ur mysql/storage/blackhole/plug.in mysql-new/storage/blackhole/plug.in
--- mysql/storage/blackhole/plug.in 2010-02-04 10:39:55.000000000 -0100
-+++ mysql-new/storage/blackhole/plug.in 2010-03-21 02:24:07.000000000 -0100
++++ mysql-new/storage/blackhole/plug.in 2010-03-21 03:16:42.000000000 -0100
@@ -1,6 +1,5 @@
MYSQL_STORAGE_ENGINE(blackhole,,[Blackhole Storage Engine],
[Basic Write-only Read-never tables], [max,max-no-ndb])
@@ -627,7 +628,7 @@ diff -ur mysql/storage/blackhole/plug.in mysql-new/storage/blackhole/plug.in
diff -ur mysql/storage/csv/Makefile.am mysql-new/storage/csv/Makefile.am
--- mysql/storage/csv/Makefile.am 2010-02-04 10:39:55.000000000 -0100
-+++ mysql-new/storage/csv/Makefile.am 2010-03-21 02:24:07.000000000 -0100
++++ mysql-new/storage/csv/Makefile.am 2010-03-21 03:16:42.000000000 -0100
@@ -29,17 +29,17 @@
DEFS = @DEFS@
noinst_HEADERS = ha_tina.h transparent_file.h
@@ -653,7 +654,7 @@ diff -ur mysql/storage/csv/Makefile.am mysql-new/storage/csv/Makefile.am
+
diff -ur mysql/storage/csv/plug.in mysql-new/storage/csv/plug.in
--- mysql/storage/csv/plug.in 2010-02-04 10:39:55.000000000 -0100
-+++ mysql-new/storage/csv/plug.in 2010-03-21 02:24:07.000000000 -0100
++++ mysql-new/storage/csv/plug.in 2010-03-21 03:16:42.000000000 -0100
@@ -1,5 +1,5 @@
MYSQL_STORAGE_ENGINE(csv,, [CSV Storage Engine],
[Stores tables in text CSV format])
@@ -663,7 +664,7 @@ diff -ur mysql/storage/csv/plug.in mysql-new/storage/csv/plug.in
MYSQL_PLUGIN_MANDATORY(csv) dnl Used for logging
diff -ur mysql/storage/federated/Makefile.am mysql-new/storage/federated/Makefile.am
--- mysql/storage/federated/Makefile.am 2010-02-04 10:39:55.000000000 -0100
-+++ mysql-new/storage/federated/Makefile.am 2010-03-21 02:24:07.000000000 -0100
++++ mysql-new/storage/federated/Makefile.am 2010-03-21 03:16:42.000000000 -0100
@@ -32,7 +32,7 @@
noinst_HEADERS = ha_federated.h
@@ -691,7 +692,7 @@ diff -ur mysql/storage/federated/Makefile.am mysql-new/storage/federated/Makefil
EXTRA_DIST = CMakeLists.txt plug.in
diff -ur mysql/storage/federated/plug.in mysql-new/storage/federated/plug.in
--- mysql/storage/federated/plug.in 2010-02-04 10:39:55.000000000 -0100
-+++ mysql-new/storage/federated/plug.in 2010-03-21 02:24:07.000000000 -0100
++++ mysql-new/storage/federated/plug.in 2010-03-21 03:16:42.000000000 -0100
@@ -1,5 +1,4 @@
MYSQL_STORAGE_ENGINE(federated,,[Federated Storage Engine],
[Connects to tables on remote MySQL servers], [max,max-no-ndb])
@@ -701,7 +702,7 @@ diff -ur mysql/storage/federated/plug.in mysql-new/storage/federated/plug.in
MYSQL_PLUGIN_DEPENDS_ON_MYSQL_INTERNALS(federated, [ha_federated.cc])
diff -ur mysql/storage/heap/Makefile.am mysql-new/storage/heap/Makefile.am
--- mysql/storage/heap/Makefile.am 2010-02-04 10:39:55.000000000 -0100
-+++ mysql-new/storage/heap/Makefile.am 2010-03-21 02:24:07.000000000 -0100
++++ mysql-new/storage/heap/Makefile.am 2010-03-21 03:16:42.000000000 -0100
@@ -26,21 +26,20 @@
LDADD =
@@ -736,7 +737,7 @@ diff -ur mysql/storage/heap/Makefile.am mysql-new/storage/heap/Makefile.am
hp_rnext.c hp_rlast.c hp_rprev.c hp_clear.c \
diff -ur mysql/storage/heap/plug.in mysql-new/storage/heap/plug.in
--- mysql/storage/heap/plug.in 2010-02-04 10:39:55.000000000 -0100
-+++ mysql-new/storage/heap/plug.in 2010-03-21 02:24:07.000000000 -0100
++++ mysql-new/storage/heap/plug.in 2010-03-21 03:16:42.000000000 -0100
@@ -1,7 +1,7 @@
MYSQL_STORAGE_ENGINE(heap,no, [Memory Storage Engine],
[Volatile memory based tables])
@@ -748,7 +749,7 @@ diff -ur mysql/storage/heap/plug.in mysql-new/storage/heap/plug.in
diff -ur mysql/storage/innobase/Makefile.am mysql-new/storage/innobase/Makefile.am
--- mysql/storage/innobase/Makefile.am 2010-02-04 10:39:55.000000000 -0100
-+++ mysql-new/storage/innobase/Makefile.am 2010-03-21 02:24:07.000000000 -0100
++++ mysql-new/storage/innobase/Makefile.am 2010-03-21 03:16:42.000000000 -0100
@@ -122,9 +122,9 @@
include/ut0list.ic include/ut0wqueue.h \
include/ha_prototypes.h handler/ha_innodb.h
@@ -777,7 +778,7 @@ diff -ur mysql/storage/innobase/Makefile.am mysql-new/storage/innobase/Makefile.
ha_innodb_la_LDFLAGS= -module -rpath $(pkgplugindir)
diff -ur mysql/storage/innobase/plug.in mysql-new/storage/innobase/plug.in
--- mysql/storage/innobase/plug.in 2010-02-04 10:39:58.000000000 -0100
-+++ mysql-new/storage/innobase/plug.in 2010-03-21 02:24:07.000000000 -0100
++++ mysql-new/storage/innobase/plug.in 2010-03-21 03:16:42.000000000 -0100
@@ -1,8 +1,8 @@
MYSQL_STORAGE_ENGINE(innobase, innodb, [InnoDB Storage Engine],
[Transactional Tables using InnoDB], [max,max-no-ndb])
@@ -791,7 +792,7 @@ diff -ur mysql/storage/innobase/plug.in mysql-new/storage/innobase/plug.in
AC_SUBST(innodb_system_libs)
diff -ur mysql/storage/myisam/Makefile.am mysql-new/storage/myisam/Makefile.am
--- mysql/storage/myisam/Makefile.am 2010-02-04 10:40:05.000000000 -0100
-+++ mysql-new/storage/myisam/Makefile.am 2010-03-21 02:24:07.000000000 -0100
++++ mysql-new/storage/myisam/Makefile.am 2010-03-21 03:16:42.000000000 -0100
@@ -20,70 +20,37 @@
INCLUDES = -I$(top_srcdir)/include -I$(top_builddir)/include \
-I$(top_srcdir)/regex \
@@ -883,7 +884,7 @@ diff -ur mysql/storage/myisam/Makefile.am mysql-new/storage/myisam/Makefile.am
mi_rrnd.c mi_scan.c mi_cache.c \
diff -ur mysql/storage/myisam/plug.in mysql-new/storage/myisam/plug.in
--- mysql/storage/myisam/plug.in 2010-02-04 10:40:07.000000000 -0100
-+++ mysql-new/storage/myisam/plug.in 2010-03-21 02:24:07.000000000 -0100
++++ mysql-new/storage/myisam/plug.in 2010-03-21 03:16:42.000000000 -0100
@@ -1,7 +1,6 @@
MYSQL_STORAGE_ENGINE(myisam,no, [MyISAM Storage Engine],
[Traditional non-transactional MySQL tables])
@@ -895,7 +896,7 @@ diff -ur mysql/storage/myisam/plug.in mysql-new/storage/myisam/plug.in
-
diff -ur mysql/storage/myisammrg/Makefile.am mysql-new/storage/myisammrg/Makefile.am
--- mysql/storage/myisammrg/Makefile.am 2010-02-04 10:40:07.000000000 -0100
-+++ mysql-new/storage/myisammrg/Makefile.am 2010-03-21 02:24:07.000000000 -0100
++++ mysql-new/storage/myisammrg/Makefile.am 2010-03-21 03:16:42.000000000 -0100
@@ -20,16 +20,15 @@
INCLUDES = -I$(top_srcdir)/include -I$(top_builddir)/include \
-I$(top_srcdir)/regex \
@@ -918,7 +919,7 @@ diff -ur mysql/storage/myisammrg/Makefile.am mysql-new/storage/myisammrg/Makefil
myrg_rkey.c myrg_rfirst.c myrg_rlast.c myrg_rnext.c \
diff -ur mysql/storage/myisammrg/plug.in mysql-new/storage/myisammrg/plug.in
--- mysql/storage/myisammrg/plug.in 2010-02-04 10:40:07.000000000 -0100
-+++ mysql-new/storage/myisammrg/plug.in 2010-03-21 02:24:07.000000000 -0100
++++ mysql-new/storage/myisammrg/plug.in 2010-03-21 03:16:42.000000000 -0100
@@ -1,6 +1,6 @@
MYSQL_STORAGE_ENGINE(myisammrg,no,[MyISAM MERGE Engine],
[Merge multiple MySQL tables into one])
@@ -929,7 +930,7 @@ diff -ur mysql/storage/myisammrg/plug.in mysql-new/storage/myisammrg/plug.in
MYSQL_PLUGIN_DEPENDS_ON_MYSQL_INTERNALS(myisammrg, [ha_myisammrg.cc])
diff -ur mysql/storage/ndb/config/type_ndbapitest.mk.am mysql-new/storage/ndb/config/type_ndbapitest.mk.am
--- mysql/storage/ndb/config/type_ndbapitest.mk.am 2010-02-04 10:40:08.000000000 -0100
-+++ mysql-new/storage/ndb/config/type_ndbapitest.mk.am 2010-03-21 02:24:07.000000000 -0100
++++ mysql-new/storage/ndb/config/type_ndbapitest.mk.am 2010-03-21 03:16:42.000000000 -0100
@@ -15,9 +15,9 @@
LDADD += $(top_builddir)/storage/ndb/test/src/libNDBT.a \
@@ -945,7 +946,7 @@ diff -ur mysql/storage/ndb/config/type_ndbapitest.mk.am mysql-new/storage/ndb/co
-I$(top_builddir)/include \
diff -ur mysql/storage/ndb/config/type_ndbapitools.mk.am mysql-new/storage/ndb/config/type_ndbapitools.mk.am
--- mysql/storage/ndb/config/type_ndbapitools.mk.am 2010-02-04 10:40:08.000000000 -0100
-+++ mysql-new/storage/ndb/config/type_ndbapitools.mk.am 2010-03-21 02:24:07.000000000 -0100
++++ mysql-new/storage/ndb/config/type_ndbapitools.mk.am 2010-03-21 03:16:42.000000000 -0100
@@ -15,9 +15,9 @@
LDADD += \
@@ -961,7 +962,7 @@ diff -ur mysql/storage/ndb/config/type_ndbapitools.mk.am mysql-new/storage/ndb/c
-I$(top_builddir)/include \
diff -ur mysql/storage/ndb/config/win-libraries mysql-new/storage/ndb/config/win-libraries
--- mysql/storage/ndb/config/win-libraries 2010-02-04 10:40:08.000000000 -0100
-+++ mysql-new/storage/ndb/config/win-libraries 2010-03-21 02:24:07.000000000 -0100
++++ mysql-new/storage/ndb/config/win-libraries 2010-03-21 03:16:42.000000000 -0100
@@ -21,7 +21,7 @@
# the same goes for mysys and strings
lib=$i
@@ -973,7 +974,7 @@ diff -ur mysql/storage/ndb/config/win-libraries mysql-new/storage/ndb/config/win
;;
diff -ur mysql/storage/ndb/src/common/util/Makefile.am mysql-new/storage/ndb/src/common/util/Makefile.am
--- mysql/storage/ndb/src/common/util/Makefile.am 2010-02-04 10:40:13.000000000 -0100
-+++ mysql-new/storage/ndb/src/common/util/Makefile.am 2010-03-21 02:24:07.000000000 -0100
++++ mysql-new/storage/ndb/src/common/util/Makefile.am 2010-03-21 03:16:42.000000000 -0100
@@ -31,9 +31,9 @@
testBitmask_SOURCES = testBitmask.cpp
testBitmask_LDFLAGS = @ndb_bin_am_ldflags@ \
@@ -989,7 +990,7 @@ diff -ur mysql/storage/ndb/src/common/util/Makefile.am mysql-new/storage/ndb/src
rm -f testBitmask.cpp
diff -ur mysql/storage/ndb/src/cw/cpcd/Makefile.am mysql-new/storage/ndb/src/cw/cpcd/Makefile.am
--- mysql/storage/ndb/src/cw/cpcd/Makefile.am 2010-02-04 10:40:14.000000000 -0100
-+++ mysql-new/storage/ndb/src/cw/cpcd/Makefile.am 2010-03-21 02:24:07.000000000 -0100
++++ mysql-new/storage/ndb/src/cw/cpcd/Makefile.am 2010-03-21 03:16:42.000000000 -0100
@@ -19,9 +19,9 @@
LDADD_LOC = \
@@ -1005,7 +1006,7 @@ diff -ur mysql/storage/ndb/src/cw/cpcd/Makefile.am mysql-new/storage/ndb/src/cw/
include $(top_srcdir)/storage/ndb/config/type_util.mk.am
diff -ur mysql/storage/ndb/src/kernel/blocks/backup/Makefile.am mysql-new/storage/ndb/src/kernel/blocks/backup/Makefile.am
--- mysql/storage/ndb/src/kernel/blocks/backup/Makefile.am 2010-02-04 10:40:15.000000000 -0100
-+++ mysql-new/storage/ndb/src/kernel/blocks/backup/Makefile.am 2010-03-21 02:24:07.000000000 -0100
++++ mysql-new/storage/ndb/src/kernel/blocks/backup/Makefile.am 2010-03-21 03:16:42.000000000 -0100
@@ -17,9 +17,9 @@
ndb_print_backup_file_SOURCES = read.cpp
ndb_print_backup_file_LDFLAGS = @ndb_bin_am_ldflags@ \
@@ -1021,7 +1022,7 @@ diff -ur mysql/storage/ndb/src/kernel/blocks/backup/Makefile.am mysql-new/storag
include $(top_srcdir)/storage/ndb/config/type_kernel.mk.am
diff -ur mysql/storage/ndb/src/kernel/blocks/dbdict/Makefile.am mysql-new/storage/ndb/src/kernel/blocks/dbdict/Makefile.am
--- mysql/storage/ndb/src/kernel/blocks/dbdict/Makefile.am 2010-02-04 10:40:15.000000000 -0100
-+++ mysql-new/storage/ndb/src/kernel/blocks/dbdict/Makefile.am 2010-03-21 02:24:07.000000000 -0100
++++ mysql-new/storage/ndb/src/kernel/blocks/dbdict/Makefile.am 2010-03-21 03:16:42.000000000 -0100
@@ -19,17 +19,17 @@
LDADD += \
$(top_builddir)/storage/ndb/src/common/util/libgeneral.la \
@@ -1048,7 +1049,7 @@ diff -ur mysql/storage/ndb/src/kernel/blocks/dbdict/Makefile.am mysql-new/storag
%::SCCS/s.%
diff -ur mysql/storage/ndb/src/kernel/blocks/dbdih/Makefile.am mysql-new/storage/ndb/src/kernel/blocks/dbdih/Makefile.am
--- mysql/storage/ndb/src/kernel/blocks/dbdih/Makefile.am 2010-02-04 10:40:15.000000000 -0100
-+++ mysql-new/storage/ndb/src/kernel/blocks/dbdih/Makefile.am 2010-03-21 02:24:07.000000000 -0100
++++ mysql-new/storage/ndb/src/kernel/blocks/dbdih/Makefile.am 2010-03-21 03:16:42.000000000 -0100
@@ -17,9 +17,9 @@
ndb_print_sys_file_SOURCES = printSysfile.cpp
ndb_print_sys_file_LDFLAGS = @ndb_bin_am_ldflags@ \
@@ -1064,7 +1065,7 @@ diff -ur mysql/storage/ndb/src/kernel/blocks/dbdih/Makefile.am mysql-new/storage
include $(top_srcdir)/storage/ndb/config/common.mk.am
diff -ur mysql/storage/ndb/src/kernel/blocks/dblqh/Makefile.am mysql-new/storage/ndb/src/kernel/blocks/dblqh/Makefile.am
--- mysql/storage/ndb/src/kernel/blocks/dblqh/Makefile.am 2010-02-04 10:40:16.000000000 -0100
-+++ mysql-new/storage/ndb/src/kernel/blocks/dblqh/Makefile.am 2010-03-21 02:24:07.000000000 -0100
++++ mysql-new/storage/ndb/src/kernel/blocks/dblqh/Makefile.am 2010-03-21 03:16:42.000000000 -0100
@@ -23,9 +23,9 @@
ndbd_redo_log_reader_LDFLAGS = @ndb_bin_am_ldflags@ \
@@ -1080,7 +1081,7 @@ diff -ur mysql/storage/ndb/src/kernel/blocks/dblqh/Makefile.am mysql-new/storage
%::SCCS/s.%
diff -ur mysql/storage/ndb/src/kernel/blocks/dbtup/Makefile.am mysql-new/storage/ndb/src/kernel/blocks/dbtup/Makefile.am
--- mysql/storage/ndb/src/kernel/blocks/dbtup/Makefile.am 2010-02-04 10:40:16.000000000 -0100
-+++ mysql-new/storage/ndb/src/kernel/blocks/dbtup/Makefile.am 2010-03-21 02:24:07.000000000 -0100
++++ mysql-new/storage/ndb/src/kernel/blocks/dbtup/Makefile.am 2010-03-21 03:16:42.000000000 -0100
@@ -20,9 +20,9 @@
test_varpage_SOURCES = test_varpage.cpp tuppage.cpp
test_varpage_LDFLAGS = @ndb_bin_am_ldflags@ \
@@ -1096,7 +1097,7 @@ diff -ur mysql/storage/ndb/src/kernel/blocks/dbtup/Makefile.am mysql-new/storage
%::SCCS/s.%
diff -ur mysql/storage/ndb/src/kernel/blocks/Makefile.am mysql-new/storage/ndb/src/kernel/blocks/Makefile.am
--- mysql/storage/ndb/src/kernel/blocks/Makefile.am 2010-02-04 10:40:15.000000000 -0100
-+++ mysql-new/storage/ndb/src/kernel/blocks/Makefile.am 2010-03-21 02:24:07.000000000 -0100
++++ mysql-new/storage/ndb/src/kernel/blocks/Makefile.am 2010-03-21 03:16:42.000000000 -0100
@@ -57,9 +57,9 @@
ndb_print_file_SOURCES = print_file.cpp diskpage.cpp dbtup/tuppage.cpp
ndb_print_file_LDFLAGS = @ndb_bin_am_ldflags@ \
@@ -1112,7 +1113,7 @@ diff -ur mysql/storage/ndb/src/kernel/blocks/Makefile.am mysql-new/storage/ndb/s
include $(top_srcdir)/storage/ndb/config/type_kernel.mk.am
diff -ur mysql/storage/ndb/src/kernel/Makefile.am mysql-new/storage/ndb/src/kernel/Makefile.am
--- mysql/storage/ndb/src/kernel/Makefile.am 2010-02-04 10:40:15.000000000 -0100
-+++ mysql-new/storage/ndb/src/kernel/Makefile.am 2010-03-21 02:24:07.000000000 -0100
++++ mysql-new/storage/ndb/src/kernel/Makefile.am 2010-03-21 03:16:42.000000000 -0100
@@ -53,9 +53,9 @@
$(top_builddir)/storage/ndb/src/mgmapi/libmgmapi.la \
$(top_builddir)/storage/ndb/src/common/portlib/libportlib.la \
@@ -1128,7 +1129,7 @@ diff -ur mysql/storage/ndb/src/kernel/Makefile.am mysql-new/storage/ndb/src/kern
diff -ur mysql/storage/ndb/src/kernel/vm/Makefile.am mysql-new/storage/ndb/src/kernel/vm/Makefile.am
--- mysql/storage/ndb/src/kernel/vm/Makefile.am 2010-02-04 10:40:17.000000000 -0100
-+++ mysql-new/storage/ndb/src/kernel/vm/Makefile.am 2010-03-21 02:24:07.000000000 -0100
++++ mysql-new/storage/ndb/src/kernel/vm/Makefile.am 2010-03-21 03:16:42.000000000 -0100
@@ -65,24 +65,24 @@
ndbd_malloc_impl_test_SOURCES = ndbd_malloc_impl.cpp
ndbd_malloc_impl_test_LDFLAGS = @ndb_bin_am_ldflags@ \
@@ -1165,7 +1166,7 @@ diff -ur mysql/storage/ndb/src/kernel/vm/Makefile.am mysql-new/storage/ndb/src/k
diff -ur mysql/storage/ndb/src/mgmclient/Makefile.am mysql-new/storage/ndb/src/mgmclient/Makefile.am
--- mysql/storage/ndb/src/mgmclient/Makefile.am 2010-02-04 10:40:18.000000000 -0100
-+++ mysql-new/storage/ndb/src/mgmclient/Makefile.am 2010-03-21 02:24:07.000000000 -0100
++++ mysql-new/storage/ndb/src/mgmclient/Makefile.am 2010-03-21 03:16:42.000000000 -0100
@@ -37,9 +37,9 @@
../common/portlib/libportlib.la \
@readline_link@ \
@@ -1181,7 +1182,7 @@ diff -ur mysql/storage/ndb/src/mgmclient/Makefile.am mysql-new/storage/ndb/src/m
ndb_mgm_LDFLAGS = @ndb_bin_am_ldflags@
diff -ur mysql/storage/ndb/src/mgmsrv/Makefile.am mysql-new/storage/ndb/src/mgmsrv/Makefile.am
--- mysql/storage/ndb/src/mgmsrv/Makefile.am 2010-02-04 10:40:18.000000000 -0100
-+++ mysql-new/storage/ndb/src/mgmsrv/Makefile.am 2010-03-21 02:24:07.000000000 -0100
++++ mysql-new/storage/ndb/src/mgmsrv/Makefile.am 2010-03-21 03:16:42.000000000 -0100
@@ -40,9 +40,9 @@
LDADD_LOC = $(top_builddir)/storage/ndb/src/mgmclient/CommandInterpreter.lo \
@@ -1197,7 +1198,7 @@ diff -ur mysql/storage/ndb/src/mgmsrv/Makefile.am mysql-new/storage/ndb/src/mgms
@TERMCAP_LIB@
diff -ur mysql/storage/ndb/src/ndbapi/Makefile.am mysql-new/storage/ndb/src/ndbapi/Makefile.am
--- mysql/storage/ndb/src/ndbapi/Makefile.am 2010-02-04 10:40:18.000000000 -0100
-+++ mysql-new/storage/ndb/src/ndbapi/Makefile.am 2010-03-21 02:24:07.000000000 -0100
++++ mysql-new/storage/ndb/src/ndbapi/Makefile.am 2010-03-21 03:16:42.000000000 -0100
@@ -67,9 +67,9 @@
include $(top_srcdir)/storage/ndb/config/type_ndbapi.mk.am
@@ -1213,7 +1214,7 @@ diff -ur mysql/storage/ndb/src/ndbapi/Makefile.am mysql-new/storage/ndb/src/ndba
%::SCCS/s.%
diff -ur mysql/storage/ndb/test/run-test/Makefile.am mysql-new/storage/ndb/test/run-test/Makefile.am
--- mysql/storage/ndb/test/run-test/Makefile.am 2010-02-04 10:40:22.000000000 -0100
-+++ mysql-new/storage/ndb/test/run-test/Makefile.am 2010-03-21 02:24:07.000000000 -0100
++++ mysql-new/storage/ndb/test/run-test/Makefile.am 2010-03-21 03:16:42.000000000 -0100
@@ -34,9 +34,9 @@
INCLUDES_LOC = -I$(top_srcdir)/storage/ndb/test/include
LDADD_LOC = $(top_builddir)/storage/ndb/test/src/libNDBT.a \
@@ -1229,7 +1230,7 @@ diff -ur mysql/storage/ndb/test/run-test/Makefile.am mysql-new/storage/ndb/test/
-I$(top_srcdir)/ndb/src/mgmsrv \
diff -ur mysql/strings/Makefile.am mysql-new/strings/Makefile.am
--- mysql/strings/Makefile.am 2010-02-04 10:40:23.000000000 -0100
-+++ mysql-new/strings/Makefile.am 2010-03-21 02:24:07.000000000 -0100
++++ mysql-new/strings/Makefile.am 2010-03-21 03:16:42.000000000 -0100
@@ -16,7 +16,7 @@
# This file is public domain and comes with NO WARRANTY of any kind
@@ -1287,7 +1288,7 @@ diff -ur mysql/strings/Makefile.am mysql-new/strings/Makefile.am
# Don't update the files from bitkeeper
diff -ur mysql/strings/strings-x86.s mysql-new/strings/strings-x86.s
--- mysql/strings/strings-x86.s 2010-02-04 10:40:24.000000000 -0100
-+++ mysql-new/strings/strings-x86.s 2010-03-21 02:24:07.000000000 -0100
++++ mysql-new/strings/strings-x86.s 2010-03-21 03:16:42.000000000 -0100
@@ -293,7 +293,7 @@
movl %esp,%ebp
pushl 12(%ebp) # search
@@ -1299,7 +1300,7 @@ diff -ur mysql/strings/strings-x86.s mysql-new/strings/strings-x86.s
jz si_99 # Not found, return NULL
diff -ur mysql/tests/Makefile.am mysql-new/tests/Makefile.am
--- mysql/tests/Makefile.am 2010-02-04 10:40:25.000000000 -0100
-+++ mysql-new/tests/Makefile.am 2010-03-21 02:24:07.000000000 -0100
++++ mysql-new/tests/Makefile.am 2010-03-21 03:16:42.000000000 -0100
@@ -49,11 +49,11 @@
insert_test_SOURCES= insert_test.c
@@ -1317,7 +1318,7 @@ diff -ur mysql/tests/Makefile.am mysql-new/tests/Makefile.am
DEFS = -DMYSQL_CLIENT_NO_THREADS
diff -ur mysql/unittest/mysys/Makefile.am mysql-new/unittest/mysys/Makefile.am
--- mysql/unittest/mysys/Makefile.am 2010-02-04 10:40:25.000000000 -0100
-+++ mysql-new/unittest/mysys/Makefile.am 2010-03-21 02:24:07.000000000 -0100
++++ mysql-new/unittest/mysys/Makefile.am 2010-03-21 03:16:42.000000000 -0100
@@ -17,9 +17,9 @@
AM_CPPFLAGS += -I$(top_srcdir)/include -I$(top_srcdir)/unittest/mytap
@@ -1333,7 +1334,7 @@ diff -ur mysql/unittest/mysys/Makefile.am mysql-new/unittest/mysys/Makefile.am
diff -ur mysql/vio/Makefile.am mysql-new/vio/Makefile.am
--- mysql/vio/Makefile.am 2010-02-04 10:40:25.000000000 -0100
-+++ mysql-new/vio/Makefile.am 2010-03-21 02:24:07.000000000 -0100
++++ mysql-new/vio/Makefile.am 2010-03-21 03:16:42.000000000 -0100
@@ -16,11 +16,12 @@
INCLUDES = -I$(top_builddir)/include -I$(top_srcdir)/include \
$(openssl_includes)