summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--00000_index.txt14
-rw-r--r--01050_all_mariadb_mysql_config_cleanup-5.1.41.patch46
-rw-r--r--15000_all_mariadb_libevent-system_5.1.42.patch92
3 files changed, 152 insertions, 0 deletions
diff --git a/00000_index.txt b/00000_index.txt
index 3118351..3dd61b9 100644
--- a/00000_index.txt
+++ b/00000_index.txt
@@ -103,6 +103,7 @@
@patch 00350_x86_asm-pic-fixes-5.1.41.patch
@ver 5.01.39.00 to 5.01.99.99
@pn mysql
+@pn mariadb
@@ remove page relocations
@@ Most of the original patch has already been accepted by MysQL,
@@ here is the remaining.
@@ -225,6 +226,11 @@
@pn mysql
@@ fix bug #156301 mysql_config wrongly retains too much info from CFLAGS
+@patch 01050_all_mariadb_config_cleanup-5.1.41.patch
+@ver 5.01.39.00 to 5.01.99.99
+@pn mariadb
+@@ fix bug #156301 mysql_config wrongly retains too much info from CFLAGS
+
@patch 02000_all_query-logging-bypass-4.1.19.patch
@ver 4.01.14.00 to 4.01.99.99
@pn mysql
@@ -344,6 +350,7 @@
@patch 07040_all_disable_mybug_9735_test-5.1.41.patch
@ver 5.01.39.00 to 5.01.99.99
@pn mysql
+@pn mariadb
@@ disable a test that fail on longtext field length, the expected value is
@@ three times the returned one, look like a multibyte character related
@@ failure.
@@ -555,12 +562,14 @@
@patch 07250_all_testcase_latin1_fix-5.1.42.patch
@ver 5.01.42.00 to 5.01.99.99
@pn mysql
+@pn mariadb
@@ Latin1 is assumed by the testsuite even with --with-charset=utf8
@@ is passed to configure. Fix mysql_comments test.
@patch 07260_all_testsuite_mtr_latin1_fix-5.1.42.patch
@ver 5.01.42.00 to 5.01.99.99
@pn mysql
+@pn mariadb
@@ Latin1 is assumed by the testsuite even with --with-charset=utf8
@@ is passed to configure. Fix information_schema test.
@@ -1064,3 +1073,8 @@
@pn mysql
@pn mysql-community
@@ GCC4.4 Fixup for Percona Patch
+
+@patch 15000_all_mariadb_libevent-system_5.1.42.patch
+@ver 5.01.39.00 to 5.01.99.99
+@pn mariadb
+@@ Clean up libevent autoconf usage
diff --git a/01050_all_mariadb_mysql_config_cleanup-5.1.41.patch b/01050_all_mariadb_mysql_config_cleanup-5.1.41.patch
new file mode 100644
index 0000000..2c16e1e
--- /dev/null
+++ b/01050_all_mariadb_mysql_config_cleanup-5.1.41.patch
@@ -0,0 +1,46 @@
+--- mysql.old/scripts/mysql_config.sh 2007-01-04 22:35:51.000000000 +0100
++++ mysql.new/scripts/mysql_config.sh 2007-01-04 23:35:31.000000000 +0100
+@@ -123,22 +123,28 @@
+ include="-I$pkgincludedir"
+
+ # Remove some options that a client doesn't have to care about
+-# FIXME until we have a --cxxflags, we need to remove -Xa
+-# and -xstrconst to make --cflags usable for Sun Forte C++
+-# FIXME until we have a --cxxflags, we need to remove -AC99
+-# to make --cflags usable for HP C++ (aCC)
+-for remove in DDBUG_OFF DSAFEMALLOC USAFEMALLOC DSAFE_MUTEX \
+- DPEDANTIC_SAFEMALLOC DUNIV_MUST_NOT_INLINE DFORCE_INIT_OF_VARS \
+- DEXTRA_DEBUG DHAVE_valgrind O 'O[0-9]' 'xO[0-9]' 'W[-A-Za-z]*' \
+- 'mtune=[-A-Za-z0-9]*' 'mcpu=[-A-Za-z0-9]*' 'march=[-A-Za-z0-9]*' \
+- Xa xstrconst "xc99=none" AC99 \
+- unroll2 ip mp restrict
++tmpcflags=""
++for f in $cflags
+ do
+- # The first option we might strip will always have a space before it because
+- # we set -I$pkgincludedir as the first option
+- cflags=`echo "$cflags"|sed -e "s/ -$remove */ /g"`
++ case "${f}" in
++ -DDBUG_OFF) f="" ;;
++ -DSAFEMALLOC) f="" ;;
++ -USAFEMALLOC) f="" ;;
++ -DSAFE_MUTEX) f="" ;;
++ -DPEDANTIC_SAFEMALLOC) f="" ;;
++ -DUNIV_MUST_NOT_INLINE) f="" ;;
++ -DFORCE_INIT_OF_VARS) f="" ;;
++ -DEXTRA_DEBUG) f="" ;;
++ -DHAVE_purify) f="" ;;
++ -[ID]*) tmpcflags="${tmpcflags} ${f}" ;;
++ -[Ll]*)
++ libs="${libs} ${f}"
++ libs_r="${libs_r} ${f}"
++ embedded_libs="${embedded_libs} ${f}"
++ ;;
++ esac
+ done
+-cflags=`echo "$cflags"|sed -e 's/ *\$//'`
++cflags="${tmpcflags# }"
+
+ # Same for --libs(_r)
+ for remove in lmtmalloc static-libcxa i-static static-intel
+
diff --git a/15000_all_mariadb_libevent-system_5.1.42.patch b/15000_all_mariadb_libevent-system_5.1.42.patch
new file mode 100644
index 0000000..8da3de0
--- /dev/null
+++ b/15000_all_mariadb_libevent-system_5.1.42.patch
@@ -0,0 +1,92 @@
+--- config/ac-macros/libevent.m4 2010-01-31 04:17:56.000000000 -0500
++++ config/ac-macros/libevent.m4 2010-01-31 04:17:56.000000000 -0500
+@@ -14,13 +14,6 @@
+
+ libevent_libs="\$(top_builddir)/extra/libevent/libevent.a"
+ libevent_includes="-I\$(top_srcdir)/extra/libevent"
+- libevent_test_option="--mysqld=--thread-handling=pool-of-threads"
+- AC_SUBST(libevent_libs)
+- AC_SUBST(libevent_includes)
+- AC_SUBST(libevent_test_option)
+-
+- AC_DEFINE([HAVE_LIBEVENT], [1], [If we want to use libevent and have connection pooling])
+- AC_MSG_RESULT([using bundled libevent])
+
+ dnl Get the upstream file with the original libevent configure macros.
+ dnl Use builtin include for this, to work around path problems in old versions of aclocal.
+@@ -39,17 +32,64 @@
+
+ AC_CONFIG_FILES(extra/libevent/Makefile)
+
+- AC_MSG_CHECKING(for libevent)
++ AC_MSG_NOTICE([checking what libevent library to use])
++
+ AC_ARG_WITH([libevent],
+- [ --with-libevent use libevent and have connection pooling],
+- [with_libevent=$withval],
+- [with_libevent=no]
+- )
+-
+- if test "$with_libevent" != "no"; then
+- MYSQL_USE_BUNDLED_LIBEVENT
+- else
+- AC_MSG_RESULT([disabled])
++ AC_HELP_STRING([--with-libevent=yes|no|bundled|DIR],
++ [Use libevent and have connection pooling.
++ A location of libevent library can be specified.
++ Given DIR, libevent library is
++ assumed to be in $DIR/lib and header files
++ in $DIR/include.]),
++ [with_libevent=${withval}],
++ [with_libevent=no])
++
++ case "$with_libevent" in
++ "no")
++ with_libevent=disabled
++ ;;
++ "bundled")
++ MYSQL_USE_BUNDLED_LIBEVENT
++ ;;
++ "" | "yes")
++ libevent_includes=""
++ libevent_libs="-levent"
++ AC_CHECK_LIB(event, evutil_socketpair,[with_libevent=system],
++ [with_libevent=bundled])
++ AC_CHECK_HEADER(evutil.h,,[with_libevent=bundled])
++ if test "$with_libevent" = "bundled"; then
++ MYSQL_USE_BUNDLED_LIBEVENT
++ fi
++ ;;
++ *)
++ # Test for libevent using all known library file endings
++ if test \( -f "$with_libevent/lib/libevent.a" -o \
++ -f "$with_libevent/lib/libevent.so" -o \
++ -f "$with_libevent/lib/libevent.sl" -o \
++ -f "$with_libevent/lib/libevent.dylib" \) \
++ -a -f "$with_libevent/include/evutil.h"; then
++ libevent_includes="-I$with_libevent/include"
++ libevent_libs="-L$with_libevent/lib -levent"
++ AC_CHECK_LIB(event, evutil_socketpair,[with_libevent=$with_libevent],
++ [with_libevent=no], [$libevent_libs])
++ else
++ with_libevent=no
++ fi
++ if test "$with_libevent" = "no"; then
++ AC_MSG_ERROR([libevent headers or binaries were not found])
++ fi
++ ;;
++ esac
++ AC_MSG_CHECKING(for libevent)
++ AC_MSG_RESULT([$with_libevent])
++
++ if test "$with_libevent" != "disabled"; then
++ libevent_test_option="--mysqld=--thread-handling=pool-of-threads"
++ AC_SUBST(libevent_libs)
++ AC_SUBST(libevent_includes)
++ AC_SUBST(libevent_test_option)
++ AC_DEFINE([HAVE_LIBEVENT], [1], [If we want to use libevent and have connection pooling])
+ fi
+- AM_CONDITIONAL([HAVE_LIBEVENT], [ test "$with_libevent" != "no" ])
++ AM_CONDITIONAL([HAVE_LIBEVENT], [ test "$with_libevent" != "disabled" ])
+ ])
++