aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-09-06 22:56:50 +0000
committerMike Frysinger <vapier@gentoo.org>2009-09-06 22:56:50 +0000
commitf91f1b0d7f213282ae44cbc7bdd6bde28f11dc35 (patch)
tree3fb7606e3668605715f529f849b75b99d5992cbb /Makefile
parentadd missing dependency on version.h to libdir target to fix parallel build fa... (diff)
downloadnet-tools-f91f1b0d7f213282ae44cbc7bdd6bde28f11dc35.tar.gz
net-tools-f91f1b0d7f213282ae44cbc7bdd6bde28f11dc35.tar.bz2
net-tools-f91f1b0d7f213282ae44cbc7bdd6bde28f11dc35.zip
convert -idirafter to -I
The local include trees no longer need -idirafter semantics, so use the normal -I flags to avoid random cruft on users' systems. This fixes Gentoo #283759 where user had local headers named the same as the net-tools local headers, but the toolchain defaulted to the system paths due to -idirafter.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 7459224..3d87c07 100644
--- a/Makefile
+++ b/Makefile
@@ -112,7 +112,7 @@ endif
NET_LIB = $(NET_LIB_PATH)/lib$(NET_LIB_NAME).a
-CPPFLAGS += -I. -idirafter ./include/ -I$(NET_LIB_PATH)
+CPPFLAGS += -I. -I$(TOPDIR)/include -I$(NET_LIB_PATH)
LDFLAGS += -L$(NET_LIB_PATH)
SUBDIRS = man/ $(NET_LIB_PATH)/