aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-01-28 10:14:46 +0000
committerSam James <sam@gentoo.org>2023-01-28 10:14:46 +0000
commitaa907a42d89ddfd5a7e64d8182a1da35277f2f6e (patch)
treea6144b444a8371a32970316f186d057268518f52 /paxmacho.h
parentmeson.build: release 1.3.7 (diff)
downloadpax-utils-aa907a42d89ddfd5a7e64d8182a1da35277f2f6e.tar.gz
pax-utils-aa907a42d89ddfd5a7e64d8182a1da35277f2f6e.tar.bz2
pax-utils-aa907a42d89ddfd5a7e64d8182a1da35277f2f6e.zip
Make headers standalone (missing includes, prep for clang-tidy)
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'paxmacho.h')
-rw-r--r--paxmacho.h2
1 files changed, 2 insertions, 0 deletions
diff --git a/paxmacho.h b/paxmacho.h
index 48ac854..c32ccbb 100644
--- a/paxmacho.h
+++ b/paxmacho.h
@@ -12,6 +12,8 @@
#ifndef _PAX_MACHO_H
#define _PAX_MACHO_H
+#include <stddef.h>
+
#include "macho.h"
#define MGET(swapped, value) (swapped ? (__typeof__(value))bswap_32(value) : value)