aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gmail.com>2021-02-26 21:26:26 -0700
committerTim Harder <radhermit@gmail.com>2021-02-26 21:26:26 -0700
commit1977a2de1d7e0c815654cf4135d6ba325c0d040a (patch)
tree9f3f37efd1c1b4e17896546035e185e38ece7283 /src/pkgcheck/scripts
parentsetup.py: update caches module location (diff)
downloadpkgcheck-1977a2de1d7e0c815654cf4135d6ba325c0d040a.tar.gz
pkgcheck-1977a2de1d7e0c815654cf4135d6ba325c0d040a.tar.bz2
pkgcheck-1977a2de1d7e0c815654cf4135d6ba325c0d040a.zip
pkgcheck: suppress pkgcore-specific help options
They're still supported for now, just not shown when --help or similar is used.
Diffstat (limited to 'src/pkgcheck/scripts')
-rw-r--r--src/pkgcheck/scripts/pkgcheck.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/pkgcheck/scripts/pkgcheck.py b/src/pkgcheck/scripts/pkgcheck.py
index e5ed3080..ba495ff4 100644
--- a/src/pkgcheck/scripts/pkgcheck.py
+++ b/src/pkgcheck/scripts/pkgcheck.py
@@ -7,7 +7,7 @@ ebuild repositories for various issues.
from pkgcore.util import commandline
argparser = commandline.ArgumentParser(
- description=__doc__, script=(__file__, __name__))
+ description=__doc__, help=False, script=(__file__, __name__))
subparsers = argparser.add_subparsers()
subparsers.add_command('scan')