aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'testdata')
-rw-r--r--testdata/repos/python/dev-lang/pypy/pypy-2.7.7.3.17.ebuild6
-rw-r--r--testdata/repos/python/dev-lang/pypy/pypy-3.10.7.3.17.ebuild (renamed from testdata/repos/python/dev-python/pypy3/pypy-7.3.17.ebuild)2
-rw-r--r--testdata/repos/python/eclass/python-any-r1.eclass2
-rw-r--r--testdata/repos/python/eclass/python-r1.eclass2
-rw-r--r--testdata/repos/python/eclass/python-single-r1.eclass2
5 files changed, 10 insertions, 4 deletions
diff --git a/testdata/repos/python/dev-lang/pypy/pypy-2.7.7.3.17.ebuild b/testdata/repos/python/dev-lang/pypy/pypy-2.7.7.3.17.ebuild
new file mode 100644
index 00000000..36ab208d
--- /dev/null
+++ b/testdata/repos/python/dev-lang/pypy/pypy-2.7.7.3.17.ebuild
@@ -0,0 +1,6 @@
+EAPI=8
+
+DESCRIPTION="Stub ebuild for pypy interpreter"
+HOMEPAGE="https://github.com/pkgcore/pkgcheck"
+LICENSE="BSD"
+SLOT="2.7/1234"
diff --git a/testdata/repos/python/dev-python/pypy3/pypy-7.3.17.ebuild b/testdata/repos/python/dev-lang/pypy/pypy-3.10.7.3.17.ebuild
index 5c7e964e..6d32fa2f 100644
--- a/testdata/repos/python/dev-python/pypy3/pypy-7.3.17.ebuild
+++ b/testdata/repos/python/dev-lang/pypy/pypy-3.10.7.3.17.ebuild
@@ -3,4 +3,4 @@ EAPI=8
DESCRIPTION="Stub ebuild for pypy3 interpreter"
HOMEPAGE="https://github.com/pkgcore/pkgcheck"
LICENSE="BSD"
-SLOT="0/pypy310"
+SLOT="3.10/pypy310-1234"
diff --git a/testdata/repos/python/eclass/python-any-r1.eclass b/testdata/repos/python/eclass/python-any-r1.eclass
index 68c9774c..56aa329c 100644
--- a/testdata/repos/python/eclass/python-any-r1.eclass
+++ b/testdata/repos/python/eclass/python-any-r1.eclass
@@ -21,7 +21,7 @@ _python_set_impls() {
PYTHON_DEPS+=" dev-lang/python:${slot}"
;;
pypy3)
- PYTHON_DEPS+=" dev-python/pypy3:="
+ PYTHON_DEPS+=" >=dev-lang/pypy-3.10:="
;;
esac
done
diff --git a/testdata/repos/python/eclass/python-r1.eclass b/testdata/repos/python/eclass/python-r1.eclass
index e33047ca..0bac0d92 100644
--- a/testdata/repos/python/eclass/python-r1.eclass
+++ b/testdata/repos/python/eclass/python-r1.eclass
@@ -22,7 +22,7 @@ _python_set_impls() {
PYTHON_DEPS+=" python_targets_${i}? ( dev-lang/python:${slot} )"
;;
pypy3)
- PYTHON_DEPS+=" python_targets_${i}? ( dev-python/pypy3:= )"
+ PYTHON_DEPS+=" python_targets_${i}? ( >=dev-lang/pypy-3.10:= )"
;;
esac
done
diff --git a/testdata/repos/python/eclass/python-single-r1.eclass b/testdata/repos/python/eclass/python-single-r1.eclass
index a7049ac0..5a8debca 100644
--- a/testdata/repos/python/eclass/python-single-r1.eclass
+++ b/testdata/repos/python/eclass/python-single-r1.eclass
@@ -22,7 +22,7 @@ _python_set_impls() {
PYTHON_DEPS+=" python_single_target_${i}? ( dev-lang/python:${slot} )"
;;
pypy3)
- PYTHON_DEPS+=" python_single_target_${i}? ( dev-python/pypy3:= )"
+ PYTHON_DEPS+=" python_single_target_${i}? ( >=dev-lang/pypy-3.10:= )"
;;
esac
done