aboutsummaryrefslogtreecommitdiff
path: root/bin
diff options
context:
space:
mode:
authorBrian Harring <ferringb@gmail.com>2015-03-19 11:34:43 -0500
committerBrian Harring <ferringb@gmail.com>2015-03-19 14:56:17 -0500
commit85588eec0ec811b2b402d184fdb7fd4011f52d0c (patch)
treeaaf0a41f84f59ec861be067e0429322dca778299 /bin
parentsetup.py: Drop the pkgcore_ prefixed command naming scheme. (diff)
downloadpkgcore-85588eec0ec811b2b402d184fdb7fd4011f52d0c.tar.gz
pkgcore-85588eec0ec811b2b402d184fdb7fd4011f52d0c.tar.bz2
pkgcore-85588eec0ec811b2b402d184fdb7fd4011f52d0c.zip
Drop PKGCORE_REPO_PATH, add a new pkgcore._const file for installed usage.
During installation, setup.py will now write out a pkgcore._const file holding the pathways that were specified during the install- primarily pathways to get at certain data files, or ebd directories. In the absence of this file, it's assumed the code is being ran from a non installed state- git checkout or release tarball- and defaults to finding that content within the repository. Additionally, pkgcore.const grew a _GET_CONST function; this function pulls in content from pkgcore._const if it exists, allows for interpolation against other const values, and supports pulling the variable out of the environment (if the const allows it); any env access is prefixed with PKGCORE_OVERRIDE_. setup.py test uses this environmental support to override the data path used; very little else should need that sort of support, but it's there. Note: this requires snakeoil 27a76bc or later due to reliance on a new snakeoil.mappings.ProxiedAttrs class.
Diffstat (limited to 'bin')
-rwxr-xr-xbin/pwrapper1
1 files changed, 0 insertions, 1 deletions
diff --git a/bin/pwrapper b/bin/pwrapper
index faffac9fe..f372d5f8c 100755
--- a/bin/pwrapper
+++ b/bin/pwrapper
@@ -14,7 +14,6 @@ import sys
sys.path.insert(1, os.path.dirname(os.path.dirname(os.path.abspath(__file__))))
if __name__ == '__main__':
- os.environ['PKGCORE_REPO_PATH'] = os.path.dirname(os.path.dirname(os.path.realpath(__file__)))
try:
from pkgcore.util import commandline
name = os.path.basename(sys.argv[0]).replace("-", "_")