summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-print/brother-mfc6490cw-lpr/brother-mfc6490cw-lpr-1.1.2_p2.ebuild')
-rw-r--r--net-print/brother-mfc6490cw-lpr/brother-mfc6490cw-lpr-1.1.2_p2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-print/brother-mfc6490cw-lpr/brother-mfc6490cw-lpr-1.1.2_p2.ebuild b/net-print/brother-mfc6490cw-lpr/brother-mfc6490cw-lpr-1.1.2_p2.ebuild
new file mode 100644
index 0000000..bd8df76
--- /dev/null
+++ b/net-print/brother-mfc6490cw-lpr/brother-mfc6490cw-lpr-1.1.2_p2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit rpm
+
+MY_PN="${PN/brother-/}"
+MY_PN="${MY_PN/-lpr/}"
+MY_PV="${PV/_p/-}"
+
+DESCRIPTION="LPR driver for Brother MFC-6490CW"
+HOMEPAGE="http://welcome.solutions.brother.com/bsc/public_s/id/linux/en/download_prn.html"
+SRC_URI="http://www.brother.com/pub/bsc/linux/dlf/${MY_PN}lpr-${MY_PV}.i386.rpm"
+RESTRICT="mirror strip"
+
+LICENSE="Brother"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="|| ( net-print/cups net-print/lprng )
+ app-text/ghostscript-gpl
+ app-text/a2ps"
+DEPEND=""
+
+S="${WORKDIR}"
+
+src_install() {
+ cp -R "${S}"/* "${D}"/ || die "Install failed"
+}