aboutsummaryrefslogtreecommitdiff
path: root/tools
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2022-01-23 20:16:55 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2022-01-23 20:16:55 +0100
commit52f389d43a83b727d08cfd9447f04b5ed7235e05 (patch)
tree660e99252cd6f38c719469771e272b81105982d6 /tools
parentarm64: Unify stage and spec naming (diff)
downloadreleng-52f389d43a83b727d08cfd9447f04b5ed7235e05.tar.gz
releng-52f389d43a83b727d08cfd9447f04b5ed7235e05.tar.bz2
releng-52f389d43a83b727d08cfd9447f04b5ed7235e05.zip
arm64: add desktop stages
Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'tools')
-rw-r--r--tools/catalyst-auto-arm64.conf13
1 files changed, 10 insertions, 3 deletions
diff --git a/tools/catalyst-auto-arm64.conf b/tools/catalyst-auto-arm64.conf
index 0e32bc43..d9d0c37f 100644
--- a/tools/catalyst-auto-arm64.conf
+++ b/tools/catalyst-auto-arm64.conf
@@ -6,10 +6,11 @@ UPLOAD_KEY=/root/.ssh/id_ed25519
SPECS_DIR=${REPO_DIR}/releases/specs/arm64
SUBARCH=`grep subarch $SPECS_DIR/stage1.spec | awk '{print $2}'`
-SETS="musl muslhardened default"
+SETS="openrc systemd musl muslhardened"
-SET_default_SPECS="stage1-openrc.spec stage3-openrc.spec stage1-systemd.spec stage3-systemd.spec"
-SET_default_OPTIONAL_SPECS="installcd-stage1.spec installcd-stage2-minimal.spec"
+SET_openrc_SPECS="stage1-openrc.spec stage3-openrc.spec stage3d-openrc.spec"
+SET_openrc_OPTIONAL_SPECS="installcd-stage1.spec installcd-stage2-minimal.spec"
+SET_systemd_SPECS="stage1-systemd.spec stage3-systemd.spec stage3d-systemd.spec"
SET_musl_SPECS="musl/stage1.spec musl/stage3.spec"
SET_muslhardened_SPECS="musl-hardened/stage1.spec musl-hardened/stage3.spec"
@@ -43,9 +44,15 @@ post_build() {
stage3-openrc.spec)
upload stage3-${SUBARCH}-openrc-${TIMESTAMP}*.xz*
;;
+ stage3d-openrc.spec)
+ upload stage3-${SUBARCH}-desktop-openrc-${TIMESTAMP}*.xz*
+ ;;
stage3-systemd.spec)
upload stage3-${SUBARCH}-systemd-${TIMESTAMP}*.xz*
;;
+ stage3d-systemd.spec)
+ upload stage3-${SUBARCH}-desktop-systemd-${TIMESTAMP}*.xz*
+ ;;
*)
echo "Finished ${spec}"
;;