aboutsummaryrefslogtreecommitdiff
path: root/tools
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-09-26 14:00:39 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-09-26 14:01:31 +0200
commitcfaa37c932e9377f823654b22a90f0231fa2c098 (patch)
tree0e0295a33a8a3a92c7f247f1638721f58cfc447d /tools
parentCopy alpha specs to qemu dir (diff)
downloadreleng-cfaa37c932e9377f823654b22a90f0231fa2c098.tar.gz
releng-cfaa37c932e9377f823654b22a90f0231fa2c098.tar.bz2
releng-cfaa37c932e9377f823654b22a90f0231fa2c098.zip
First version of specs for qemu alpha builds
Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'tools')
-rw-r--r--tools/catalyst-auto-qemu-alpha.conf46
1 files changed, 46 insertions, 0 deletions
diff --git a/tools/catalyst-auto-qemu-alpha.conf b/tools/catalyst-auto-qemu-alpha.conf
new file mode 100644
index 00000000..2a7718dd
--- /dev/null
+++ b/tools/catalyst-auto-qemu-alpha.conf
@@ -0,0 +1,46 @@
+# This is the config file for the catalyst-auto script. It should be pretty
+# self-explanatory.
+
+UPLOAD_USER=alpha
+UPLOAD_KEY=/root/.ssh/id_rsa
+SPECS_DIR=${REPO_DIR}/releases/specs-qemu/alpha
+
+SETS="openrc"
+
+SET_openrc_SPECS="stage1-openrc.spec stage3-openrc.spec"
+SET_openrc_OPTIONAL_SPECS="installcd-stage1.spec installcd-stage2-minimal.spec"
+
+KCONFIG_DIR=${REPO_DIR}/releases/kconfig/alpha
+
+update_symlinks() {
+ # Symlink the latest stages3 to build from
+ local d f
+ for d in "${BUILD_SRCDIR_BASE}/builds/default" ; do
+ pushd "${d}" >/dev/null
+ for f in $(ls stage3*xz | grep -v latest | give_latest_from_dates) ; do
+ local of=$(echo "${f}" | convert_filename)
+ ln -sf "${f}" "${of}"
+ done
+ popd >/dev/null
+ done
+}
+
+post_build() {
+ local set=$1 spec=$2
+
+ pushd "${BUILD_SRCDIR_BASE}/builds/default" >/dev/null
+
+ case ${spec} in
+ installcd-stage2-minimal.spec)
+ upload *-${TIMESTAMP}*.iso*
+ ;;
+ stage3.spec)
+ upload stage3-*${TIMESTAMP}*.xz*
+ ;;
+ *)
+ echo "Finished ${spec}"
+ ;;
+ esac
+
+ popd >/dev/null
+}